aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-08-31 08:32:33 +0800
committerbapt <bapt@FreeBSD.org>2013-08-31 08:32:33 +0800
commitc0dfe266b6cdb135046bc3318c41e490727e285a (patch)
treebd2dadbb23b80c0e52bb04cab69b59f5404abd5f
parent1d6906acb47ec8516d8e2b9676289ebaca7e7a65 (diff)
downloadfreebsd-ports-gnome-c0dfe266b6cdb135046bc3318c41e490727e285a.tar.gz
freebsd-ports-gnome-c0dfe266b6cdb135046bc3318c41e490727e285a.tar.zst
freebsd-ports-gnome-c0dfe266b6cdb135046bc3318c41e490727e285a.zip
Convert USE_GNOME=pkgconfig to USES=pkgconfig
Convert USE_GNOME=gnomehack to USES=pathfix Convert USE_GMAKE to USES=gmake Convert USE_PERL5 to USES=perl5
-rw-r--r--misc/amanda-server/Makefile5
-rw-r--r--misc/podsleuth/Makefile3
-rw-r--r--misc/sword/Makefile3
3 files changed, 4 insertions, 7 deletions
diff --git a/misc/amanda-server/Makefile b/misc/amanda-server/Makefile
index 3456c23df0e6..ed00b3ded1a4 100644
--- a/misc/amanda-server/Makefile
+++ b/misc/amanda-server/Makefile
@@ -20,11 +20,10 @@ SLAVEDIRS= misc/amanda-client
LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
GNU_CONFIGURE= yes
-USE_GNOME= pkgconfig glib20
-USE_GMAKE= yes
+USES= gmake pkgconfig perl5
+USE_GNOME= glib20
USE_OPENSSL= yes
USE_LDCONFIG= yes
-USE_PERL5= yes
CONFIGURE_ARGS= --libexecdir=${PREFIX}/libexec/amanda \
--without-amlibexecdir \
--with-amandahosts --with-fqdn \
diff --git a/misc/podsleuth/Makefile b/misc/podsleuth/Makefile
index 711299837cb9..7b5a2138f4cc 100644
--- a/misc/podsleuth/Makefile
+++ b/misc/podsleuth/Makefile
@@ -20,8 +20,7 @@ RUN_DEPENDS= ${LOCALBASE}/bin/mono:${PORTSDIR}/lang/mono \
CONFIGURE_ARGS+=--with-hal-callouts-dir=${PREFIX}/libexec
LDFLAGS+= -L${LOCALBASE}/lib
GNU_CONFIGURE= yes
-USE_GMAKE= yes
-USE_GNOME= gnomehack pkgconfig
+USES= gmake pkgconfig pathfix
post-patch:
@${REINPLACE_CMD} -e 's|^#!/bin/bash$$|#!/bin/sh|' \
diff --git a/misc/sword/Makefile b/misc/sword/Makefile
index ba26986c282c..b442c26e834d 100644
--- a/misc/sword/Makefile
+++ b/misc/sword/Makefile
@@ -19,8 +19,7 @@ BUILD_DEPENDS= cppunit-config:${PORTSDIR}/devel/cppunit
USE_GCC= any
-USE_GNOME= pkgconfig
-USE_GMAKE= yes
+USES= pkgconfig gmake
GNU_CONFIGURE= yes
USE_AUTOTOOLS= automake autoconf
CONFIGURE_ARGS+= --without-conf --with-zlib