aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2006-08-16 20:51:40 +0800
committeritetcu <itetcu@FreeBSD.org>2006-08-16 20:51:40 +0800
commitc1252202de26ac80833cde0f83a9032bb43fa590 (patch)
treeea2f2e99cf5855a2f53000cbcc85fd0fdd25d681
parent8e2cc874f8f9be0409c790dc323592a8e9c63fbe (diff)
downloadfreebsd-ports-gnome-c1252202de26ac80833cde0f83a9032bb43fa590.tar.gz
freebsd-ports-gnome-c1252202de26ac80833cde0f83a9032bb43fa590.tar.zst
freebsd-ports-gnome-c1252202de26ac80833cde0f83a9032bb43fa590.zip
youtube-dl is a small command-line program for downloading videos
from YouTube.com. WWW: http://www.arrakis.es/~rggi3/youtube-dl/ PR: ports/101912 Submitted by: Pankov Pavel <pankov_p at mail.ru>
-rw-r--r--www/Makefile1
-rw-r--r--www/youtube_dl/Makefile34
-rw-r--r--www/youtube_dl/distinfo3
-rw-r--r--www/youtube_dl/files/patch-youtube-dl8
-rw-r--r--www/youtube_dl/pkg-descr4
5 files changed, 50 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 48d1a473f9db..3a5cdf2cc272 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1133,6 +1133,7 @@
SUBDIR += xulrunner
SUBDIR += yabb
SUBDIR += yaws
+ SUBDIR += youtube_dl
SUBDIR += zerowait-httpd
SUBDIR += ziproxy
SUBDIR += znavigator
diff --git a/www/youtube_dl/Makefile b/www/youtube_dl/Makefile
new file mode 100644
index 000000000000..d4767f8fba03
--- /dev/null
+++ b/www/youtube_dl/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: youtube_dl
+# Date created: 2006-08-12
+# Whom: Pankov Pavel <pankov_p@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= youtube_dl
+PORTVERSION= 2006.08.13
+CATEGORIES= www
+MASTER_SITES= http://www.arrakis.es/~rggi3/youtube-dl/
+DISTFILES= youtube-dl-${PORTVERSION}
+EXTRACT_ONLY=
+
+MAINTAINER= pankov_p@mail.ru
+COMMENT= A program for downloading videos from YouTube.com
+
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+USE_PYTHON= 2.4+
+
+PLIST_FILES= bin/youtube-dl
+
+post-extract:
+ @${CP} ${DISTDIR}/youtube-dl-${PORTVERSION} ${WRKSRC}/youtube-dl
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%PYTHON_CMD%%|${PYTHON_CMD}|g' ${WRKSRC}/youtube-dl
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/youtube-dl ${TARGETDIR}/bin/youtube-dl
+
+.include <bsd.port.mk>
diff --git a/www/youtube_dl/distinfo b/www/youtube_dl/distinfo
new file mode 100644
index 000000000000..0c5a752f94cb
--- /dev/null
+++ b/www/youtube_dl/distinfo
@@ -0,0 +1,3 @@
+MD5 (youtube-dl-2006.08.13) = 383d8aa4f54127c62a0e4d898f77dbff
+SHA256 (youtube-dl-2006.08.13) = 15c1d75183383693d93010767c2baffc8922146fd0939629ef6d2853ca1ab274
+SIZE (youtube-dl-2006.08.13) = 9843
diff --git a/www/youtube_dl/files/patch-youtube-dl b/www/youtube_dl/files/patch-youtube-dl
new file mode 100644
index 000000000000..96338d469f27
--- /dev/null
+++ b/www/youtube_dl/files/patch-youtube-dl
@@ -0,0 +1,8 @@
+--- youtube-dl-orig Fri Aug 11 01:00:08 2006
++++ youtube-dl Sat Aug 12 13:46:38 2006
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!%%PYTHON_CMD%%
+ #
+ # Copyright (c) 2006 Ricardo Garcia Gonzalez
+ #
diff --git a/www/youtube_dl/pkg-descr b/www/youtube_dl/pkg-descr
new file mode 100644
index 000000000000..6ba1ee144dfe
--- /dev/null
+++ b/www/youtube_dl/pkg-descr
@@ -0,0 +1,4 @@
+youtube-dl is a small command-line program for downloading videos
+from YouTube.com.
+
+WWW: http://www.arrakis.es/~rggi3/youtube-dl/