aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormva <mva@FreeBSD.org>2013-12-15 21:21:13 +0800
committermva <mva@FreeBSD.org>2013-12-15 21:21:13 +0800
commitc13734add3c160590504994363d8d1de1e82f351 (patch)
tree65a0bf5cfab18d38189df3a1e076c111a46e8e10
parentc08b80ddd0563ad334a513807780a1b4f0b61e06 (diff)
downloadfreebsd-ports-gnome-c13734add3c160590504994363d8d1de1e82f351.tar.gz
freebsd-ports-gnome-c13734add3c160590504994363d8d1de1e82f351.tar.zst
freebsd-ports-gnome-c13734add3c160590504994363d8d1de1e82f351.zip
- Fix the usage of 'python' to get rid of the implicit lang/python
dependency Reported by: exp-run (PR 184591) Approved by: portmgr (blanket)
-rw-r--r--games/pykawari/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/games/pykawari/Makefile b/games/pykawari/Makefile
index a385c1c0070c..1455034250f7 100644
--- a/games/pykawari/Makefile
+++ b/games/pykawari/Makefile
@@ -34,6 +34,10 @@ NO_STAGE= yes
CFLAGS+= -fPIC
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|shell python|shell ${PYTHON_CMD}|' \
+ ${WRKSRC}/build/src/gcc.mak
+
do-build:
(cd ${WRKSRC}/build/src; CFLAGS="${CFLAGS}" ${GMAKE} -f gcc.mak PYTHONBASE=${PYTHONBASE} PYTHON_VERSION=${PYTHON_VERSION} PTHREAD_LIBS=${PTHREAD_LIBS} CXX=${CXX})