aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorfjoe <fjoe@FreeBSD.org>2003-01-04 06:52:45 +0800
committerfjoe <fjoe@FreeBSD.org>2003-01-04 06:52:45 +0800
commitc14bf483344654abcc28da0d244cbf1647e75f28 (patch)
tree3c3c84cf26ca96e6c51576ce6a30aa0437a001dc
parent560194cfa4b3a995e2f75e91a293a153c2a5a606 (diff)
downloadfreebsd-ports-gnome-c14bf483344654abcc28da0d244cbf1647e75f28.tar.gz
freebsd-ports-gnome-c14bf483344654abcc28da0d244cbf1647e75f28.tar.zst
freebsd-ports-gnome-c14bf483344654abcc28da0d244cbf1647e75f28.zip
- fix compiling when PostgreSQL is not installed before building this port
(old layouts are still supported with -DWITH_OLD_LAYOUT) - use ${LOCALBASE} instead of ${PREFIX} when building with old PostgreSQL layout
-rw-r--r--databases/p5-DBD-Pg-13/Makefile14
-rw-r--r--databases/p5-DBD-Pg/Makefile14
2 files changed, 14 insertions, 14 deletions
diff --git a/databases/p5-DBD-Pg-13/Makefile b/databases/p5-DBD-Pg-13/Makefile
index a841e4c11758..da5dab47fe33 100644
--- a/databases/p5-DBD-Pg-13/Makefile
+++ b/databases/p5-DBD-Pg-13/Makefile
@@ -24,15 +24,15 @@ MAN3= DBD::Pg.3 DBD::dbd-pg.3
.include <bsd.port.mk>
-.if exists(${LOCALBASE}/bin/pg_config)
-PG_CONFIG= ${LOCALBASE}/bin/pg_config
-.elif exists(${LOCALBASE}/pgsql/bin/pg_config)
+.if defined(WITH_OLD_LAYOUT)
+CONFIGURE_ENV+= POSTGRES_INCLUDE=${LOCALBASE}/include/pgsql \
+ POSTGRES_LIB=${LOCALBASE}/lib
+.else
+.if exists(${LOCALBASE}/pgsql/bin/pg_config)
PG_CONFIG= ${LOCALBASE}/pgsql/bin/pg_config
+.else
+PG_CONFIG= ${LOCALBASE}/bin/pg_config
.endif
-.if defined(PG_CONFIG)
CONFIGURE_ENV+= POSTGRES_INCLUDE=`${PG_CONFIG} --includedir` \
POSTGRES_LIB=`${PG_CONFIG} --libdir`
-.else
-CONFIGURE_ENV+= POSTGRES_INCLUDE=${PREFIX}/include/pgsql \
- POSTGRES_LIB=${PREFIX}/lib
.endif
diff --git a/databases/p5-DBD-Pg/Makefile b/databases/p5-DBD-Pg/Makefile
index a841e4c11758..da5dab47fe33 100644
--- a/databases/p5-DBD-Pg/Makefile
+++ b/databases/p5-DBD-Pg/Makefile
@@ -24,15 +24,15 @@ MAN3= DBD::Pg.3 DBD::dbd-pg.3
.include <bsd.port.mk>
-.if exists(${LOCALBASE}/bin/pg_config)
-PG_CONFIG= ${LOCALBASE}/bin/pg_config
-.elif exists(${LOCALBASE}/pgsql/bin/pg_config)
+.if defined(WITH_OLD_LAYOUT)
+CONFIGURE_ENV+= POSTGRES_INCLUDE=${LOCALBASE}/include/pgsql \
+ POSTGRES_LIB=${LOCALBASE}/lib
+.else
+.if exists(${LOCALBASE}/pgsql/bin/pg_config)
PG_CONFIG= ${LOCALBASE}/pgsql/bin/pg_config
+.else
+PG_CONFIG= ${LOCALBASE}/bin/pg_config
.endif
-.if defined(PG_CONFIG)
CONFIGURE_ENV+= POSTGRES_INCLUDE=`${PG_CONFIG} --includedir` \
POSTGRES_LIB=`${PG_CONFIG} --libdir`
-.else
-CONFIGURE_ENV+= POSTGRES_INCLUDE=${PREFIX}/include/pgsql \
- POSTGRES_LIB=${PREFIX}/lib
.endif