aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-04-05 12:36:58 +0800
committeryuri <yuri@FreeBSD.org>2018-04-05 12:36:58 +0800
commitc1c1eb532141ba7608ffcc444621cdbd23f97b02 (patch)
treeba5b9195af0f06e0b58afe3ea5f38bc54ad3bb32
parent68e214090245ddbecd137c29b235664666782b93 (diff)
downloadfreebsd-ports-gnome-c1c1eb532141ba7608ffcc444621cdbd23f97b02.tar.gz
freebsd-ports-gnome-c1c1eb532141ba7608ffcc444621cdbd23f97b02.tar.zst
freebsd-ports-gnome-c1c1eb532141ba7608ffcc444621cdbd23f97b02.zip
New port: net-mgmt/py-pyeapi: Python client for Arista eAPI
PR: 227078 Submitted by: Kai <freebsd_ports@k-worx.org>
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/py-pyeapi/Makefile21
-rw-r--r--net-mgmt/py-pyeapi/distinfo3
-rw-r--r--net-mgmt/py-pyeapi/pkg-descr12
4 files changed, 37 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index d3ec127a577e..908fbde2136f 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -315,6 +315,7 @@
SUBDIR += py-ncclient
SUBDIR += py-pdagent
SUBDIR += py-pyang
+ SUBDIR += py-pyeapi
SUBDIR += py-pynsca
SUBDIR += py-pysmi
SUBDIR += py-pyzabbix
diff --git a/net-mgmt/py-pyeapi/Makefile b/net-mgmt/py-pyeapi/Makefile
new file mode 100644
index 000000000000..7ff5b15e2b31
--- /dev/null
+++ b/net-mgmt/py-pyeapi/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= pyeapi
+DISTVERSION= 0.8.2
+CATEGORIES= net-mgmt python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= freebsd_ports@k-worx.org
+COMMENT= Python client for Arista eAPI
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}netaddr>0:net/py-netaddr@${FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/py-pyeapi/distinfo b/net-mgmt/py-pyeapi/distinfo
new file mode 100644
index 000000000000..6acb6ce29652
--- /dev/null
+++ b/net-mgmt/py-pyeapi/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1522340692
+SHA256 (pyeapi-0.8.2.tar.gz) = 5be222c290e9e14827ee15541f0e61e290e0223bdead6151233aa7baa5b1b3c8
+SIZE (pyeapi-0.8.2.tar.gz) = 133732
diff --git a/net-mgmt/py-pyeapi/pkg-descr b/net-mgmt/py-pyeapi/pkg-descr
new file mode 100644
index 000000000000..48cfdd63f760
--- /dev/null
+++ b/net-mgmt/py-pyeapi/pkg-descr
@@ -0,0 +1,12 @@
+The Python library for Arista's eAPI command API implementation provides a
+client API work using eAPI and communicating with EOS nodes. The Python
+library can be used to communicate with EOS either locally (on-box) or remotely
+(off-box). It uses a standard INI-style configuration file to specify one or
+more nodes and connection properties.
+
+The pyeapi library also provides an API layer for building native Python
+objects to interact with the destination nodes. The API layer is a convenient
+implementation for working with the EOS configuration and is extensible for
+developing custom implementations.
+
+WWW: https://github.com/arista-eosplus/pyeapi