aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2008-03-07 18:32:51 +0800
committerpav <pav@FreeBSD.org>2008-03-07 18:32:51 +0800
commitc20df281733d15f65258f5d082c646cfa9565981 (patch)
tree0c240bb22f9bf6eca24a54d2b562a51de7c176a6
parent22865c41628cf65a59f8da27379a0262efe5b4df (diff)
downloadfreebsd-ports-gnome-c20df281733d15f65258f5d082c646cfa9565981.tar.gz
freebsd-ports-gnome-c20df281733d15f65258f5d082c646cfa9565981.tar.zst
freebsd-ports-gnome-c20df281733d15f65258f5d082c646cfa9565981.zip
- Add option to accept Linux science applications
Requested by: marck
-rw-r--r--net/boinc-client/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/net/boinc-client/Makefile b/net/boinc-client/Makefile
index 7e2e18c4ecd4..774dd5987b2e 100644
--- a/net/boinc-client/Makefile
+++ b/net/boinc-client/Makefile
@@ -37,7 +37,8 @@ CXXFLAGS:= ${CXXFLAGS:N-O*:N-f*} -O3
CFLAGS:= ${CFLAGS:N-O*:N-f*} -O3
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" CXXFLAGSS="${CXXFLAGS}" CFLAGS="${CFLAGS}"
-OPTIONS= X11 "Build Boinc Manager GUI" on
+OPTIONS= X11 "Build Boinc Manager GUI" on \
+ ALT "Accept Linux science applications" off
.include <bsd.port.pre.mk>
@@ -46,22 +47,22 @@ USE_XLIB= yes
USE_WX= 2.6+
WX_CONF_ARGS= absolute
CPPFLAGS+= -I${X11BASE}/include
-.else
-CONFIGURE_ARGS+= --with-wx-config=false --without-x
-.endif
-.if !defined(WITHOUT_X11)
USE_ICONV= yes
LIB_DEPENDS+= jpeg:${PORTSDIR}/graphics/jpeg \
glut:${PORTSDIR}/graphics/libglut
-.endif
-.if !defined(WITHOUT_X11)
PLIST_SUB+= BOINC_GUI=""
.else
+CONFIGURE_ARGS+= --with-wx-config=false --without-x
PLIST_SUB+= BOINC_GUI="@comment "
.endif
+.if defined(WITH_ALT)
+CONFIGURE_ARGS+=--with-boinc-alt-platform=i686-pc-linux-gnu
+USE_LINUX= yes
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|gui_rpc_auth.cfg|${BOINC_HOME}/gui_rpc_auth.cfg|g' \
${WRKSRC}/client/file_names.h ${WRKSRC}/lib/boinc_cmd.C \