aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-06-23 21:22:22 +0800
committerjylefort <jylefort@FreeBSD.org>2005-06-23 21:22:22 +0800
commitc20ef7101ffeab4e04ee80863c0078a8ddc19232 (patch)
tree41f8be752cd836b4021dab91a538749051c50f12
parentf1d746f516ac325edd5434f6be595a8f1d09b52f (diff)
downloadfreebsd-ports-gnome-c20ef7101ffeab4e04ee80863c0078a8ddc19232.tar.gz
freebsd-ports-gnome-c20ef7101ffeab4e04ee80863c0078a8ddc19232.tar.zst
freebsd-ports-gnome-c20ef7101ffeab4e04ee80863c0078a8ddc19232.zip
- Fix compilation of the milter interface
- Unconditionally define PORTDOCS, as bsd.port.mk now tests ${NOPORTDOCS}
-rw-r--r--security/clamav-devel/Makefile2
-rw-r--r--security/clamav-devel/files/patch-configure.in15
2 files changed, 12 insertions, 5 deletions
diff --git a/security/clamav-devel/Makefile b/security/clamav-devel/Makefile
index cb7a77d80292..48c992864573 100644
--- a/security/clamav-devel/Makefile
+++ b/security/clamav-devel/Makefile
@@ -40,9 +40,7 @@ USE_RC_SUBR= yes
PKGINSTALL= ${WRKDIR}/pkg-install
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
-.if !defined(NOPORTDOCS)
PORTDOCS= NEWS ChangeLog html
-.endif
DBDIR= /var/db/clamav
LOGDIR= /var/log/clamav
diff --git a/security/clamav-devel/files/patch-configure.in b/security/clamav-devel/files/patch-configure.in
index 2c383f683861..cd63667cc63d 100644
--- a/security/clamav-devel/files/patch-configure.in
+++ b/security/clamav-devel/files/patch-configure.in
@@ -1,6 +1,6 @@
---- configure.in.o Mon Jan 10 20:13:18 2005
-+++ configure.in Mon Jan 10 20:13:42 2005
-@@ -360,9 +360,6 @@
+--- configure.in.orig Tue Jun 14 00:41:54 2005
++++ configure.in Thu Jun 23 15:14:13 2005
+@@ -387,9 +387,6 @@
;;
freebsd*)
if test "$have_pthreads" = "yes"; then
@@ -10,3 +10,12 @@
TH_SAFE="-thread-safe"
AC_DEFINE(CL_THREAD_SAFE,1,[thread safe])
AC_DEFINE(_REENTRANT,1,[thread safe])
+@@ -732,7 +729,7 @@
+
+ AC_ARG_ENABLE(gethostbyname_r,
+ [ --disable-gethostbyname_r disable support for gethostbyname_r],
+-disable_gethostbyname_r=$enableval,)
++test $enableval = yes && disable_gethostbyname_r=no || disable_gethostbyname_r=yes,)
+
+ if test "$disable_gethostbyname_r" = "yes"; then
+ AC_MSG_RESULT(support disabled)