aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsbruno <sbruno@FreeBSD.org>2016-06-14 03:12:50 +0800
committersbruno <sbruno@FreeBSD.org>2016-06-14 03:12:50 +0800
commitc2bf9797ceed7d84d1776c054abb9ee0a0080266 (patch)
tree8af3b8f5a5ff107ca28af078853093555cf8476f
parent12049909adb54e05f898a9f2719324d6664a1cff (diff)
downloadfreebsd-ports-gnome-c2bf9797ceed7d84d1776c054abb9ee0a0080266.tar.gz
freebsd-ports-gnome-c2bf9797ceed7d84d1776c054abb9ee0a0080266.tar.zst
freebsd-ports-gnome-c2bf9797ceed7d84d1776c054abb9ee0a0080266.zip
Use correct ELF magic to run powerpc64 binaries.
PR: 209983 Submitted by: jbeich
-rw-r--r--emulators/qemu-sbruno/Makefile1
-rw-r--r--emulators/qemu-sbruno/files/qemu_user_static.in2
2 files changed, 2 insertions, 1 deletions
diff --git a/emulators/qemu-sbruno/Makefile b/emulators/qemu-sbruno/Makefile
index ab6279ba91f5..a8728a23576f 100644
--- a/emulators/qemu-sbruno/Makefile
+++ b/emulators/qemu-sbruno/Makefile
@@ -3,6 +3,7 @@
PORTNAME= qemu
PORTVERSION= 2.6.50.g20160611
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= GH \
LOCAL/nox:dtc \
diff --git a/emulators/qemu-sbruno/files/qemu_user_static.in b/emulators/qemu-sbruno/files/qemu_user_static.in
index ff47b6bec281..de00cd2effd7 100644
--- a/emulators/qemu-sbruno/files/qemu_user_static.in
+++ b/emulators/qemu-sbruno/files/qemu_user_static.in
@@ -98,7 +98,7 @@ list_cmd="${BINMISCCTL} list"
interpreter=${QEMU_DIR}/${QEMU_PREFIX}ppc64${QEMU_SUFFIX}
if [ -x "${interpreter}" ]; then
${BINMISCCTL} add powerpc64 --interpreter "${interpreter}" \
- --magic "\x7f\x45\x4c\x46\x01\x02\x01\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x02\x00\x15" \
+ --magic "\x7f\x45\x4c\x46\x02\x02\x01\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x02\x00\x15" \
--mask "\xff\xff\xff\xff\xff\xff\xff\x00\xff\xff\xff\xff\xff\xff\xff\xff\xff\xfe\xff\xff" \
--size 20 --set-enabled
else