aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2001-09-18 02:09:58 +0800
committerknu <knu@FreeBSD.org>2001-09-18 02:09:58 +0800
commitc3472ec2106c6cbb189cd1d5968a97b852bf9089 (patch)
tree589d78957fac146e84b44667b560630f3e651243
parentc97509cb800059e3a20d77a1178ccb9bbd7a2375 (diff)
downloadfreebsd-ports-gnome-c3472ec2106c6cbb189cd1d5968a97b852bf9089.tar.gz
freebsd-ports-gnome-c3472ec2106c6cbb189cd1d5968a97b852bf9089.tar.zst
freebsd-ports-gnome-c3472ec2106c6cbb189cd1d5968a97b852bf9089.zip
Remove ruby_static from RUN_DEPENDS.
Now that RUBY_ARCH has been changed not to include a minor version of the system, you no longer need to have ruby_s in order to cope with the migration problem with a minor system upgrade like 4.3 -> 4.4. You will need ruby_static only if you are going to do a major upgrade of your system like 4.3 -> 5.0.
-rw-r--r--ports-mgmt/portupgrade-devel/Makefile3
-rw-r--r--ports-mgmt/portupgrade/Makefile3
-rw-r--r--sysutils/portupgrade-devel/Makefile3
-rw-r--r--sysutils/portupgrade/Makefile3
4 files changed, 4 insertions, 8 deletions
diff --git a/ports-mgmt/portupgrade-devel/Makefile b/ports-mgmt/portupgrade-devel/Makefile
index e501497d2a60..0b838504ebd6 100644
--- a/ports-mgmt/portupgrade-devel/Makefile
+++ b/ports-mgmt/portupgrade-devel/Makefile
@@ -21,8 +21,7 @@ MAINTAINER= knu@FreeBSD.org
RUN_DEPENDS= ${RUBY_SITELIBDIR}/optparse.rb:${PORTSDIR}/devel/ruby-optparse \
${RUBY_SITEARCHLIBDIR}/fnmatch.so:${PORTSDIR}/devel/ruby-fnmatch \
${RUBY_SITELIBDIR}/uri.rb:${PORTSDIR}/net/ruby-uri \
- ${LOCALBASE}/sbin/pkg_tarup:${PORTSDIR}/misc/pkg_tarup \
- ${LOCALBASE}/bin/ruby_s:${PORTSDIR}/lang/ruby_static
+ ${LOCALBASE}/sbin/pkg_tarup:${PORTSDIR}/misc/pkg_tarup
USE_RUBY= yes
diff --git a/ports-mgmt/portupgrade/Makefile b/ports-mgmt/portupgrade/Makefile
index e501497d2a60..0b838504ebd6 100644
--- a/ports-mgmt/portupgrade/Makefile
+++ b/ports-mgmt/portupgrade/Makefile
@@ -21,8 +21,7 @@ MAINTAINER= knu@FreeBSD.org
RUN_DEPENDS= ${RUBY_SITELIBDIR}/optparse.rb:${PORTSDIR}/devel/ruby-optparse \
${RUBY_SITEARCHLIBDIR}/fnmatch.so:${PORTSDIR}/devel/ruby-fnmatch \
${RUBY_SITELIBDIR}/uri.rb:${PORTSDIR}/net/ruby-uri \
- ${LOCALBASE}/sbin/pkg_tarup:${PORTSDIR}/misc/pkg_tarup \
- ${LOCALBASE}/bin/ruby_s:${PORTSDIR}/lang/ruby_static
+ ${LOCALBASE}/sbin/pkg_tarup:${PORTSDIR}/misc/pkg_tarup
USE_RUBY= yes
diff --git a/sysutils/portupgrade-devel/Makefile b/sysutils/portupgrade-devel/Makefile
index e501497d2a60..0b838504ebd6 100644
--- a/sysutils/portupgrade-devel/Makefile
+++ b/sysutils/portupgrade-devel/Makefile
@@ -21,8 +21,7 @@ MAINTAINER= knu@FreeBSD.org
RUN_DEPENDS= ${RUBY_SITELIBDIR}/optparse.rb:${PORTSDIR}/devel/ruby-optparse \
${RUBY_SITEARCHLIBDIR}/fnmatch.so:${PORTSDIR}/devel/ruby-fnmatch \
${RUBY_SITELIBDIR}/uri.rb:${PORTSDIR}/net/ruby-uri \
- ${LOCALBASE}/sbin/pkg_tarup:${PORTSDIR}/misc/pkg_tarup \
- ${LOCALBASE}/bin/ruby_s:${PORTSDIR}/lang/ruby_static
+ ${LOCALBASE}/sbin/pkg_tarup:${PORTSDIR}/misc/pkg_tarup
USE_RUBY= yes
diff --git a/sysutils/portupgrade/Makefile b/sysutils/portupgrade/Makefile
index e501497d2a60..0b838504ebd6 100644
--- a/sysutils/portupgrade/Makefile
+++ b/sysutils/portupgrade/Makefile
@@ -21,8 +21,7 @@ MAINTAINER= knu@FreeBSD.org
RUN_DEPENDS= ${RUBY_SITELIBDIR}/optparse.rb:${PORTSDIR}/devel/ruby-optparse \
${RUBY_SITEARCHLIBDIR}/fnmatch.so:${PORTSDIR}/devel/ruby-fnmatch \
${RUBY_SITELIBDIR}/uri.rb:${PORTSDIR}/net/ruby-uri \
- ${LOCALBASE}/sbin/pkg_tarup:${PORTSDIR}/misc/pkg_tarup \
- ${LOCALBASE}/bin/ruby_s:${PORTSDIR}/lang/ruby_static
+ ${LOCALBASE}/sbin/pkg_tarup:${PORTSDIR}/misc/pkg_tarup
USE_RUBY= yes