aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorriggs <riggs@FreeBSD.org>2015-01-18 19:40:01 +0800
committerriggs <riggs@FreeBSD.org>2015-01-18 19:40:01 +0800
commitc43c89f15f32b3a4d833deeab9057c5a200ec066 (patch)
treece211fd80fc1fa32bc3d919b5aa24a6fb93b4778
parent0abdb2a7cf62a6027c813020b537d374c632a14d (diff)
downloadfreebsd-ports-gnome-c43c89f15f32b3a4d833deeab9057c5a200ec066.tar.gz
freebsd-ports-gnome-c43c89f15f32b3a4d833deeab9057c5a200ec066.tar.zst
freebsd-ports-gnome-c43c89f15f32b3a4d833deeab9057c5a200ec066.zip
Handle arch-dependent CFLAGS in Makefile.options because it
should be included by mencoder as well.
-rw-r--r--multimedia/mplayer/Makefile4
-rw-r--r--multimedia/mplayer/Makefile.options3
2 files changed, 3 insertions, 4 deletions
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index 63eb0bb44ed2..b89949dcdc5f 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -60,10 +60,6 @@ CONFIGURE_ARGS+= --disable-arts \
.include "${.CURDIR}/Makefile.options"
-.if ${ARCH} == "armv6"
-CFLAGS_armv6+= -no-integrated-as
-.endif
-
.if ${PORT_OPTIONS:MGUI} && ${PORT_OPTIONS:MX11}
PLIST_SUB+= GMPLAYER=""
DESKTOP_ENTRIES= "MPlayer" "High performance media player" "mplayer" "gmplayer" "" false
diff --git a/multimedia/mplayer/Makefile.options b/multimedia/mplayer/Makefile.options
index eb64b54f0de8..e1a45901177a 100644
--- a/multimedia/mplayer/Makefile.options
+++ b/multimedia/mplayer/Makefile.options
@@ -141,6 +141,9 @@ MAKE_ENV+= COMPILER_PATH=${LOCALBASE}/bin
.endif # ${PORT_OPTIONS:MOTCHAIN}
.endif # defined(WITH_BASE_CLANG)
+.if ${ARCH} == "armv6"
+CFLAGS_armv6+= -no-integrated-as
+.endif
# Extra build options for debugging and optimised CFLAGS
# ======================================================