aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2014-04-18 23:05:06 +0800
committerpawel <pawel@FreeBSD.org>2014-04-18 23:05:06 +0800
commitc49d94d08a85e2f3c0166ed46ba20b8c3a1795a8 (patch)
tree264dd5727c8137b0c82f0e5a702f7a6d6e278e5c
parentc21ef89d9f3aca44c11d0c016694a8aac63e9934 (diff)
downloadfreebsd-ports-gnome-c49d94d08a85e2f3c0166ed46ba20b8c3a1795a8.tar.gz
freebsd-ports-gnome-c49d94d08a85e2f3c0166ed46ba20b8c3a1795a8.tar.zst
freebsd-ports-gnome-c49d94d08a85e2f3c0166ed46ba20b8c3a1795a8.zip
- Fix build on 10+ (use gmake during build)
- Add staging support - Convert to USES=tar:bzip2 - Remove Author tag from pkg-descr, info available on homepage MFH: 2014Q2
-rw-r--r--games/noegnud-nethack/Makefile10
-rw-r--r--games/noegnud-nethack/files/patch-variants::Makefile47
-rw-r--r--games/noegnud-nethack/pkg-descr1
-rw-r--r--games/noegnud-nethack/pkg-plist4
4 files changed, 18 insertions, 44 deletions
diff --git a/games/noegnud-nethack/Makefile b/games/noegnud-nethack/Makefile
index a02fea478e97..b9c7f03b216a 100644
--- a/games/noegnud-nethack/Makefile
+++ b/games/noegnud-nethack/Makefile
@@ -18,18 +18,16 @@ COMMENT= The noeGNUd UI for the vanilla Nethack
RUN_DEPENDS= ${LOCALBASE}/share/${NOEGNUDVERSION}/data/gui:${PORTSDIR}/games/noegnud-data
NOEGNUDVERSION= ${PORTNAME}-0.8.0
-USES= bison gmake
+USES= bison gmake tar:bzip2
USE_GL= yes
WANT_SDL= yes
USE_SDL= sdl image mixer
-USE_BZIP2= yes
WRKSRC= ${WRKDIR}/${DISTNAME}/variants
PATCH_WRKSRC= ${WRKDIR}/${DISTNAME}
ALL_TARGET= nh343
INSTALL_TARGET= install_nh343
MAKE_JOBS_UNSAFE= yes
-NO_STAGE= yes
.include <bsd.port.pre.mk>
pre-everything::
@@ -46,6 +44,12 @@ post-extract:
post-patch:
(cd ${WRKSRC} && ${MAKE} ${NOEGNUDVERSION}-nethack-3.4.3)
@(${PATCH} ${PATCH_ARGS} < ${FILESDIR}/noegnud-nethack.patch)
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|' \
+ -e 's|make|${MAKE_CMD}|' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -E -e 's,ch(grp|own),true,' \
+ -e '/(^VARDIR|ln -s|sed)/! s,(GAME|SHELL|VAR)DIR),DESTDIR)$$(&,g' \
+ -e '/ln -s/ s,SHELLDIR,DESTDIR)$$(&,2' \
+ ${WRKSRC}/${NOEGNUDVERSION}-nethack-3.4.3/sys/unix/Makefile.top
do-configure:
(cd ${WRKSRC} && ${MAKE} ${NOEGNUDVERSION}-nethack-3.4.3/Makefile)
diff --git a/games/noegnud-nethack/files/patch-variants::Makefile b/games/noegnud-nethack/files/patch-variants::Makefile
index 64a0919d8c0d..69fdcd8a736c 100644
--- a/games/noegnud-nethack/files/patch-variants::Makefile
+++ b/games/noegnud-nethack/files/patch-variants::Makefile
@@ -1,51 +1,20 @@
---- variants/Makefile.orig Mon Nov 15 03:02:30 2004
-+++ variants/Makefile Mon Nov 15 03:03:25 2004
-@@ -1,7 +1,6 @@
+--- variants/Makefile.orig 2004-08-23 19:13:51.000000000 +0200
++++ variants/Makefile 2014-04-17 11:20:10.067045121 +0200
+@@ -1,7 +1,7 @@
NOEGNUDVERSION=noegnud-0.8.0
# you __MUST__ change this if you change the prefix for any variants' install !!!!!!!!!!!!!
# although ..... " make -e foo " also works :O ;)
-PREFIX = /usr/local
++PREFIX = %%PREFIX%%
GAMEUID = games
GAMEGRP = bin
CHOWN = chown
-@@ -62,31 +61,31 @@
- install: install_all
-
- install_nh342: nh342
-- make -e -C $(NOEGNUDVERSION)-nethack-3.4.2 install
-+ make -EPREFIX -C $(NOEGNUDVERSION)-nethack-3.4.2 install
+@@ -65,7 +65,7 @@
+ make -e -C $(NOEGNUDVERSION)-nethack-3.4.2 install
install_nh343: nh343
- make -e -C $(NOEGNUDVERSION)-nethack-3.4.3 install
-+ make -EPREFIX -C $(NOEGNUDVERSION)-nethack-3.4.3 install
++ make -C $(NOEGNUDVERSION)-nethack-3.4.3 install
install_se006e4f8: se006e4f8
-- make -e -C $(NOEGNUDVERSION)-slashem-0.0.6E4F8 install
-+ make -EPREFIX -C $(NOEGNUDVERSION)-slashem-0.0.6E4F8 install
-
- install_se007e2: se007e2
-- make -e -C $(NOEGNUDVERSION)-slashem-0.0.7E2 install
-+ make -EPREFIX -C $(NOEGNUDVERSION)-slashem-0.0.7E2 install
-
- install_se007e5: se007e5
-- make -e -C $(NOEGNUDVERSION)-slashem-0.0.7E5 install
-+ make -EPREFIX -C $(NOEGNUDVERSION)-slashem-0.0.7E5 install
-
- install_se007e6: se007e6
-- make -e -C $(NOEGNUDVERSION)-slashem-0.0.7E6 install
-+ make -EPREFIX -C $(NOEGNUDVERSION)-slashem-0.0.7E6 install
-
- install_se007e6f2: se007e6f2
-- make -e -C $(NOEGNUDVERSION)-slashem-0.0.7E6F2 install
-+ make -EPREFIX -C $(NOEGNUDVERSION)-slashem-0.0.7E6F2 install
-
- install_lh001: lh001
-- make -e -C $(NOEGNUDVERSION)-littlehack-0.0.1 install
-+ make -EPREFIX -C $(NOEGNUDVERSION)-littlehack-0.0.1 install
-
- install_nh342-dt: nh342-dt
-- make -e -C $(NOEGNUDVERSION)-nethack-3.4.2-deet install
-+ make -EPREFIX -C $(NOEGNUDVERSION)-nethack-3.4.2-deet install
-
- # data
-
+ make -e -C $(NOEGNUDVERSION)-slashem-0.0.6E4F8 install
diff --git a/games/noegnud-nethack/pkg-descr b/games/noegnud-nethack/pkg-descr
index 291c9048d954..399aa3cc9f3d 100644
--- a/games/noegnud-nethack/pkg-descr
+++ b/games/noegnud-nethack/pkg-descr
@@ -6,5 +6,4 @@ and an outstanding 3D-Mode.
This port installs noeGNUd for the vanilla NetHack.
-Author: Clive Crous
WWW: http://noegnud.sourceforge.net/
diff --git a/games/noegnud-nethack/pkg-plist b/games/noegnud-nethack/pkg-plist
index fc55d1537cfe..65024fcfe325 100644
--- a/games/noegnud-nethack/pkg-plist
+++ b/games/noegnud-nethack/pkg-plist
@@ -1,5 +1,7 @@
bin/noegnud-0.8.0-nethack-3.4.3
bin/noegnud-nethack-3.4.3
+@owner games
+@group bin
share/noegnud-0.8.0/nethack-3.4.3/license
share/noegnud-0.8.0/nethack-3.4.3/logfile
share/noegnud-0.8.0/nethack-3.4.3/nhdat
@@ -7,7 +9,7 @@ share/noegnud-0.8.0/nethack-3.4.3/noegnud-0.8.0-nethack-3.4.3
share/noegnud-0.8.0/nethack-3.4.3/perm
share/noegnud-0.8.0/nethack-3.4.3/record
share/noegnud-0.8.0/nethack-3.4.3/recover
-@exec chown games:bin %D/share/noegnud-0.8.0/nethack-3.4.3
+@exec chown root:wheel %D/share/noegnud-0.8.0
@exec chmod 775 %D/share/noegnud-0.8.0/nethack-3.4.3
@dirrmtry share/noegnud-0.8.0/nethack-3.4.3/save
@dirrmtry share/noegnud-0.8.0/nethack-3.4.3