aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2012-02-12 11:36:18 +0800
committersunpoet <sunpoet@FreeBSD.org>2012-02-12 11:36:18 +0800
commitc518babdf346a19c8204f49b8b876641c98da7e6 (patch)
treed899bbc8b1571113b304bb70eb2a38804b507eb6
parente33beeb2027241a0e42205504968acb0739fbeb8 (diff)
downloadfreebsd-ports-gnome-c518babdf346a19c8204f49b8b876641c98da7e6.tar.gz
freebsd-ports-gnome-c518babdf346a19c8204f49b8b876641c98da7e6.tar.zst
freebsd-ports-gnome-c518babdf346a19c8204f49b8b876641c98da7e6.zip
- Update to 1.2.8
- Add my LOCAL to MASTER_SITES - Pet portlint - Take maintainership Changes: http://trac.xapian.org/wiki/ReleaseOverview/1.2.8
-rw-r--r--databases/xapian-bindings/Makefile19
-rw-r--r--databases/xapian-bindings/distinfo4
-rw-r--r--www/xapian-omega/Makefile37
-rw-r--r--www/xapian-omega/distinfo4
4 files changed, 31 insertions, 33 deletions
diff --git a/databases/xapian-bindings/Makefile b/databases/xapian-bindings/Makefile
index 1461bd90af50..d2bde0cce185 100644
--- a/databases/xapian-bindings/Makefile
+++ b/databases/xapian-bindings/Makefile
@@ -6,25 +6,28 @@
#
PORTNAME= xapian-bindings
-PORTVERSION= 1.2.7
+PORTVERSION= 1.2.8
CATEGORIES= databases
-MASTER_SITES= http://oligarchy.co.uk/xapian/${PORTVERSION}/
+MASTER_SITES= http://oligarchy.co.uk/xapian/${PORTVERSION}/ \
+ LOCAL/sunpoet
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Bindings allowing Xapian to be used from various programming languages
-LIB_DEPENDS= xapian.26:${PORTSDIR}/databases/xapian-core
-
LICENSE= GPLv2
-OPTIONS= PHP "Build PHP binding" on \
- PYTHON "Build Python binding" on \
- RUBY "Build Ruby binding" on
+LIB_DEPENDS= xapian.26:${PORTSDIR}/databases/xapian-core
+
+OPTIONS= PHP "Build PHP binding" on \
+ PYTHON "Build Python binding" on \
+ RUBY "Build Ruby binding" on
CONFIGURE_ARGS= --datarootdir="${DATADIR}" --docdir="${DOCSDIR}" \
--without-csharp --without-java --without-tcl
GNU_CONFIGURE= yes
+.include <bsd.port.options.mk>
+
.if defined(WITHOUT_PHP)
CONFIGURE_ARGS+= --without-php
PLIST_SUB+= BINDING_PHP="@comment "
diff --git a/databases/xapian-bindings/distinfo b/databases/xapian-bindings/distinfo
index 61fd1fb56412..a9f29a1b5b6a 100644
--- a/databases/xapian-bindings/distinfo
+++ b/databases/xapian-bindings/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xapian-bindings-1.2.7.tar.gz) = c9f63ad7a032c260f0617e029327d7b05dd986d91af401032268a9f7b2eabde8
-SIZE (xapian-bindings-1.2.7.tar.gz) = 1447683
+SHA256 (xapian-bindings-1.2.8.tar.gz) = eb740c619c75d288e65a1c2f86faecdca53d44d3f9896bcc080085839887b124
+SIZE (xapian-bindings-1.2.8.tar.gz) = 1462478
diff --git a/www/xapian-omega/Makefile b/www/xapian-omega/Makefile
index 54097e838dfd..b920774afca6 100644
--- a/www/xapian-omega/Makefile
+++ b/www/xapian-omega/Makefile
@@ -3,25 +3,26 @@
# Whom: Henrik Brix Andersen <brix@FreeBSD.org>
#
# $FreeBSD$
+#
PORTNAME= xapian-omega
-PORTVERSION= 1.2.7
+PORTVERSION= 1.2.8
CATEGORIES= www
MASTER_SITES= http://oligarchy.co.uk/xapian/${PORTVERSION}/ \
+ LOCAL/sunpoet
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= CGI search application built on Xapian
-LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre \
- xapian.26:${PORTSDIR}/databases/xapian-core
-
LICENSE= GPLv2
-OPTIONS= ICONV "Enable iconv character set conversion support" on
+LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre \
+ xapian.26:${PORTSDIR}/databases/xapian-core
-CONFIGURE_ENV= PCRE_CONFIG=${LOCALBASE}/bin/pcre-config \
- XAPIAN_CONFIG=${LOCALBASE}/bin/xapian-config
+OPTIONS= ICONV "Enable iconv character set conversion support" on
+CONFIGURE_ENV= PCRE_CONFIG=${LOCALBASE}/bin/pcre-config \
+ XAPIAN_CONFIG=${LOCALBASE}/bin/xapian-config
CPPFLAGS+= -I${LOCALBASE}/include
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib
@@ -29,15 +30,9 @@ USE_LDCONFIG= yes
USE_PERL5= yes
MAN1= omindex.1 scriptindex.1
-
MORE_PORTDOCS= AUTHORS ChangeLog NEWS README TODO
-PORTDOCS= cgiparams.html \
- index.html \
- omegascript.html \
- overview.html \
- quickstart.html \
- scriptindex.html \
- termprefixes.html \
+PORTDOCS= cgiparams.html index.html omegascript.html overview.html \
+ quickstart.html scriptindex.html termprefixes.html \
${MORE_PORTDOCS}
PORTEXAMPLES= omega.conf
@@ -45,16 +40,16 @@ PORTEXAMPLES= omega.conf
.if defined(WITH_ICONV)
USE_ICONV= yes
-CONFIGURE_ARGS+= --with-iconv
+CONFIGURE_ARGS+=--with-iconv
.else
-CONFIGURE_ARGS+= --without-iconv
+CONFIGURE_ARGS+=--without-iconv
.endif
post-patch:
@${REINPLACE_CMD} \
- -e 's|^\(dist_sysconf_DATA\ =\ omega\.conf\)|#\1|' \
- -e 's|^\(pkglibbindir\)\ =.*/bin|\1\ =\ \$$(prefix)/${WWWDIR_REL}/cgi-bin|' \
- ${WRKSRC}/Makefile.in
+ -e '/^dist_sysconf_DATA = /d' \
+ -e '/^pkglibbindir = / s| = .*$$| = ${WWWDIR}/cgi-bin|' \
+ ${WRKSRC}/Makefile.in
.if defined(NOPORTDOCS)
@${REINPLACE_CMD} -e '/^SUBDIRS = / s| docs||' ${WRKSRC}/Makefile.in
.endif
diff --git a/www/xapian-omega/distinfo b/www/xapian-omega/distinfo
index 9a7863efa983..77bce3d673d9 100644
--- a/www/xapian-omega/distinfo
+++ b/www/xapian-omega/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xapian-omega-1.2.7.tar.gz) = 867497e77ea39cde079c0a18aab1106401f6dc8bf9b5e0087d23727db4032786
-SIZE (xapian-omega-1.2.7.tar.gz) = 608920
+SHA256 (xapian-omega-1.2.8.tar.gz) = e7df07d04e8f4ed5364bb3ecc45c0e5388f27404a6f8097bddcf6e7b303a2f8f
+SIZE (xapian-omega-1.2.8.tar.gz) = 615930