aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorroam <roam@FreeBSD.org>2001-01-03 17:27:16 +0800
committerroam <roam@FreeBSD.org>2001-01-03 17:27:16 +0800
commitc5712736d4a4ce5e2ccebfb1a251859a717c3fc4 (patch)
tree754819478c59d7be65122807c2bcb1a031fe6f40
parent979110ca023ae9774c5200089133862475eb5b39 (diff)
downloadfreebsd-ports-gnome-c5712736d4a4ce5e2ccebfb1a251859a717c3fc4.tar.gz
freebsd-ports-gnome-c5712736d4a4ce5e2ccebfb1a251859a717c3fc4.tar.zst
freebsd-ports-gnome-c5712736d4a4ce5e2ccebfb1a251859a717c3fc4.zip
Install a correct pkgIndex.tcl, make the pkg-plist NOPORTDOCS-aware.
PR: 23865 Submitted by: maintainer
-rw-r--r--devel/tcl-memchan/Makefile7
-rw-r--r--devel/tcl-memchan/files/pkgIndex.tcl1
-rw-r--r--devel/tcl-memchan/pkg-plist28
3 files changed, 21 insertions, 15 deletions
diff --git a/devel/tcl-memchan/Makefile b/devel/tcl-memchan/Makefile
index 6ae0acedd059..c2f0207f689e 100644
--- a/devel/tcl-memchan/Makefile
+++ b/devel/tcl-memchan/Makefile
@@ -40,10 +40,15 @@ DDIR= ${PREFIX}/lib/tcl${TCLV}/Trf
do-install:
${MKDIR} ${PREFIX}/lib/tcl${TCLV}/memchan
${INSTALL_DATA} ${WRKSRC}/libmemchan.so.1 ${PREFIX}/lib/
- ${INSTALL_DATA} ${WRKSRC}/pkgIndex.tcl ${PREFIX}/lib/tcl${TCLV}/memchan
+ ${SED} 's@%%PREFIX%%@${PREFIX}@g' < ${FILESDIR}/pkgIndex.tcl \
+ > ${PREFIX}/lib/tcl${TCLV}/memchan/pkgIndex.tcl
.ifndef(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/memchan
${CP} -pR ${WRKSRC}/../doc/html/* ${PREFIX}/share/doc/memchan/
+
+PLIST_SUB+= DOC=''
+.else
+PLIST_SUB+= DOC='@comment '
.endif
.include <bsd.port.mk>
diff --git a/devel/tcl-memchan/files/pkgIndex.tcl b/devel/tcl-memchan/files/pkgIndex.tcl
index e69de29bb2d1..a0753233f032 100644
--- a/devel/tcl-memchan/files/pkgIndex.tcl
+++ b/devel/tcl-memchan/files/pkgIndex.tcl
@@ -0,0 +1 @@
+package ifneeded Memchan 2.1 [list load %%PREFIX%%/lib/libmemchan.so.1]
diff --git a/devel/tcl-memchan/pkg-plist b/devel/tcl-memchan/pkg-plist
index 79e781b3e842..3dc67d882d35 100644
--- a/devel/tcl-memchan/pkg-plist
+++ b/devel/tcl-memchan/pkg-plist
@@ -1,17 +1,17 @@
lib/libmemchan.so.1
lib/tcl%%TCLV%%/memchan/pkgIndex.tcl
@dirrm lib/tcl%%TCLV%%/memchan
-share/doc/memchan/img/up.gif
-share/doc/memchan/memchan_ack.html
-share/doc/memchan/memchan_bdist.html
-share/doc/memchan/memchan_cmac.html
-share/doc/memchan/memchan_cmds.html
-share/doc/memchan/memchan_compile.html
-share/doc/memchan/memchan_ctea.html
-share/doc/memchan/memchan_cunix.html
-share/doc/memchan/memchan_cwin.html
-share/doc/memchan/index.html
-share/doc/memchan/memchan_where.html
-share/doc/memchan/sitemap.html
-@dirrm share/doc/memchan/img/
-@dirrm share/doc/memchan/
+%%DOC%%share/doc/memchan/img/up.gif
+%%DOC%%share/doc/memchan/memchan_ack.html
+%%DOC%%share/doc/memchan/memchan_bdist.html
+%%DOC%%share/doc/memchan/memchan_cmac.html
+%%DOC%%share/doc/memchan/memchan_cmds.html
+%%DOC%%share/doc/memchan/memchan_compile.html
+%%DOC%%share/doc/memchan/memchan_ctea.html
+%%DOC%%share/doc/memchan/memchan_cunix.html
+%%DOC%%share/doc/memchan/memchan_cwin.html
+%%DOC%%share/doc/memchan/index.html
+%%DOC%%share/doc/memchan/memchan_where.html
+%%DOC%%share/doc/memchan/sitemap.html
+%%DOC%%@dirrm share/doc/memchan/img/
+%%DOC%%@dirrm share/doc/memchan/