aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzeising <zeising@FreeBSD.org>2019-09-10 13:56:06 +0800
committerzeising <zeising@FreeBSD.org>2019-09-10 13:56:06 +0800
commitc577d39db3f49396725145dc048a0a1628f477d5 (patch)
tree339da1e9a528986e57a795caa1cb185b8c1e2538
parentdc9cfff57fdedbb7d6476ce1452a41f0ee3fca61 (diff)
downloadfreebsd-ports-gnome-c577d39db3f49396725145dc048a0a1628f477d5.tar.gz
freebsd-ports-gnome-c577d39db3f49396725145dc048a0a1628f477d5.tar.zst
freebsd-ports-gnome-c577d39db3f49396725145dc048a0a1628f477d5.zip
databases/grass7: Remove MOTIF option
Remove the MOTIF option from databases/grass7. This option is a noop, since the configure options it controls doesn't do anything. In addition, this option adds a dependency on graphics/libGLw, which is deprecated. PR: 240133 Approved by: Loic Bartoletti (maintainer)
-rw-r--r--databases/grass7/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/databases/grass7/Makefile b/databases/grass7/Makefile
index 6967b02bcdf6..755b812e4f0a 100644
--- a/databases/grass7/Makefile
+++ b/databases/grass7/Makefile
@@ -3,7 +3,7 @@
PORTNAME= grass
PORTVERSION= 7.6.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= databases geography
MASTER_SITES= https://grass.osgeo.org/%SUBDIR%/ \
http://grass.cict.fr/%SUBDIR%/ \
@@ -79,12 +79,12 @@ PLIST_SUB= GRASS_INST_DIR="${GRASS_INST_DIR}" \
VERSION="${PORTVERSION}" VERS="${PORTVERSION:C/([0-9]+).([0-9]+)(.*)/\1.\2/}" \
VER="${VER}" MAJVER="${PKGNAMESUFFIX}"
-OPTIONS_DEFINE= LAS MOTIF NETCDF PDAL
+OPTIONS_DEFINE= LAS NETCDF PDAL
OPTIONS_MULTI= DB
OPTIONS_MULTI_DB= MYSQL ODBC PGSQL SQLITE
#OPTIONS_SINGLE= BLAS
#OPTIONS_SINGLE_BLAS= ATLAS NETLIB GOTOBLAS OPENBLAS
-OPTIONS_DEFAULT= LAS PDAL PGSQL SQLITE NETLIB MOTIF NETCDF MYSQL ODBC
+OPTIONS_DEFAULT= LAS PDAL PGSQL SQLITE NETLIB NETCDF MYSQL ODBC
OPTIONS_SUB= yes
#BLAS_DESC= BLAS/LAPACK support
@@ -101,9 +101,6 @@ LAS_LIB_DEPENDS= liblas.so:devel/liblas \
libboost_program_options.so:devel/boost-libs \
libboost_thread.so:devel/boost-libs \
libgeotiff.so:graphics/libgeotiff
-MOTIF_USES= motif
-MOTIF_USE= GL=glw
-MOTIF_CONFIGURE_ON= --with-motif --with-glw
MYSQL_USES= mysql
MYSQL_CONFIGURE_ON= --with-mysql \
--with-mysql-includes=${LOCALBASE}/include/mysql \