aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2005-01-12 00:49:42 +0800
committervs <vs@FreeBSD.org>2005-01-12 00:49:42 +0800
commitc6ae5e19e48b64698dc5e01808c54c40cfd99c55 (patch)
tree05b87fb89d61ece856202bdadd2d72c8b364b95d
parent5f43bd6509826e70b100b8b3a410ad6f79cc9ad0 (diff)
downloadfreebsd-ports-gnome-c6ae5e19e48b64698dc5e01808c54c40cfd99c55.tar.gz
freebsd-ports-gnome-c6ae5e19e48b64698dc5e01808c54c40cfd99c55.tar.zst
freebsd-ports-gnome-c6ae5e19e48b64698dc5e01808c54c40cfd99c55.zip
Update to 4.2.2
PR: ports/75841 Submitted by: maintainer
-rw-r--r--devel/spin/Makefile16
-rw-r--r--devel/spin/distinfo4
-rw-r--r--devel/spin/files/patch-make_unix14
-rw-r--r--devel/spin/files/patch-makefile14
-rw-r--r--devel/spin/files/patch-xspin4
5 files changed, 26 insertions, 26 deletions
diff --git a/devel/spin/Makefile b/devel/spin/Makefile
index 9504044b7a62..b9aaac7142df 100644
--- a/devel/spin/Makefile
+++ b/devel/spin/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= spin
-PORTVERSION= 4.2.1
+PORTVERSION= 4.2.2
CATEGORIES= devel
MASTER_SITES= http://spinroot.com/spin/Src/
DISTNAME= spin${PORTVERSION:S/.//g}
@@ -23,7 +23,7 @@ PLIST_SUB+= XSPIN="@comment "
DIST_SUBDIR= spin
WRKSRC= ${WRKDIR}/Src${PORTVERSION}
-MAKEFILE= make_unix
+MAKEFILE= makefile
ALL_TARGET= spin
USE_REINPLACE= yes
@@ -39,23 +39,23 @@ post-extract:
@cd ${WRKDIR}/Test && ${SH} ${WRKDIR}/Test/examples
pre-patch:
- ${TR} -d '\015' < ${WRKDIR}/Xspin4.2/xspin421.tcl \
- > ${WRKDIR}/Xspin4.2/xspin421.tcl.tmp
- ${MV} -f ${WRKDIR}/Xspin4.2/xspin421.tcl.tmp \
- ${WRKDIR}/Xspin4.2/xspin421.tcl
+ ${TR} -d '\015' < ${WRKDIR}/Xspin4.2/xspin422.tcl \
+ > ${WRKDIR}/Xspin4.2/xspin422.tcl.tmp
+ ${MV} -f ${WRKDIR}/Xspin4.2/xspin422.tcl.tmp \
+ ${WRKDIR}/Xspin4.2/xspin422.tcl
post-patch:
@WISH=`(cd ${LOCALBASE}/bin ; ${LS} wish8* ) | tail -1` ; \
if [ -z "$$WISH" ] ; then WISH=wish8.0 ; fi ; \
${REINPLACE_CMD} \
-e "s|%%LOCALBASE%%|${LOCALBASE}|g;" \
- -e "s|%%WISH%%|$$WISH|g" ${WRKDIR}/Xspin4.2/xspin421.tcl
+ -e "s|%%WISH%%|$$WISH|g" ${WRKDIR}/Xspin4.2/xspin422.tcl
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/spin ${PREFIX}/bin
.if !defined(WITHOUT_XSPIN)
${RM} -f ${PREFIX}/bin/xspin
- ${INSTALL_SCRIPT} ${WRKDIR}/Xspin4.2/xspin421.tcl ${PREFIX}/bin/xspin
+ ${INSTALL_SCRIPT} ${WRKDIR}/Xspin4.2/xspin422.tcl ${PREFIX}/bin/xspin
.endif
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}/Doc
diff --git a/devel/spin/distinfo b/devel/spin/distinfo
index b244533800c0..5f794f3000c9 100644
--- a/devel/spin/distinfo
+++ b/devel/spin/distinfo
@@ -1,2 +1,2 @@
-MD5 (spin/spin421.tar.gz) = 279a8c0af87990ef5aa138017f2787f9
-SIZE (spin/spin421.tar.gz) = 323729
+MD5 (spin/spin422.tar.gz) = 858e90506c2521a9714658983f22b6ef
+SIZE (spin/spin422.tar.gz) = 324452
diff --git a/devel/spin/files/patch-make_unix b/devel/spin/files/patch-make_unix
deleted file mode 100644
index e1deddbdf8bd..000000000000
--- a/devel/spin/files/patch-make_unix
+++ /dev/null
@@ -1,14 +0,0 @@
---- make_unix.orig Mon Apr 7 20:30:46 2003
-+++ make_unix Mon Apr 7 20:31:36 2003
-@@ -9,8 +9,9 @@
- # [a more up-to-date book documenting Spin will appear in 2003]
-
- # CC=gcc # or any other ansi compatible c compiler
--CC=cc -g -DNXT # -DNXT enables the X operator in LTL
--CFLAGS=-ansi -D_POSIX_SOURCE # on some systems add: -I/usr/include
-+# CC=cc -g -DNXT # -DNXT enables the X operator in LTL
-+# CFLAGS=-ansi -D_POSIX_SOURCE # on some systems add: -I/usr/include
-+CFLAGS += -DNXT
-
- # on Solaris: add -DSOLARIS
- # on PCs: add -DPC
diff --git a/devel/spin/files/patch-makefile b/devel/spin/files/patch-makefile
new file mode 100644
index 000000000000..5f42427e16b0
--- /dev/null
+++ b/devel/spin/files/patch-makefile
@@ -0,0 +1,14 @@
+--- makefile.orig Tue Jan 4 22:47:37 2005
++++ makefile Tue Jan 4 22:48:24 2005
+@@ -10,8 +10,9 @@
+ # Bug-reports: bugs@spinroot.com
+
+ # CC=gcc # or any other ansi compatible c compiler
+-CC=cc -DNXT # -DNXT enables the X operator in LTL
+-CFLAGS=-ansi -D_POSIX_SOURCE # on some systems add: -I/usr/include
++# CC=cc -DNXT # -DNXT enables the X operator in LTL
++# CFLAGS=-ansi -D_POSIX_SOURCE # on some systems add: -I/usr/include
++CFLAGS += -DNXT
+
+ # on PC: add -DPC to CFLAGS above
+ # on Solaris: add -DSOLARIS
diff --git a/devel/spin/files/patch-xspin b/devel/spin/files/patch-xspin
index f2cb1c282b7c..d2be25f2ffa3 100644
--- a/devel/spin/files/patch-xspin
+++ b/devel/spin/files/patch-xspin
@@ -1,5 +1,5 @@
---- ../Xspin4.2/xspin421.tcl.orig Mon Mar 8 11:27:07 2004
-+++ ../Xspin4.2/xspin421.tcl Mon Mar 8 11:31:09 2004
+--- ../Xspin4.2/xspin422.tcl.orig Mon Mar 8 11:27:07 2004
++++ ../Xspin4.2/xspin422.tcl Mon Mar 8 11:31:09 2004
@@ -1,6 +1,6 @@
-#!/bin/sh
+#!%%LOCALBASE%%/bin/%%WISH%% -f