aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2014-02-17 18:00:57 +0800
committermiwi <miwi@FreeBSD.org>2014-02-17 18:00:57 +0800
commitc6b243635982e12cfd1138b11412e6013631eee0 (patch)
tree92040b75078043ed4fef7d32517d4a68927f5282
parentb6f4b63a9a2970b650afb14255707137dbcc91f4 (diff)
downloadfreebsd-ports-gnome-c6b243635982e12cfd1138b11412e6013631eee0.tar.gz
freebsd-ports-gnome-c6b243635982e12cfd1138b11412e6013631eee0.tar.zst
freebsd-ports-gnome-c6b243635982e12cfd1138b11412e6013631eee0.zip
- Stage support
-rw-r--r--textproc/mxml/Makefile19
1 files changed, 7 insertions, 12 deletions
diff --git a/textproc/mxml/Makefile b/textproc/mxml/Makefile
index 232fa80f1471..83fa09df2e5f 100644
--- a/textproc/mxml/Makefile
+++ b/textproc/mxml/Makefile
@@ -15,32 +15,27 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
USE_AUTOTOOLS= libtool
-USES= pathfix
+USES= pathfix desthack
CONFIGURE_ARGS= --with-docdir=no
USE_LDCONFIG= yes
-MAN1= mxmldoc.1
-MAN3= mxml.3
-
PORTDOCS= *
PLIST_FILES= bin/mxmldoc include/mxml.h \
lib/libmxml.a \
lib/libmxml.so lib/libmxml.so.1 lib/libmxml.so.1.5 \
- libdata/pkgconfig/mxml.pc
-
-NO_STAGE= yes
+ libdata/pkgconfig/mxml.pc \
+ man/man1/mxmldoc.1.gz \
+ man/man3/mxml.3.gz
OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- (cd ${WRKSRC}/doc && ${COPYTREE_SHARE} \* ${DOCSDIR})
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC}/doc && ${COPYTREE_SHARE} \* ${STAGEDIR}${DOCSDIR})
.include <bsd.port.mk>