aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2014-07-28 15:41:22 +0800
committergahr <gahr@FreeBSD.org>2014-07-28 15:41:22 +0800
commitc70d720903eb29c21389dbed170517bf80042244 (patch)
tree3e14bb3d7f80a5292c2469d51507a7b9bc1aacc5
parente60e2c273aeca264aa6ba03d1690853769fba499 (diff)
downloadfreebsd-ports-gnome-c70d720903eb29c21389dbed170517bf80042244.tar.gz
freebsd-ports-gnome-c70d720903eb29c21389dbed170517bf80042244.tar.zst
freebsd-ports-gnome-c70d720903eb29c21389dbed170517bf80042244.zip
- Fix build with gcc 4.8 by fixing include files dependencies [1]
- While at it, install a stripped shared library PR: 192134 [1] Submitted by: gerald
-rw-r--r--math/abacus/Makefile2
-rw-r--r--math/abacus/files/patch-Include-abacus_master.h10
-rw-r--r--math/abacus/files/patch-Include-abacus_sub.h10
3 files changed, 21 insertions, 1 deletions
diff --git a/math/abacus/Makefile b/math/abacus/Makefile
index 4510bddc96af..6857888f4bbc 100644
--- a/math/abacus/Makefile
+++ b/math/abacus/Makefile
@@ -31,7 +31,7 @@ post-patch:
do-install:
${INSTALL_DATA} ${WRKSRC}/lib/linux20-gcc44/libabacus-osi.a ${STAGEDIR}${PREFIX}/lib/libabacus-osi.a
- ${INSTALL_DATA} ${WRKSRC}/lib/linux20-gcc44/libabacus-osi.so ${STAGEDIR}${PREFIX}/lib/libabacus-osi.so.1
+ ${INSTALL_PROGRAM} ${WRKSRC}/lib/linux20-gcc44/libabacus-osi.so ${STAGEDIR}${PREFIX}/lib/libabacus-osi.so.1
${LN} -sf libabacus-osi.so.1 ${STAGEDIR}${PREFIX}/lib/libabacus-osi.so
cd ${WRKSRC}/Include && ${COPYTREE_SHARE} abacus ${STAGEDIR}${PREFIX}/include
diff --git a/math/abacus/files/patch-Include-abacus_master.h b/math/abacus/files/patch-Include-abacus_master.h
new file mode 100644
index 000000000000..d329d099ad26
--- /dev/null
+++ b/math/abacus/files/patch-Include-abacus_master.h
@@ -0,0 +1,10 @@
+--- Include/abacus/master.h.orig 2014-07-28 09:34:10.000000000 +0200
++++ Include/abacus/master.h 2014-07-28 09:38:07.000000000 +0200
+@@ -51,7 +51,6 @@
+ #include "abacus/cputimer.h"
+ #include "abacus/cowtimer.h"
+ #include "abacus/string.h"
+-#include "abacus/standardpool.h"
+
+
+ class ABA_SUB;
diff --git a/math/abacus/files/patch-Include-abacus_sub.h b/math/abacus/files/patch-Include-abacus_sub.h
new file mode 100644
index 000000000000..6092803d1e03
--- /dev/null
+++ b/math/abacus/files/patch-Include-abacus_sub.h
@@ -0,0 +1,10 @@
+--- Include/abacus/sub.h.orig 2014-07-28 09:37:03.000000000 +0200
++++ Include/abacus/sub.h 2014-07-28 09:37:19.000000000 +0200
+@@ -51,6 +51,7 @@
+ #include "abacus/buffer.h"
+ #include "abacus/vartype.h"
+ #include "abacus/cputimer.h"
++#include "abacus/standardpool.h"
+
+ class ABA_LPSUB;
+ class ABA_TAILOFF;