aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2017-01-01 06:07:17 +0800
committermarino <marino@FreeBSD.org>2017-01-01 06:07:17 +0800
commitc70dacbae0138803e4adf83b856cff8c601f703e (patch)
treedcc7583840850e94c4a7e04987aadfcf89470271
parentd80de7b89a9d7781997aacfb525e9776fda6312b (diff)
downloadfreebsd-ports-gnome-c70dacbae0138803e4adf83b856cff8c601f703e.tar.gz
freebsd-ports-gnome-c70dacbae0138803e4adf83b856cff8c601f703e.tar.zst
freebsd-ports-gnome-c70dacbae0138803e4adf83b856cff8c601f703e.zip
shells/sparforte: skip -fstack-protector
The gcc6-aux port doesn't build libssp* to which the stack-protctor switch could try to link. I believe the bdb generator was linking with the base ssp libraries. The linker couldn't find the base ssp libraries on DragonFly, which revealed the issue.
-rw-r--r--shells/sparforte/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/shells/sparforte/Makefile b/shells/sparforte/Makefile
index 778a5ce89da4..c77ef7da57e1 100644
--- a/shells/sparforte/Makefile
+++ b/shells/sparforte/Makefile
@@ -132,6 +132,7 @@ post-patch:
${REINPLACE_CMD} -e "s|BDB4|BDB4 -I${PREFIX}/include/db48|" \
-e "s|-ldb|-L${PREFIX}/lib/db48 -ldb|" \
-e "s|db: db.adb|db: bdb_constants.ads db.adb|" \
+ -e "s| -fstack-protector||" \
${WRKSRC}/src/bdb/GNUmakefile
# fix areadline linkage
${REINPLACE_CMD} -e "s|gnatlink.*|gnatlink rl.ali -L${PREFIX}/lib -lreadline -lhistory|" \