aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2014-02-17 01:22:43 +0800
committersunpoet <sunpoet@FreeBSD.org>2014-02-17 01:22:43 +0800
commitc777d8492fd71a27da549db2e1019fef0680e036 (patch)
treeb9fd288403cd913d211a565cb4437efa83cccc1f
parentf86cbfadd2dbfab1dc1ea72e5084a23c10b1dc6c (diff)
downloadfreebsd-ports-gnome-c777d8492fd71a27da549db2e1019fef0680e036.tar.gz
freebsd-ports-gnome-c777d8492fd71a27da549db2e1019fef0680e036.tar.zst
freebsd-ports-gnome-c777d8492fd71a27da549db2e1019fef0680e036.zip
- Support STAGEDIR
-rw-r--r--devel/bpython/Makefile24
-rw-r--r--devel/bpython/pkg-plist2
2 files changed, 9 insertions, 17 deletions
diff --git a/devel/bpython/Makefile b/devel/bpython/Makefile
index 15e8b54ca3ad..83ffea6b4232 100644
--- a/devel/bpython/Makefile
+++ b/devel/bpython/Makefile
@@ -19,38 +19,28 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pygments>=0:${PORTSDIR}/textproc/py-pygments
OPTIONS_DEFINE= EXAMPLES NLS
OPTIONS_SUB= yes
-NO_STAGE= yes
USE_PYTHON= yes
USE_PYDISTUTILS=easy_install
PYDISTUTILS_BUILD_TARGET= build bdist_egg
-MAN1= bpython.1
-MAN5= bpython-config.5
PORTEXAMPLES= light.theme sample-config sample.theme
NLS_USES= gettext
-.include <bsd.port.options.mk>
-
post-patch:
@${REINPLACE_CMD} -e '/build\/man\/bpython/d; /data\/bpython.desktop/d' ${WRKSRC}/${PYSETUP}
post-install:
- ${INSTALL_MAN} ${WRKSRC}/build/man/bpython.1 ${MANPREFIX}/man/man1/
- ${INSTALL_MAN} ${WRKSRC}/build/man/bpython-config.5 ${MANPREFIX}/man/man5/
- ${INSTALL_DATA} ${WRKSRC}/data/bpython.desktop ${DESKTOPDIR}/
-.if ${PORT_OPTIONS:MEXAMPLES}
- ${MKDIR} ${EXAMPLESDIR}/
- cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTEXAMPLES} ${EXAMPLESDIR}/
-.endif
-.if ${PORT_OPTIONS:MNLS}
+ ${INSTALL_MAN} ${WRKSRC}/build/man/bpython.1 ${STAGEDIR}${PREFIX}/man/man1/
+ ${INSTALL_MAN} ${WRKSRC}/build/man/bpython-config.5 ${STAGEDIR}${PREFIX}/man/man5/
+ ${INSTALL_DATA} ${WRKSRC}/data/bpython.desktop ${STAGEDIR}${DESKTOPDIR}/
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/
+ cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTEXAMPLES} ${STAGEDIR}${EXAMPLESDIR}/
.for lang in it_IT nl_NL
- ${MKDIR} ${PREFIX}/share/locale/${lang}/LC_MESSAGES/
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/locale/${lang}/LC_MESSAGES/
.endfor
.for lang in de es_ES it_IT nl_NL
- ${INSTALL_DATA} ${WRKSRC}/bpython/translations/${lang}/LC_MESSAGES/bpython.mo \
- ${PREFIX}/share/locale/${lang}/LC_MESSAGES/
+ ${INSTALL_DATA} ${WRKSRC}/bpython/translations/${lang}/LC_MESSAGES/bpython.mo ${STAGEDIR}${PREFIX}/share/locale/${lang}/LC_MESSAGES/
.endfor
-.endif
.include <bsd.port.mk>
diff --git a/devel/bpython/pkg-plist b/devel/bpython/pkg-plist
index c1a4b05fa2f6..db74bbbec270 100644
--- a/devel/bpython/pkg-plist
+++ b/devel/bpython/pkg-plist
@@ -103,6 +103,8 @@ bin/bpython-urwid
%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/bpython/urwid.py
%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/bpython/urwid.pyc
%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/bpython/urwid.pyo
+man/man1/bpython.1.gz
+man/man5/bpython-config.5.gz
share/applications/bpython.desktop
%%NLS%%share/locale/de/LC_MESSAGES/bpython.mo
%%NLS%%share/locale/es_ES/LC_MESSAGES/bpython.mo