aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-01-18 17:01:34 +0800
committeredwin <edwin@FreeBSD.org>2003-01-18 17:01:34 +0800
commitc8311315b6f3717b2608d4a720eb108b7353b2bb (patch)
treebc3f88875b3d03fc29bc0bf7142a1aa53b5315ec
parentad767f1482f5088793db749a800842c0b6adbf1c (diff)
downloadfreebsd-ports-gnome-c8311315b6f3717b2608d4a720eb108b7353b2bb.tar.gz
freebsd-ports-gnome-c8311315b6f3717b2608d4a720eb108b7353b2bb.tar.zst
freebsd-ports-gnome-c8311315b6f3717b2608d4a720eb108b7353b2bb.zip
New port: MySQLMan - a web based MySQL database manager written in perl
This port can be useful those, who have to manage MySQL remotely via web, but they don't want to install php for phpMyAdmin. Unfortunately the license is not complete free: You have to download yourself from the original distribution site then you can freely use it, but you cannot redistribute. PR: ports/38958 Submitted by: Janos Mohacsi <janos.mohacsi@bsd.hu>
-rw-r--r--databases/Makefile1
-rw-r--r--databases/mysqlman/Makefile71
-rw-r--r--databases/mysqlman/distinfo1
-rw-r--r--databases/mysqlman/files/patch-mysql.cgi13
-rw-r--r--databases/mysqlman/pkg-comment1
-rw-r--r--databases/mysqlman/pkg-descr11
-rw-r--r--databases/mysqlman/pkg-plist85
7 files changed, 183 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index eb5875bce637..b56311c494ae 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -63,6 +63,7 @@
SUBDIR += mysql2pgsql
SUBDIR += mysql323-client
SUBDIR += mysql323-server
+ SUBDIR += mysqlman
SUBDIR += mysqltcl
SUBDIR += mytop
SUBDIR += namazu2
diff --git a/databases/mysqlman/Makefile b/databases/mysqlman/Makefile
new file mode 100644
index 000000000000..a69c2c3613ef
--- /dev/null
+++ b/databases/mysqlman/Makefile
@@ -0,0 +1,71 @@
+# New ports collection makefile for: mysqlman
+# Date created: 06.06.2002
+# Whom: Janos Mohacsi <janos.mohacsi@bsd.hu>
+#
+# $FreeBSD$
+
+PORTNAME= mysqlman
+PORTVERSION= 1.09
+CATEGORIES= databases www
+MASTER_SITES= #http://www.gossamer-threads.com/scripts/mysqlman/index.htm
+DISTNAME= mysqlman
+
+MAINTAINER= Janos.Mohacsi@bsd.hu
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
+ ${WWW_DIR}:${PORTSDIR}/www/apache13
+
+RESTRICTED= "not redistributable, license agreement required"
+NO_CDROM= ${RESTRICTED}
+NO_PACKAGE= ${RESTRICTED}
+USE_PERL5= yes
+NO_BUILD= yes
+
+# to determine whether apache installed
+WWW_DIR= ${LOCALBASE}/www/
+#install dir of mysqlman
+MYMANDIR= www/mysqlman-${PORTVERSION}
+
+#do the substitution according to the install place
+PLIST_SUB+= MYMANDIR=${MYMANDIR}
+
+#FILES to patch
+f="mysql.cgi"
+
+#Web user
+WEBUSER?= www:www
+
+.include <bsd.port.pre.mk>
+
+.if !exists(${DISTDIR}/${DISTFILES})
+IGNORE= You need to read the license agreement on \
+ http://www.gossamer-threads.com/scripts/mysqlman/index.htm and \
+ download on your own. Once ${DISTFILES} has been downloaded, move \
+ it to ${DISTDIR} and then restart this build
+.endif
+
+do-configure:
+ @${MV} ${WRKSRC}/${f} ${WRKSRC}/${f}.bak && ${SED} <${WRKSRC}/${f}.bak \
+ s+%%PATHPERLBIN%%+${PERL5}+g >${WRKSRC}/${f}
+
+do-install:
+ @${FIND} ${WRKSRC} ! \( -path "*/${f}*" -or -path "*/mysql.cfg" \) | ${XARGS} -n1 ${SH} -c 'if ${TEST} -d $$0; \
+ then ${MKDIR} ${PREFIX}/${MYMANDIR}$${0#${WRKSRC}}; \
+ else ${INSTALL_DATA} $$0 ${PREFIX}/${MYMANDIR}$${0#${WRKSRC}}; fi'
+ @${INSTALL_SCRIPT} ${WRKSRC}/mysql.cgi ${PREFIX}/${MYMANDIR}
+ @if [ -L ${PREFIX}/www/mysqlman ]; then \
+ ${ECHO} "Updating ${PREFIX}/www/mysqlman symbolic link" ; \
+ ${RM} ${PREFIX}/www/mysqlman ; \
+ fi
+ ${LN} -s ${PREFIX}/${MYMANDIR} ${PREFIX}/www/mysqlman
+
+post-install:
+ @${CHOWN} ${WEBUSER} ${PREFIX}/${MYMANDIR}/templates/compiled
+ @${INSTALL_DATA} ${WRKSRC}/mysql.cfg ${PREFIX}/${MYMANDIR}/mysql.cfg.dist
+ @${ECHO} ""
+ @${ECHO} "Sample config installed at \
+ ${PREFIX}/${MYMANDIR}/mysql.cfg.dist"
+ @${ECHO} "Modify to your needs!"
+ @${ECHO} ""
+
+.include <bsd.port.post.mk>
diff --git a/databases/mysqlman/distinfo b/databases/mysqlman/distinfo
new file mode 100644
index 000000000000..9e44b30c342a
--- /dev/null
+++ b/databases/mysqlman/distinfo
@@ -0,0 +1 @@
+MD5 (mysqlman.tar.gz) = 73cea1f037691097091aa0f8b56ea7e5
diff --git a/databases/mysqlman/files/patch-mysql.cgi b/databases/mysqlman/files/patch-mysql.cgi
new file mode 100644
index 000000000000..6a75dad22dba
--- /dev/null
+++ b/databases/mysqlman/files/patch-mysql.cgi
@@ -0,0 +1,13 @@
+*** mysql.cgi.orig Thu Jun 6 20:07:24 2002
+--- mysql.cgi Thu Jun 6 20:08:07 2002
+***************
+*** 1,4 ****
+! #!/usr/bin/perl
+ # ==================================================================
+ # MySQLMan - web based MySQL manager.
+ #
+--- 1,4 ----
+! #!%%PATHPERLBIN%%
+ # ==================================================================
+ # MySQLMan - web based MySQL manager.
+ #
diff --git a/databases/mysqlman/pkg-comment b/databases/mysqlman/pkg-comment
new file mode 100644
index 000000000000..aa7097d3b062
--- /dev/null
+++ b/databases/mysqlman/pkg-comment
@@ -0,0 +1 @@
+MySQLMan is a web based MySQL database manager written in perl
diff --git a/databases/mysqlman/pkg-descr b/databases/mysqlman/pkg-descr
new file mode 100644
index 000000000000..1c8a41099594
--- /dev/null
+++ b/databases/mysqlman/pkg-descr
@@ -0,0 +1,11 @@
+MySQLMan is a web based database manager. It allows you to perform common
+maintenance and administration tasks in Mysql. MySQLMan was based off of
+PHPmyadmin, but written in Perl. It allows you to do common tasks like:
+
+- browse/create/drop databases
+- browse/search/create/drop/alter tables
+- import/export data
+- add/remove/alter table columns
+- add/remove/alter table keys
+
+WWW: http://www.gossamer-threads.com/scripts/mysqlman/index.htm
diff --git a/databases/mysqlman/pkg-plist b/databases/mysqlman/pkg-plist
new file mode 100644
index 000000000000..ae9ae53844d9
--- /dev/null
+++ b/databases/mysqlman/pkg-plist
@@ -0,0 +1,85 @@
+%%MYMANDIR%%/GT/Base.pm
+%%MYMANDIR%%/GT/CGI/EventLoop.pm
+%%MYMANDIR%%/GT/CGI.pm
+%%MYMANDIR%%/GT/Template/Editor.pm
+%%MYMANDIR%%/GT/Template/Parser.pm
+%%MYMANDIR%%/GT/Template.pm
+%%MYMANDIR%%/GT/TempFile.pm
+%%MYMANDIR%%/GT/Date.pm
+%%MYMANDIR%%/GT/Cache.pm
+%%MYMANDIR%%/GT/Dumper.pm
+%%MYMANDIR%%/bases.pm
+%%MYMANDIR%%/README
+%%MYMANDIR%%/html.pl
+%%MYMANDIR%%/mysql.cgi
+%%MYMANDIR%%/mysql.cfg.dist
+%%MYMANDIR%%/constants.pm
+%%MYMANDIR%%/templates/help/col_def.jpg
+%%MYMANDIR%%/templates/help/help_add_col.html
+%%MYMANDIR%%/templates/help/help_browse.html
+%%MYMANDIR%%/templates/help/help_col_def.html
+%%MYMANDIR%%/templates/help/help_col_def_change.html
+%%MYMANDIR%%/templates/help/help_confirm.html
+%%MYMANDIR%%/templates/help/help_create_db.html
+%%MYMANDIR%%/templates/help/help_create_table.html
+%%MYMANDIR%%/templates/help/help_db_list.html
+%%MYMANDIR%%/templates/help/help_demo.html
+%%MYMANDIR%%/templates/help/help_edit.html
+%%MYMANDIR%%/templates/help/help_export.html
+%%MYMANDIR%%/templates/help/help_home.html
+%%MYMANDIR%%/templates/help/help_import.html
+%%MYMANDIR%%/templates/help/help_insert.html
+%%MYMANDIR%%/templates/help/help_login.html
+%%MYMANDIR%%/templates/help/help_login_back.html
+%%MYMANDIR%%/templates/help/insert.jpg
+%%MYMANDIR%%/templates/help/help_login_dbname.html
+%%MYMANDIR%%/templates/help/help_logout.html
+%%MYMANDIR%%/templates/help/help_properties.html
+%%MYMANDIR%%/templates/help/help_rename.html
+%%MYMANDIR%%/templates/help/help_save_search_result.html
+%%MYMANDIR%%/templates/help/help_select.html
+%%MYMANDIR%%/templates/help/help_sql_dump.html
+%%MYMANDIR%%/templates/help/help_sql_monitor.html
+%%MYMANDIR%%/templates/help/help_sqlerr.html
+%%MYMANDIR%%/templates/help/help_table_list.html
+%%MYMANDIR%%/templates/help/help_toolbar.html
+%%MYMANDIR%%/templates/alter_col.html
+%%MYMANDIR%%/templates/confirm.html
+%%MYMANDIR%%/templates/create_field.txt
+%%MYMANDIR%%/templates/create_table.html
+%%MYMANDIR%%/templates/database.html
+%%MYMANDIR%%/templates/demo_prompt.html
+%%MYMANDIR%%/templates/edit.html
+%%MYMANDIR%%/templates/fields_selection.txt
+%%MYMANDIR%%/templates/functions.txt
+%%MYMANDIR%%/templates/header.txt
+%%MYMANDIR%%/templates/insert.html
+%%MYMANDIR%%/templates/login.html
+%%MYMANDIR%%/templates/login_back.html
+%%MYMANDIR%%/templates/login_dbname.html
+%%MYMANDIR%%/templates/logout.html
+%%MYMANDIR%%/templates/message.txt
+%%MYMANDIR%%/templates/op_add_fields.html
+%%MYMANDIR%%/templates/op_create_db.html
+%%MYMANDIR%%/templates/op_create_table.html
+%%MYMANDIR%%/templates/op_export.html
+%%MYMANDIR%%/templates/op_import.html
+%%MYMANDIR%%/templates/op_mysqldump.html
+%%MYMANDIR%%/templates/op_rename_table.html
+%%MYMANDIR%%/templates/op_sql_monitor.html
+%%MYMANDIR%%/templates/page_jump.txt
+%%MYMANDIR%%/templates/property.html
+%%MYMANDIR%%/templates/save_search.html
+%%MYMANDIR%%/templates/show_query.html
+%%MYMANDIR%%/templates/sqlerr.html
+%%MYMANDIR%%/templates/table.html
+%%MYMANDIR%%/templates/table_browse.html
+%%MYMANDIR%%/templates/table_select.html
+www/mysqlman
+@dirrm %%MYMANDIR%%/GT/CGI
+@dirrm %%MYMANDIR%%/GT/Template
+@dirrm %%MYMANDIR%%/GT
+@dirrm %%MYMANDIR%%/templates/help
+@dirrm %%MYMANDIR%%/templates/compiled
+@dirrm %%MYMANDIR%%/templates
+@dirrm %%MYMANDIR%%/