aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorConrad Meyer <cem@FreeBSD.org>2016-07-14 07:10:27 +0800
committerConrad Meyer <cem@FreeBSD.org>2016-07-14 07:10:27 +0800
commitc83b6c4050d70f53764982fa3654df91a26a3603 (patch)
tree8252458c76a811dc330c2982ef81ee1dab80fdd3
parent7553001e1538ac26d2c2245817616f1a8b0bc54e (diff)
downloadfreebsd-ports-gnome-c83b6c4050d70f53764982fa3654df91a26a3603.tar.gz
freebsd-ports-gnome-c83b6c4050d70f53764982fa3654df91a26a3603.tar.zst
freebsd-ports-gnome-c83b6c4050d70f53764982fa3654df91a26a3603.zip
elfutils: Revert installing elfutils' elf.h
This conflicts with base elf.h. Instead, add needed types (and perhaps numeric definitions) to base elf.h. Sponsored by: EMC / Isilon Storage Division
-rw-r--r--devel/elfutils/Makefile3
-rw-r--r--devel/elfutils/files/patch-libelf_Makefile.am20
-rw-r--r--devel/elfutils/files/patch-libelf_libelf.h9
-rw-r--r--devel/elfutils/pkg-plist1
4 files changed, 1 insertions, 32 deletions
diff --git a/devel/elfutils/Makefile b/devel/elfutils/Makefile
index 63b17f1b05fd..72c9efc29813 100644
--- a/devel/elfutils/Makefile
+++ b/devel/elfutils/Makefile
@@ -3,7 +3,7 @@
PORTNAME= elfutils
PORTVERSION= 0.163
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= https://fedorahosted.org/releases/e/l/elfutils/$(PORTVERSION)/
@@ -39,6 +39,5 @@ post-patch:
$(LOCALBASE)/share/gnulib/lib/obstack.h \
$(LOCALBASE)/share/gnulib/lib/obstack_printf.c \
$(WRKSRC)/lib
- @cd $(WRKSRC) && ${LN} -s libelf elfutils
.include <bsd.port.mk>
diff --git a/devel/elfutils/files/patch-libelf_Makefile.am b/devel/elfutils/files/patch-libelf_Makefile.am
deleted file mode 100644
index 0a783c5a0ab1..000000000000
--- a/devel/elfutils/files/patch-libelf_Makefile.am
+++ /dev/null
@@ -1,20 +0,0 @@
---- libelf/Makefile.am.orig 2014-12-22 15:04:49 UTC
-+++ libelf/Makefile.am
-@@ -39,7 +39,7 @@ noinst_LIBRARIES = libelf_pic.a
- noinst_PROGRAMS = $(noinst_LIBRARIES:_pic.a=.so)
- include_HEADERS = libelf.h gelf.h nlist.h
-
--pkginclude_HEADERS = elf-knowledge.h
-+pkginclude_HEADERS = elf-knowledge.h elf.h
-
- libelf_a_SOURCES = elf_version.c elf_hash.c elf_error.c elf_fill.c \
- elf_begin.c elf_next.c elf_rand.c elf_end.c elf_kind.c \
-@@ -117,7 +117,7 @@ uninstall: uninstall-am
- rm -f $(DESTDIR)$(libdir)/libelf.so.$(VERSION)
- rm -f $(DESTDIR)$(libdir)/libelf.so
-
--noinst_HEADERS = elf.h abstract.h common.h exttypes.h gelf_xlate.h libelfP.h \
-+noinst_HEADERS = abstract.h common.h exttypes.h gelf_xlate.h libelfP.h \
- version_xlate.h gnuhash_xlate.h note_xlate.h dl-hash.h
- EXTRA_DIST = libelf.map
-
diff --git a/devel/elfutils/files/patch-libelf_libelf.h b/devel/elfutils/files/patch-libelf_libelf.h
index 57e4e1e6ce41..5b2b5d6c22fd 100644
--- a/devel/elfutils/files/patch-libelf_libelf.h
+++ b/devel/elfutils/files/patch-libelf_libelf.h
@@ -1,14 +1,5 @@
--- libelf/libelf.h.orig 2014-08-18 19:48:26 UTC
+++ libelf/libelf.h
-@@ -32,7 +32,7 @@
- #include <sys/types.h>
-
- /* Get the ELF types. */
--#include <elf.h>
-+#include <elfutils/elf.h>
-
-
- /* Known translation types. */
@@ -74,7 +74,7 @@ typedef struct
Elf_Type d_type; /* Type of this piece of data. */
unsigned int d_version; /* ELF version. */
diff --git a/devel/elfutils/pkg-plist b/devel/elfutils/pkg-plist
index 999dd1fe502f..c12df7ea6124 100644
--- a/devel/elfutils/pkg-plist
+++ b/devel/elfutils/pkg-plist
@@ -16,7 +16,6 @@ bin/eu-strip
bin/eu-unstrip
include/dwarf.h
include/elfutils/elf-knowledge.h
-include/elfutils/elf.h
include/elfutils/known-dwarf.h
include/elfutils/libasm.h
include/elfutils/libdw.h