aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-01-25 04:34:54 +0800
committerpav <pav@FreeBSD.org>2005-01-25 04:34:54 +0800
commitc8a267cbe597ab3a2d6034df4b3a4d70a1c2a280 (patch)
tree7685352dd19395bbea0be059d77f3a643d15e35e
parent9a1d7a483e9a06bfa48415895b8874babd1899ca (diff)
downloadfreebsd-ports-gnome-c8a267cbe597ab3a2d6034df4b3a4d70a1c2a280.tar.gz
freebsd-ports-gnome-c8a267cbe597ab3a2d6034df4b3a4d70a1c2a280.tar.zst
freebsd-ports-gnome-c8a267cbe597ab3a2d6034df4b3a4d70a1c2a280.zip
- Unbreak on 5.x
- Unbreak on !i386 (tested on amd64) PR: ports/76591 Submitted by: Sam Lawrance <boris@brooknet.com.au>
-rw-r--r--devel/openthreads/Makefile8
-rw-r--r--devel/openthreads/files/patch-Make::makedefs11
-rw-r--r--devel/openthreads/files/patch-pthread_src::PThreadConditionPrivateData.h14
3 files changed, 23 insertions, 10 deletions
diff --git a/devel/openthreads/Makefile b/devel/openthreads/Makefile
index f3bebe8568f8..4738bd02f281 100644
--- a/devel/openthreads/Makefile
+++ b/devel/openthreads/Makefile
@@ -18,7 +18,7 @@ COMMENT= A library which provides OO thread interface for C++ programmers
USE_GMAKE= yes
USE_REINPLACE= yes
MAKE_ENV= PTHREAD_LIBS=${PTHREAD_LIBS}
-ONLY_FOR_ARCHS= i386
+INSTALLS_SHLIB= yes
WRKSRC= ${WRKDIR}/${DISTNAME}
MAKEFILE= GNUmakefile
@@ -28,12 +28,10 @@ ALL_TARGET= opt
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile on FreeBSD >= 5.x"
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's,%%CXXFLAGS%%,${CXXFLAGS},g' \
${WRKSRC}/Make/makedefs
+ @${FIND} ${WRKSRC} -name '*.o' -delete
+ @${FIND} ${WRKSRC} -name '*.so' -delete
.include <bsd.port.post.mk>
diff --git a/devel/openthreads/files/patch-Make::makedefs b/devel/openthreads/files/patch-Make::makedefs
index f5b166baef88..70b842fe762f 100644
--- a/devel/openthreads/files/patch-Make::makedefs
+++ b/devel/openthreads/files/patch-Make::makedefs
@@ -1,14 +1,15 @@
---- Make/makedefs.orig Thu Oct 16 19:33:14 2003
-+++ Make/makedefs Thu Oct 16 19:38:33 2003
+--- Make/makedefs.orig Thu Oct 2 16:56:31 2003
++++ Make/makedefs Mon Jan 24 21:28:13 2005
@@ -252,15 +252,22 @@
CXX = g++
endif
DEPARG = -MM
- INC += -I/usr/local/include -I/usr/X11R6/include
-+ INC += -I${LOCALBASE}/include -I${X11BASE}/include
- DEF += -W -Wall
+- DEF += -W -Wall
- OPTF = -O2
-+ OPTF = %%CXXFLAGS%%
++ INC += -I${LOCALBASE}/include -I${X11BASE}/include
++ DEF += -W -Wall -fPIC
++ OPTF = -O -pipe
DBGF = -g
SHARED = -shared
ARCH = 32
diff --git a/devel/openthreads/files/patch-pthread_src::PThreadConditionPrivateData.h b/devel/openthreads/files/patch-pthread_src::PThreadConditionPrivateData.h
new file mode 100644
index 000000000000..4da996175428
--- /dev/null
+++ b/devel/openthreads/files/patch-pthread_src::PThreadConditionPrivateData.h
@@ -0,0 +1,14 @@
+--- pthread_src/PThreadConditionPrivateData.h.orig Sun Jan 23 14:06:58 2005
++++ pthread_src/PThreadConditionPrivateData.h Sun Jan 23 14:07:12 2005
+@@ -24,9 +24,10 @@
+ #ifndef _PTHREADCONDITIONPRIVATEDATA_H_
+ #define _PTHREADCONDITIONPRIVATEDATA_H_
+
++#include <pthread.h>
++
+ namespace OpenThreads {
+
+-#include <pthread.h>
+ #include <OpenThreads/Condition>
+
+ class PThreadConditionPrivateData {