aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2002-11-09 02:54:51 +0800
committerarved <arved@FreeBSD.org>2002-11-09 02:54:51 +0800
commitc8c02ae0c7d1f5480b45f7f644c932da51a189ee (patch)
treed28910bc53f64aaf80ccce61c253c6c0d3a3fb5e
parent87142e5fe799b99ffa7e64becb4c1dd111f7f663 (diff)
downloadfreebsd-ports-gnome-c8c02ae0c7d1f5480b45f7f644c932da51a189ee.tar.gz
freebsd-ports-gnome-c8c02ae0c7d1f5480b45f7f644c932da51a189ee.tar.zst
freebsd-ports-gnome-c8c02ae0c7d1f5480b45f7f644c932da51a189ee.zip
Unbreak by upgrading to 2.6.2
Approved by: Hiten Pandya <hiten@uk.FreeBSD.org> (maintainer)
-rw-r--r--www/larbin/Makefile9
-rw-r--r--www/larbin/distinfo2
-rw-r--r--www/larbin/files/patch-aa18
3 files changed, 7 insertions, 22 deletions
diff --git a/www/larbin/Makefile b/www/larbin/Makefile
index f03284b8e8e6..3445c3969f09 100644
--- a/www/larbin/Makefile
+++ b/www/larbin/Makefile
@@ -6,17 +6,17 @@
#
PORTNAME= larbin
-PORTVERSION= 2.6.1
+PORTVERSION= 2.6.2
CATEGORIES= www
MASTER_SITES= ftp://ftp.sourceforge.net/pub/sourceforge/larbin/
MAINTAINER= hiten@uk.FreeBSD.org
-BROKEN= "Does not compile"
+BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash2
USE_GMAKE= yes
GNU_CONFIGURE= yes
-
+USE_REINPLACE= yes
PATCH_WRKSRC= ${WRKSRC}/src
MAKE_ARGS= CXX=${CXX}
@@ -24,6 +24,9 @@ post-patch:
@${SED} -e 's,CC=,CC?=,' -e 's,CFLAGS=-O3,CFLAGS+=,' < \
${WRKSRC}/adns/Makefile > ${WRKSRC}/adns/Makefile.new
@${MV} ${WRKSRC}/adns/Makefile.new ${WRKSRC}/adns/Makefile
+ ${REINPLACE_CMD} -e 's,/bin/bash,${LOCALBASE}/bin/bash,' ${WRKSRC}/configure
+ ${REINPLACE_CMD} -e 's,CFLAGS:=-O3,CFLAGS+=,g ; s,CXXFLAGS:=-Wall -O3,CXXFLAGS+=,g' \
+ ${WRKSRC}/src/larbin.make
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/larbin ${PREFIX}/bin/
diff --git a/www/larbin/distinfo b/www/larbin/distinfo
index 8e9dad6ac0c5..25e8705a132c 100644
--- a/www/larbin/distinfo
+++ b/www/larbin/distinfo
@@ -1 +1 @@
-MD5 (larbin-2.6.1.tar.gz) = cdbb7932dc0e8c0ad6417bff971b93f0
+MD5 (larbin-2.6.2.tar.gz) = c4f0199dbbdb8e69d8d1187518f311c9
diff --git a/www/larbin/files/patch-aa b/www/larbin/files/patch-aa
deleted file mode 100644
index 9476a1b9fd52..000000000000
--- a/www/larbin/files/patch-aa
+++ /dev/null
@@ -1,18 +0,0 @@
---- larbin.make.orig Mon Mar 4 06:47:28 2002
-+++ larbin.make Sat Jun 8 21:27:26 2002
-@@ -13,8 +13,7 @@
- ABS-MAIN-OBJ:=$(MAIN-OBJ)
-
- MAKE:=gmake
--CXX:=g++
--CPPFLAGS:=-Wall -O3 -D_REENTRANT -I- -I$(BASEDIR) -I$(ADNSDIR)
-+CPPFLAGS= ${CXXFLAGS} -Wall -D_REENTRANT -I- -I$(BASEDIR) -I$(ADNSDIR)
- RM:=rm -f
-
- first: all
-@@ -37,5 +36,3 @@
-
- prof-in: CPPFLAGS += -pg -DPROF
- prof-in: redo-in
--
---include .depend