aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2010-01-19 03:01:41 +0800
committergahr <gahr@FreeBSD.org>2010-01-19 03:01:41 +0800
commitc9b97c33d82d6a7b17b03881d69c535f78b374c1 (patch)
treecbe1e51b79d9802308b94540c83075cbd98afb85
parent9d8acbfcbebf1c1d7298d5297a60088ec58705dd (diff)
downloadfreebsd-ports-gnome-c9b97c33d82d6a7b17b03881d69c535f78b374c1.tar.gz
freebsd-ports-gnome-c9b97c33d82d6a7b17b03881d69c535f78b374c1.tar.zst
freebsd-ports-gnome-c9b97c33d82d6a7b17b03881d69c535f78b374c1.zip
- Update to 1.0.1.901
Changelog: - Fix name clash related to SUSv4 signal.h (patch by Pietro Cerutti, ticket 487). - Fix creating GL pixmap in certain situations (when using mesa?). - Play with XI2. - Remove useless definition. - Tweak configuration loading. - Eliminate Mode.action_inhibit. - Show EObj info via ipc when appropriate. - Move EWindowGetNamePixmap() to x.c (and rename). - Avoid some memory leaks with incorrect themes. - Remove some redundant checks. - Unmap internal windows before destroying. - Fixes progress bar rendering when CM is active. - Scale new icons down to 48x48 pixels. - Change iconbox fallback icon mode back to snapshot. - Do not propagate key events.
-rw-r--r--x11-wm/e16/Makefile2
-rw-r--r--x11-wm/e16/distinfo6
-rw-r--r--x11-wm/e16/files/patch-signal66
3 files changed, 4 insertions, 70 deletions
diff --git a/x11-wm/e16/Makefile b/x11-wm/e16/Makefile
index e81d325c403c..d23262355cb1 100644
--- a/x11-wm/e16/Makefile
+++ b/x11-wm/e16/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= e16
-DISTVERSION= 1.0.1.002
+DISTVERSION= 1.0.1.901
CATEGORIES= x11-wm
MASTER_SITES= SF/enlightenment/${PORTNAME}/Snapshots/
diff --git a/x11-wm/e16/distinfo b/x11-wm/e16/distinfo
index 36c1f0948a1b..b8d2766bda62 100644
--- a/x11-wm/e16/distinfo
+++ b/x11-wm/e16/distinfo
@@ -1,3 +1,3 @@
-MD5 (e16-1.0.1.002.tar.gz) = 686e900bfd16ca1fb5b75a8888be861c
-SHA256 (e16-1.0.1.002.tar.gz) = 3a4f7eeae9e29e4660734ddc16579f9dc12ccdde83b7aae8030359ab8102d3f8
-SIZE (e16-1.0.1.002.tar.gz) = 2121199
+MD5 (e16-1.0.1.901.tar.gz) = 902ba3aab784189d476f0a1d5724237e
+SHA256 (e16-1.0.1.901.tar.gz) = c12d4cc6a8bbbcb271f3d4c6f8d3e68226b5e7b98cd4192e89d7db61158c72b5
+SIZE (e16-1.0.1.901.tar.gz) = 2108581
diff --git a/x11-wm/e16/files/patch-signal b/x11-wm/e16/files/patch-signal
deleted file mode 100644
index 4cc022b18912..000000000000
--- a/x11-wm/e16/files/patch-signal
+++ /dev/null
@@ -1,66 +0,0 @@
---- src/main.c.orig 2009-12-22 21:06:08.000000000 +0100
-+++ src/main.c 2009-12-22 21:10:13.000000000 +0100
-@@ -21,6 +21,9 @@
- * IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
- * CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
- */
-+#include <sys/utsname.h>
-+#include <signal.h>
-+#include <time.h>
- #include "E.h"
- #include "comms.h"
- #include "cursors.h"
-@@ -38,9 +41,6 @@
- #include "snaps.h"
- #include "user.h"
- #include "xwin.h"
--#include <sys/utsname.h>
--#include <signal.h>
--#include <time.h>
-
- const char e_wm_name[] = "e16";
- const char e_wm_version[] = VERSION;
---- src/session.c.orig 2009-12-22 21:11:00.000000000 +0100
-+++ src/session.c 2009-12-22 21:11:11.000000000 +0100
-@@ -21,6 +21,10 @@
- * IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
- * CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
- */
-+#include <fcntl.h>
-+#include <signal.h>
-+#include <sys/time.h>
-+
- #include "E.h"
- #include "dialog.h"
- #include "e16-ecore_hints.h"
-@@ -33,9 +37,6 @@
- #include "snaps.h"
- #include "user.h"
- #include "xwin.h"
--#include <fcntl.h>
--#include <signal.h>
--#include <sys/time.h>
-
- #ifdef USE_EXT_INIT_WIN
- static Window new_init_win_ext = None;
---- src/setup.c.orig 2009-12-22 21:11:26.000000000 +0100
-+++ src/setup.c 2009-12-22 21:11:36.000000000 +0100
-@@ -21,14 +21,16 @@
- * IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
- * CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
- */
-+
-+#include <signal.h>
-+#include <X11/keysym.h>
-+
- #include "E.h"
- #include "events.h"
- #include "ewins.h"
- #include "screen.h"
- #include "session.h"
- #include "xwin.h"
--#include <signal.h>
--#include <X11/keysym.h>
-
- static void
- HandleXIOError(void)