aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2016-11-24 02:16:55 +0800
committertijl <tijl@FreeBSD.org>2016-11-24 02:16:55 +0800
commitc9d340f373ea755a4471d7674539f29ecc09bae7 (patch)
tree01edfa89d4eab0a884637e056974e9fcd91abd31
parent59c473b9735389bdbfc9e1cf6f817646dc6a0541 (diff)
downloadfreebsd-ports-gnome-c9d340f373ea755a4471d7674539f29ecc09bae7.tar.gz
freebsd-ports-gnome-c9d340f373ea755a4471d7674539f29ecc09bae7.tar.zst
freebsd-ports-gnome-c9d340f373ea755a4471d7674539f29ecc09bae7.zip
Add patch to apply alignment attribute to a struct instead of a typedef.
This rounds the size of the struct to a multiple of the alignment such that malloc and friends allocate memory with the correct alignment. PR: 214784 MFH: 2016Q4
-rw-r--r--net/mpich/Makefile2
-rw-r--r--net/mpich/files/patch-src-include-mpiimpl.h11
2 files changed, 12 insertions, 1 deletions
diff --git a/net/mpich/Makefile b/net/mpich/Makefile
index b328bf70923b..5b9ce510468f 100644
--- a/net/mpich/Makefile
+++ b/net/mpich/Makefile
@@ -2,7 +2,7 @@
PORTNAME= mpich
PORTVERSION= 3.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net parallel
MASTER_SITES= http://www.mpich.org/static/downloads/${DISTVERSION}/
diff --git a/net/mpich/files/patch-src-include-mpiimpl.h b/net/mpich/files/patch-src-include-mpiimpl.h
new file mode 100644
index 000000000000..47d416502f6f
--- /dev/null
+++ b/net/mpich/files/patch-src-include-mpiimpl.h
@@ -0,0 +1,11 @@
+--- src/include/mpiimpl.h.orig 2015-11-10 02:39:01 UTC
++++ src/include/mpiimpl.h
+@@ -1528,7 +1528,7 @@ typedef struct MPID_Request {
+ #ifdef MPID_DEV_REQUEST_DECL
+ MPID_DEV_REQUEST_DECL
+ #endif
+-} MPID_Request ATTRIBUTE((__aligned__(32)));
++} ATTRIBUTE((__aligned__(32))) MPID_Request;
+
+ extern MPIU_Object_alloc_t MPID_Request_mem;
+ /* Preallocated request objects */