aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2011-02-25 20:17:11 +0800
committerale <ale@FreeBSD.org>2011-02-25 20:17:11 +0800
commitc9d478069a0d7bc1bc10065b93511d05ecacc0e8 (patch)
tree654f7dd42254057f158d69f931fde5b9a88d7483
parent2fc01f33066c1f5429eb8434ee30b1ff4693bb73 (diff)
downloadfreebsd-ports-gnome-c9d478069a0d7bc1bc10065b93511d05ecacc0e8.tar.gz
freebsd-ports-gnome-c9d478069a0d7bc1bc10065b93511d05ecacc0e8.tar.zst
freebsd-ports-gnome-c9d478069a0d7bc1bc10065b93511d05ecacc0e8.zip
JDBM is a transactional persistence engine for Java. It aims to be for Java
what GDBM is for other languages: a fast, simple persistence engine. You can use it to store a mix of objects and BLOBs, and all updates are done in a transactionally safe manner. JDBM also provides scalable data structures, such as HTree and B+Tree, to support persistence of large object collections. JDBM2 provides HashMap and TreeMap which are backed by disk storage. It is very easy and fast way to persist your data. JDBM2 also have minimal hardware requirements and is highly embeddable. WWW: http://code.google.com/p/jdbm2/
-rw-r--r--databases/Makefile1
-rw-r--r--databases/jdbm2/Makefile41
-rw-r--r--databases/jdbm2/distinfo2
-rw-r--r--databases/jdbm2/pkg-descr13
4 files changed, 57 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 851bb2fa98fc..cdd874247c83 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -131,6 +131,7 @@
SUBDIR += jdb
SUBDIR += jdbc-oracle8i
SUBDIR += jdbc-oracle9i
+ SUBDIR += jdbm2
SUBDIR += jrobin
SUBDIR += jrrd
SUBDIR += kbibtex
diff --git a/databases/jdbm2/Makefile b/databases/jdbm2/Makefile
new file mode 100644
index 000000000000..d9714e7bad2d
--- /dev/null
+++ b/databases/jdbm2/Makefile
@@ -0,0 +1,41 @@
+# Ports collection makefile for: jdbm2
+# Date created: 25 Feb 2011
+# Whom: Alex Dupre <ale@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jdbm
+PORTVERSION= 2.0
+CATEGORIES= databases java
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+
+MAINTAINER= ale@FreeBSD.org
+COMMENT= A fast, simple and transactional Java persistence engine
+
+USE_ZIP= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.5+
+NO_BUILD= yes
+
+PROJECTHOST= jdbm2
+LATEST_LINK= jdbm2
+
+PORTDOCS= *
+PORTEXAMPLES= *
+
+PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar
+
+do-install:
+ @${INSTALL_DATA} ${WRKSRC}/lib/${DISTNAME}.jar \
+ ${JAVAJARDIR}/${PORTNAME}.jar
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} \* ${DOCSDIR})
+.endif
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${EXAMPLESDIR}
+ @(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
+.endif
+
+.include <bsd.port.mk>
diff --git a/databases/jdbm2/distinfo b/databases/jdbm2/distinfo
new file mode 100644
index 000000000000..d4d57f52772f
--- /dev/null
+++ b/databases/jdbm2/distinfo
@@ -0,0 +1,2 @@
+SHA256 (jdbm-2.0.zip) = 91d6e56407f2a3e2d3a508af86d833f3cdaa38df8221fcc607dcae54101a0e3f
+SIZE (jdbm-2.0.zip) = 348648
diff --git a/databases/jdbm2/pkg-descr b/databases/jdbm2/pkg-descr
new file mode 100644
index 000000000000..0db4af7ac8bc
--- /dev/null
+++ b/databases/jdbm2/pkg-descr
@@ -0,0 +1,13 @@
+JDBM is a transactional persistence engine for Java. It aims to be for Java
+what GDBM is for other languages: a fast, simple persistence engine.
+You can use it to store a mix of objects and BLOBs, and all updates are done
+in a transactionally safe manner. JDBM also provides scalable data structures,
+such as HTree and B+Tree, to support persistence of large object collections.
+JDBM2 provides HashMap and TreeMap which are backed by disk storage.
+It is very easy and fast way to persist your data.
+JDBM2 also have minimal hardware requirements and is highly embeddable.
+
+WWW: http://code.google.com/p/jdbm2/
+
+- Alex Dupre
+ale@FreeBSD.org