aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2003-05-19 16:43:57 +0800
committerlioux <lioux@FreeBSD.org>2003-05-19 16:43:57 +0800
commitca27e6c26d5f109c8cc4c2e400a92ac36841ea1d (patch)
tree537568083d8b561ba2ceee2d61c3888b19c8a0ef
parentace1b9e89a6acfffc1158a217c8d2bcb47bc7bc8 (diff)
downloadfreebsd-ports-gnome-ca27e6c26d5f109c8cc4c2e400a92ac36841ea1d.tar.gz
freebsd-ports-gnome-ca27e6c26d5f109c8cc4c2e400a92ac36841ea1d.tar.zst
freebsd-ports-gnome-ca27e6c26d5f109c8cc4c2e400a92ac36841ea1d.zip
New port libebml version 0.4.2: EBML (Extensible Binary Meta
Language), sort of binary version of XML
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/libebml/Makefile35
-rw-r--r--textproc/libebml/distinfo1
-rw-r--r--textproc/libebml/pkg-descr6
-rw-r--r--textproc/libebml/pkg-plist29
5 files changed, 72 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 7ae1c62738c5..191c15814b63 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -128,6 +128,7 @@
SUBDIR += lacheck
SUBDIR += latex2html
SUBDIR += latte
+ SUBDIR += libebml
SUBDIR += liblrdf
SUBDIR += libtre
SUBDIR += libxml
diff --git a/textproc/libebml/Makefile b/textproc/libebml/Makefile
new file mode 100644
index 000000000000..efbb431ffe91
--- /dev/null
+++ b/textproc/libebml/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: libebml
+# Date created: Mon May 19 08:29:44 UTC 2003
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libebml
+PORTVERSION= 0.4.2
+CATEGORIES= textproc
+MASTER_SITES= http://matroska.sourceforge.net/downloads/
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= EBML (Extensible Binary Meta Language), sort of binary version of XML
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+BUILD_WRKSRC= ${WRKSRC}/make/linux
+INSTALL_WRKSRC= ${WRKSRC}/make/linux
+
+# Installs dir with proper permissions
+INSTALL_DATA_DIR= ${INSTALL} -d -o ${SHAREOWN} -g ${SHAREGRP} -m 755
+
+do-configure:
+ @${REINPLACE_CMD} -E \
+ -e 's|^(prefix)[[:space:]]*=.*$$|\1=${PREFIX}|; \
+ s,^(CXX|LD)[[:space:]]*=.*$$,\1=${CXX},; \
+ s|^(CXXFLAGS)[[:space:]]*=(.*)$$|\1+=\2|; \
+ s|^(INSTALL)[[:space:]]*=.*$$|\1=|; \
+ s|^(INSTALL_DIR_OPTS)[[:space:]]*=.*$$|\1=${INSTALL_DATA_DIR}|; \
+ s,^(INSTALL_OPTS_LIB|INSTALL_OPTS)[[:space:]]*=.*$$,\1=${INSTALL_DATA},' \
+ ${WRKSRC}/make/linux/Makefile
+
+.include <bsd.port.mk>
diff --git a/textproc/libebml/distinfo b/textproc/libebml/distinfo
new file mode 100644
index 000000000000..554fbd6ca3a6
--- /dev/null
+++ b/textproc/libebml/distinfo
@@ -0,0 +1 @@
+MD5 (libebml-0.4.2.tar.bz2) = d07a4b9323e615d320c0460ce1b69009
diff --git a/textproc/libebml/pkg-descr b/textproc/libebml/pkg-descr
new file mode 100644
index 000000000000..011ccea2a019
--- /dev/null
+++ b/textproc/libebml/pkg-descr
@@ -0,0 +1,6 @@
+[ excerpt from developer's site ]
+
+Library for EBML (Extensible Binary Meta Language), sort of a binary
+version of XML.
+
+WWW: http://www.matroska.org/
diff --git a/textproc/libebml/pkg-plist b/textproc/libebml/pkg-plist
new file mode 100644
index 000000000000..a5a6a7fe73f0
--- /dev/null
+++ b/textproc/libebml/pkg-plist
@@ -0,0 +1,29 @@
+include/ebml/Debug.h
+include/ebml/EbmlBinary.h
+include/ebml/EbmlConfig.h
+include/ebml/EbmlContexts.h
+include/ebml/EbmlCrc32.h
+include/ebml/EbmlDate.h
+include/ebml/EbmlElement.h
+include/ebml/EbmlEndian.h
+include/ebml/EbmlFloat.h
+include/ebml/EbmlHead.h
+include/ebml/EbmlId.h
+include/ebml/EbmlMaster.h
+include/ebml/EbmlSInteger.h
+include/ebml/EbmlStream.h
+include/ebml/EbmlString.h
+include/ebml/EbmlSubHead.h
+include/ebml/EbmlTypes.h
+include/ebml/EbmlUInteger.h
+include/ebml/EbmlUnicodeString.h
+include/ebml/EbmlVersion.h
+include/ebml/EbmlVoid.h
+include/ebml/IOCallback.h
+include/ebml/StdIOCallback.h
+include/ebml/StdInclude.h
+include/ebml/api/c/libebml_t.h
+lib/libebml.a
+@dirrm include/ebml/api/c
+@dirrm include/ebml/api
+@dirrm include/ebml