aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2017-01-01 19:45:28 +0800
committerjbeich <jbeich@FreeBSD.org>2017-01-01 19:45:28 +0800
commitcabc029f02c08df727035f75677066408fd7e805 (patch)
tree188cf9b9728d9f3801c662547b9b5bf82ffaafc2
parentc2c92b65b93b97c1b268b05751bd0579f6c38a89 (diff)
downloadfreebsd-ports-gnome-cabc029f02c08df727035f75677066408fd7e805.tar.gz
freebsd-ports-gnome-cabc029f02c08df727035f75677066408fd7e805.tar.zst
freebsd-ports-gnome-cabc029f02c08df727035f75677066408fd7e805.zip
devel/boost-libs: oops, work around ${CC} usage after r430247
$ make -V '${MAKE_ARGS:M--toolset*}' /bin/sh: clang39: not found make: "/usr/ports/Mk/Uses/compiler.mk" line 69: warning: "clang39 --version" returned non-zero status make: "/usr/ports/Mk/Uses/compiler.mk" line 120: warning: "clang++39 -### /dev/null 2>&1" returned non-zero status --toolset=gcc PR: 213867 MFH: 2016Q4 (r430247 followup)
-rw-r--r--devel/boost-libs/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/devel/boost-libs/Makefile b/devel/boost-libs/Makefile
index d0d25640cd69..d37d7358c4a5 100644
--- a/devel/boost-libs/Makefile
+++ b/devel/boost-libs/Makefile
@@ -32,10 +32,11 @@ ICU_MAKE_ARGS_OFF= boost.locale.icu=off
MAKE_ARGS+= --without-python
ALL_TARGET= stage
-.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
-# XXX Avoid bsd.port.(pre|post).mk dance by only working around base compiler
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1100508 && ${ARCH} == aarch64 && ${CXX} == c++
+# XXX CHOSEN_COMPILER_VERSION isn't supported, so check CXX hasn't changed
+.if ${ARCH} == aarch64 && ${CXX} == c++ && \
+ ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} < 39
BUILD_DEPENDS+= ${CC}:devel/llvm${LLVM_VER}
CC= clang${LLVM_VER}
CXX= clang++${LLVM_VER}
@@ -64,4 +65,4 @@ post-install:
-e "s|%%PYTHON_LIBDIR%%|${PYTHON_LIBDIR}|g" \
-e "s|%%PYTHON_VERSION%%|${PYTHON_VERSION}|g" ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>