aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-05-17 02:22:54 +0800
committerJan Beich <jbeich@FreeBSD.org>2019-05-17 02:22:54 +0800
commitcac332d6584366cdf0723d0ff4e1d87323db96d8 (patch)
tree15a3407b3ef48832e576861b55f92ee9f5855cc7
parentcc8c051f2d8f46b60c1759bc19a8a39d0c4273cf (diff)
downloadfreebsd-ports-gnome-cac332d6584366cdf0723d0ff4e1d87323db96d8.tar.gz
freebsd-ports-gnome-cac332d6584366cdf0723d0ff4e1d87323db96d8.tar.zst
freebsd-ports-gnome-cac332d6584366cdf0723d0ff4e1d87323db96d8.zip
www/firefox-esr: update to 60.7.0
Changes: https://www.mozilla.org/firefox/60.7.0/releasenotes/
-rw-r--r--www/firefox-esr/Makefile3
-rw-r--r--www/firefox-esr/distinfo6
-rw-r--r--www/firefox-esr/files/patch-a-bug150279950
3 files changed, 54 insertions, 5 deletions
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index 258ce258a30e..f82bcf01c0f9 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= firefox
-DISTVERSION= 60.6.3
-PORTREVISION= 1
+DISTVERSION= 60.7.0
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}esr/source \
diff --git a/www/firefox-esr/distinfo b/www/firefox-esr/distinfo
index a79f42ec65a6..ce8654969d4a 100644
--- a/www/firefox-esr/distinfo
+++ b/www/firefox-esr/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1557262721
-SHA256 (firefox-60.6.3esr.source.tar.xz) = eebf34968c64cf8c007dd0da98124edf55cdda141f8b4c653e8e00b22650833e
-SIZE (firefox-60.6.3esr.source.tar.xz) = 268688628
+TIMESTAMP = 1557861234
+SHA256 (firefox-60.7.0esr.source.tar.xz) = 0a5f0c1d8d1e9443d85083d37fec32e5cc15c1001ea992d49745490065b4a023
+SIZE (firefox-60.7.0esr.source.tar.xz) = 268497160
diff --git a/www/firefox-esr/files/patch-a-bug1502799 b/www/firefox-esr/files/patch-a-bug1502799
new file mode 100644
index 000000000000..105da6a3e21c
--- /dev/null
+++ b/www/firefox-esr/files/patch-a-bug1502799
@@ -0,0 +1,50 @@
+commit f57498276d74
+Author: Andrea Marchesini <amarchesini@mozilla.com>
+Date: Wed May 15 22:00:00 2019 -0700
+
+ Bug 1502799 - Reintroduce serialize_function, disabled by mistake by previous patches, r=emilio
+---
+ servo/components/style/gecko_string_cache/namespace.rs | 1 -
+ servo/components/style_traits/values.rs | 3 ---
+ 2 files changed, 4 deletions(-)
+
+diff --git servo/components/style/gecko_string_cache/namespace.rs servo/components/style/gecko_string_cache/namespace.rs
+index 71d2fce8ff6b..92288574e145 100644
+--- servo/components/style/gecko_string_cache/namespace.rs
++++ servo/components/style/gecko_string_cache/namespace.rs
+@@ -11,7 +11,6 @@ use std::fmt;
+ use std::ops::Deref;
+ use string_cache::{Atom, WeakAtom};
+
+-/// aaa
+ #[macro_export]
+ macro_rules! ns {
+ () => { $crate::string_cache::Namespace(atom!("")) };
+diff --git servo/components/style_traits/values.rs servo/components/style_traits/values.rs
+index 40209772a790..d6bd05b7b40e 100644
+--- servo/components/style_traits/values.rs
++++ servo/components/style_traits/values.rs
+@@ -135,7 +135,6 @@ where
+ }
+ }
+
+-/*
+ #[macro_export]
+ macro_rules! serialize_function {
+ ($dest: expr, $name: ident($( $arg: expr, )+)) => {
+@@ -153,7 +152,6 @@ macro_rules! serialize_function {
+ }
+ }
+ }
+-*/
+
+ /// Convenience wrapper to serialise CSS values separated by a given string.
+ pub struct SequenceWriter<'a, 'b: 'a, W: 'b> {
+@@ -406,7 +404,6 @@ impl_to_css_for_predefined_type!(::cssparser::RGBA);
+ impl_to_css_for_predefined_type!(::cssparser::Color);
+ impl_to_css_for_predefined_type!(::cssparser::UnicodeRange);
+
+-/// Define an enum type with unit variants that each correspond to a CSS keyword.
+ #[macro_export]
+ macro_rules! define_css_keyword_enum {
+ (pub enum $name:ident { $($variant:ident = $css:expr,)+ }) => {