aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorcy <cy@FreeBSD.org>2004-10-30 09:46:55 +0800
committercy <cy@FreeBSD.org>2004-10-30 09:46:55 +0800
commitcacd42bb34bed378bd0cf0f37cdc5117bf12fd66 (patch)
tree20fe6fe0e2bbb05b05f80c500e2a7a524ed9d066
parente4153e468f2077ea839f7c481b0c3fbeaddb5f3f (diff)
downloadfreebsd-ports-gnome-cacd42bb34bed378bd0cf0f37cdc5117bf12fd66.tar.gz
freebsd-ports-gnome-cacd42bb34bed378bd0cf0f37cdc5117bf12fd66.tar.zst
freebsd-ports-gnome-cacd42bb34bed378bd0cf0f37cdc5117bf12fd66.zip
Add a sudo dependency and dependency on libutil.
-rw-r--r--security/sudosh/Makefile3
-rw-r--r--security/sudosh2/Makefile3
-rw-r--r--security/sudosh3/Makefile3
3 files changed, 9 insertions, 0 deletions
diff --git a/security/sudosh/Makefile b/security/sudosh/Makefile
index 8c899c526a13..11c128bc67cc 100644
--- a/security/sudosh/Makefile
+++ b/security/sudosh/Makefile
@@ -15,9 +15,12 @@ MASTER_SITE_SUBDIR= ${PORTNAME:S/_/-/}
MAINTAINER= cy@FreeBSD.org
COMMENT= A sudo shell
+RUN_DEPENDS= sudo:${PORTSDIR}/security/sudo
+
USE_BZIP2= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --bindir="${PREFIX}/bin"
+CONFIGURE_ENV= LDFLAGS="-lutil"
.include <bsd.port.mk>
diff --git a/security/sudosh2/Makefile b/security/sudosh2/Makefile
index 8c899c526a13..11c128bc67cc 100644
--- a/security/sudosh2/Makefile
+++ b/security/sudosh2/Makefile
@@ -15,9 +15,12 @@ MASTER_SITE_SUBDIR= ${PORTNAME:S/_/-/}
MAINTAINER= cy@FreeBSD.org
COMMENT= A sudo shell
+RUN_DEPENDS= sudo:${PORTSDIR}/security/sudo
+
USE_BZIP2= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --bindir="${PREFIX}/bin"
+CONFIGURE_ENV= LDFLAGS="-lutil"
.include <bsd.port.mk>
diff --git a/security/sudosh3/Makefile b/security/sudosh3/Makefile
index 8c899c526a13..11c128bc67cc 100644
--- a/security/sudosh3/Makefile
+++ b/security/sudosh3/Makefile
@@ -15,9 +15,12 @@ MASTER_SITE_SUBDIR= ${PORTNAME:S/_/-/}
MAINTAINER= cy@FreeBSD.org
COMMENT= A sudo shell
+RUN_DEPENDS= sudo:${PORTSDIR}/security/sudo
+
USE_BZIP2= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --bindir="${PREFIX}/bin"
+CONFIGURE_ENV= LDFLAGS="-lutil"
.include <bsd.port.mk>