aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2006-07-27 01:08:18 +0800
committeracm <acm@FreeBSD.org>2006-07-27 01:08:18 +0800
commitcada202a11018168d331201279d62f9d1f89e453 (patch)
tree1ca5462c0f59e8af3aa1b88704306dfd7fd65c9d
parent63a8c678ba9ae3e48ed45baf3ff74d590573ee6d (diff)
downloadfreebsd-ports-gnome-cada202a11018168d331201279d62f9d1f89e453.tar.gz
freebsd-ports-gnome-cada202a11018168d331201279d62f9d1f89e453.tar.zst
freebsd-ports-gnome-cada202a11018168d331201279d62f9d1f89e453.zip
- Update to 20060708
- Removed USE_X_PREFIX - Added NLS option - Added patch-SConstruct file. It fixed a problem with intl library. Approved by: garga (mentor)
-rw-r--r--games/vdrift/Makefile31
-rw-r--r--games/vdrift/distinfo6
-rw-r--r--games/vdrift/files/patch-SConstruct11
-rw-r--r--games/vdrift/pkg-plist1
4 files changed, 39 insertions, 10 deletions
diff --git a/games/vdrift/Makefile b/games/vdrift/Makefile
index 3e1e8df9ab59..05832acb7185 100644
--- a/games/vdrift/Makefile
+++ b/games/vdrift/Makefile
@@ -6,12 +6,11 @@
#
PORTNAME= vdrift
-PORTVERSION= 20060221
-PORTREVISION= 2
+PORTVERSION= 20060708
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= ${PORTNAME}-2006-02-21-src
+DISTNAME= ${PORTNAME}-2006-07-08-src
DIST_SUBDIR= ${PORTNAME}
MAINTAINER= acm@FreeBSD.org
@@ -20,19 +19,22 @@ COMMENT= Open source driving simulation
BUILD_DEPENDS= scons:${PORTSDIR}/devel/scons
LIB_DEPENDS= openal.0:${PORTSDIR}/audio/openal \
alut.1:${PORTSDIR}/audio/freealut
-RUN_DEPENDS= ${X11BASE}/share/${PORTNAME}/settings/VDrift.config:${PORTSDIR}/games/vdrift-data
+RUN_DEPENDS= ${LOCALBASE}/share/${PORTNAME}/settings/VDrift.config:${PORTSDIR}/games/vdrift-data
USE_BZIP2= yes
-USE_X_PREFIX= yes
USE_GL= yes
USE_SDL= sdl image net
MAKE_ENV= CC="${CC}" CXX="${CXX}"
-SCONS_ARGS= prefix=${DATADIR} bin=${PREFIX}/bin
+SCONS_ARGS= prefix=${PREFIX} \
+ datadir=share/${PORTNAME} \
+ bindir=bin \
+ use_binreloc=0
SUB_FILES= pkg-message
-OPTIONS= DEBUG "Additional debug information" off
+OPTIONS= DEBUG "Additional debug information" off \
+ NLS "Internationalization support " on
.include <bsd.port.pre.mk>
@@ -42,6 +44,14 @@ SCONS_ARGS+= release=0
SCONS_ARGS+= release=1
.endif
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+FLAG_NLS= true
+.else
+PLIST_SUB+= NLS="@comment "
+.endif
+
.if ${OSVERSION} < 500000
BROKEN= does not compile
.endif
@@ -63,6 +73,13 @@ do-build:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/build/vdrift ${PREFIX}/bin
+.if defined(FLAG_NLS)
+. for DIRE in nl
+ @cd ${WRKSRC}/po/share/locale/${DIRE}/LC_MESSAGES && \
+ ${FIND} * -type f -exec ${INSTALL_DATA} "{}" ${PREFIX}/share/locale/${DIRE}/LC_MESSAGES \;
+. endfor
+.endif
+
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
.for FILE in docs/AUTHORS docs/README
diff --git a/games/vdrift/distinfo b/games/vdrift/distinfo
index dcbacf67534c..8d2212b7e0a5 100644
--- a/games/vdrift/distinfo
+++ b/games/vdrift/distinfo
@@ -1,3 +1,3 @@
-MD5 (vdrift/vdrift-2006-02-21-src.tar.bz2) = 5ba43ca0925afe5128c829dae2c61c76
-SHA256 (vdrift/vdrift-2006-02-21-src.tar.bz2) = cd46e9b240db4e701c25e5a3f0d3f3a4c30bb64a0e580c4fd3c92f2f99933617
-SIZE (vdrift/vdrift-2006-02-21-src.tar.bz2) = 1988420
+MD5 (vdrift/vdrift-2006-07-08-src.tar.bz2) = c2275e99ad0d5802a11d3263a2818bff
+SHA256 (vdrift/vdrift-2006-07-08-src.tar.bz2) = 8fba3d6bae4f21cbf65073529dc05170d2af4861954887346edc88f2cf5cc4ad
+SIZE (vdrift/vdrift-2006-07-08-src.tar.bz2) = 1082005
diff --git a/games/vdrift/files/patch-SConstruct b/games/vdrift/files/patch-SConstruct
new file mode 100644
index 000000000000..89d701992c1d
--- /dev/null
+++ b/games/vdrift/files/patch-SConstruct
@@ -0,0 +1,11 @@
+--- SConstruct Fri Jul 21 16:43:04 2006
++++ SConstruct Fri Jul 21 16:43:49 2006
+@@ -42,7 +42,7 @@
+ env = Environment(ENV = os.environ,
+ CPPPATH = ['#include',LOCALBASE + '/include', LOCALBASE + '/include/AL',X11BASE + '/include'],
+ LIBPATH = ['.', '#lib', LOCALBASE + '/lib', X11BASE + '/lib'],
+- LINKFLAGS = ['-pthread'],
++ LINKFLAGS = ['-pthread','-lintl'],
+ options = opts)
+
+ check_headers = ['GL/gl.h', 'GL/glu.h', 'SDL11/SDL.h', 'SDL11/SDL_image.h', 'SDL11/SDL_net.h']
diff --git a/games/vdrift/pkg-plist b/games/vdrift/pkg-plist
index 565530c514c5..c2ee0712b629 100644
--- a/games/vdrift/pkg-plist
+++ b/games/vdrift/pkg-plist
@@ -1,4 +1,5 @@
bin/vdrift
+%%NLS%%share/locale/nl/LC_MESSAGES/VDrift.mo
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%@dirrm %%DOCSDIR%%