aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2000-11-06 05:03:38 +0800
committerade <ade@FreeBSD.org>2000-11-06 05:03:38 +0800
commitcaf1c4f3078e3fd5c3c4bc4610224965bec99f46 (patch)
tree576845c32a4bad985025d6745816c64713606c88
parent2623f8200ae58f5ad0660e631b4e0a3527e9abf8 (diff)
downloadfreebsd-ports-gnome-caf1c4f3078e3fd5c3c4bc4610224965bec99f46.tar.gz
freebsd-ports-gnome-caf1c4f3078e3fd5c3c4bc4610224965bec99f46.tar.zst
freebsd-ports-gnome-caf1c4f3078e3fd5c3c4bc4610224965bec99f46.zip
Update to 0.0.15
-rw-r--r--lang/gnomebasic/Makefile2
-rw-r--r--lang/gnomebasic/distinfo2
-rw-r--r--lang/gnomebasic/pkg-plist2
3 files changed, 4 insertions, 2 deletions
diff --git a/lang/gnomebasic/Makefile b/lang/gnomebasic/Makefile
index 38c9eb9e3dc5..fa954f43d2d6 100644
--- a/lang/gnomebasic/Makefile
+++ b/lang/gnomebasic/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gnomebasic
-PORTVERSION= 0.0.14
+PORTVERSION= 0.0.15
CATEGORIES= lang gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= unstable/sources/gb
diff --git a/lang/gnomebasic/distinfo b/lang/gnomebasic/distinfo
index 341d27b83918..5acac885a122 100644
--- a/lang/gnomebasic/distinfo
+++ b/lang/gnomebasic/distinfo
@@ -1 +1 @@
-MD5 (gb-0.0.14.tar.gz) = 3001790f96eb9c8db3f6cc991fe1ce2f
+MD5 (gb-0.0.15.tar.gz) = 3e59330868d23b5ee4e12cb9a81f9a7c
diff --git a/lang/gnomebasic/pkg-plist b/lang/gnomebasic/pkg-plist
index b1b53c4035a1..ea3a7946deae 100644
--- a/lang/gnomebasic/pkg-plist
+++ b/lang/gnomebasic/pkg-plist
@@ -1,4 +1,5 @@
etc/gbConf.sh
+include/gb/gb-constants.h
include/gb/gb-eval.h
include/gb/gb-expr.h
include/gb/gb-lex.h
@@ -10,6 +11,7 @@ include/gb/gb-statement.h
include/gb/gb-value.h
include/gb/gb.h
include/gb/libgb.h
+include/gbrun/gbrun-collection.h
include/gbrun/gbrun-eval.h
include/gbrun/gbrun-file.h
include/gbrun/gbrun-global.h
; font-weight: bold } /* Literal.Number.Float */ .highlight .mh { color: #0000DD; font-weight: bold } /* Literal.Number.Hex */ .highlight .mi { color: #0000DD; font-weight: bold } /* Literal.Number.Integer */ .highlight .mo { color: #0000DD; font-weight: bold } /* Literal.Number.Oct */ .highlight .sa { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Affix */ .highlight .sb { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Backtick */ .highlight .sc { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Char */ .highlight .dl { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Delimiter */ .highlight .sd { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Doc */ .highlight .s2 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Double */ .highlight .se { color: #0044dd; background-color: #fff0f0 } /* Literal.String.Escape */ .highlight .sh { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Heredoc */ .highlight .si { color: #3333bb; background-color: #fff0f0 } /* Literal.String.Interpol */ .highlight .sx { color: #22bb22; background-color: #f0fff0 } /* Literal.String.Other */ .highlight .sr { color: #008800; background-color: #fff0ff } /* Literal.String.Regex */ .highlight .s1 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Single */ .highlight .ss { color: #aa6600; background-color: #fff0f0 } /* Literal.String.Symbol */ .highlight .bp { color: #003388 } /* Name.Builtin.Pseudo */ .highlight .fm { color: #0066bb; font-weight: bold } /* Name.Function.Magic */ .highlight .vc { color: #336699 } /* Name.Variable.Class */ .highlight .vg { color: #dd7700 } /* Name.Variable.Global */ .highlight .vi { color: #3333bb } /* Name.Variable.Instance */ .highlight .vm { color: #336699 } /* Name.Variable.Magic */ .highlight .il { color: #0000DD; font-weight: bold } /* Literal.Number.Integer.Long */

CircleCI

DEXON Consensus

Getting Started

Prerequisites

Installation

  1. Clone the repo git clone https://github.com/dexon-foundation/dexon-consensus.git cd dexon-consensus

  2. Setup GOPATH, the GOPATH could be anywhere in the system. Here we use $HOME/go: export GOPATH=$HOME/go export PATH=$GOPATH/bin:$PATH You should write these settings to your .bashrc file.

  3. Install go dependency management tool ./bin/install_tools.sh

  4. Install all dependencies dep ensure

Run Unit Tests

make pre-submit

Simulation

Simulation with Nodes connected by HTTP

  1. Setup the configuration under ./test.toml
  2. Compile and install the cmd dexon-simulation
make
  1. Run simulation:
dexcon-simulation -config test.toml -init

Simulation with test.Scheduler

  1. Setup the configuration under ./test.toml
  2. Compile and install the cmd dexon-simulation-with-scheduler
make
  1. Run simulation with scheduler:
dexcon-simulation-with-scheduler -config test.toml