aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortabthorpe <tabthorpe@FreeBSD.org>2009-01-28 22:46:20 +0800
committertabthorpe <tabthorpe@FreeBSD.org>2009-01-28 22:46:20 +0800
commitcb4112d24dd0bd8bb0687e0fe660d3ba23cf2c07 (patch)
tree03c359918af14e80bf0fa1251d5a2b9797b6585f
parentd12bb050136dc90003affa0929c0caf26a826ad8 (diff)
downloadfreebsd-ports-gnome-cb4112d24dd0bd8bb0687e0fe660d3ba23cf2c07.tar.gz
freebsd-ports-gnome-cb4112d24dd0bd8bb0687e0fe660d3ba23cf2c07.tar.zst
freebsd-ports-gnome-cb4112d24dd0bd8bb0687e0fe660d3ba23cf2c07.zip
- Unbreak after recent guile update
PR: ports/130919 Submitted by: Jan Henrik Sylvester <me janh.de> Approved by: maintainer implicit
-rw-r--r--print/lilypond/Makefile2
-rw-r--r--print/lilypond/files/patch-lily-parse-scm.cc13
2 files changed, 13 insertions, 2 deletions
diff --git a/print/lilypond/Makefile b/print/lilypond/Makefile
index b6ea2d012f21..78cf12e30713 100644
--- a/print/lilypond/Makefile
+++ b/print/lilypond/Makefile
@@ -52,8 +52,6 @@ NOCCACHE= yes
PLIST_SUB= PORTVERSION=${PORTVERSION}
-BROKEN= Does not compile
-
.include <bsd.port.pre.mk>
.if !defined(NOPORTDOCS) && defined(WITH_WEBDOCS)
diff --git a/print/lilypond/files/patch-lily-parse-scm.cc b/print/lilypond/files/patch-lily-parse-scm.cc
new file mode 100644
index 000000000000..e45dca9269dd
--- /dev/null
+++ b/print/lilypond/files/patch-lily-parse-scm.cc
@@ -0,0 +1,13 @@
+diff -u lily/parse-scm.cc~ lily/parse-scm.cc
+--- lily/parse-scm.cc~ 2008-09-10 06:47:20.000000000 +0200
++++ lily/parse-scm.cc 2009-01-23 17:31:48.000000000 +0100
+@@ -38,9 +38,6 @@
+ SCM answer = SCM_UNSPECIFIED;
+ SCM form = scm_read (port);
+
+- /* Reset read_buf for scm_ftell.
+- Shouldn't scm_read () do this for us? */
+- scm_fill_input (port);
+ SCM to = scm_ftell (port);
+ ps->nchars = scm_to_int (to) - scm_to_int (from);
+