aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2018-09-11 21:44:47 +0800
committerjbeich <jbeich@FreeBSD.org>2018-09-11 21:44:47 +0800
commitcba0358c6dae44b7d880798713b18eb8f096b404 (patch)
treec297b1a1b7f3f2e21b788777716086fd89c97be2
parentda6ec510a66ea287e9bfffc05fa1937eeaeb2c3d (diff)
downloadfreebsd-ports-gnome-cba0358c6dae44b7d880798713b18eb8f096b404.tar.gz
freebsd-ports-gnome-cba0358c6dae44b7d880798713b18eb8f096b404.tar.zst
freebsd-ports-gnome-cba0358c6dae44b7d880798713b18eb8f096b404.zip
devel/renpy: update to 7.1.0
Changes: https://www.renpy.org/release/7.1.0 (see Announcment) Changes: https://www.renpy.org/doc/html/changelog.html#renpy-7-1
-rw-r--r--devel/py-game_sdl2/Makefile2
-rw-r--r--devel/py-game_sdl2/distinfo6
-rw-r--r--games/renpy/Makefile2
-rw-r--r--games/renpy/distinfo6
-rw-r--r--games/renpy/files/patch-system-fribidi57
5 files changed, 65 insertions, 8 deletions
diff --git a/devel/py-game_sdl2/Makefile b/devel/py-game_sdl2/Makefile
index b3011e2f7b6a..83b706ea16e0 100644
--- a/devel/py-game_sdl2/Makefile
+++ b/devel/py-game_sdl2/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= game_sdl2
-PORTVERSION= 7.0.0
+PORTVERSION= 7.1.0
CATEGORIES= devel python
MASTER_SITES= http://www.renpy.org/dl/${PORTVERSION}/ \
GENTOO
diff --git a/devel/py-game_sdl2/distinfo b/devel/py-game_sdl2/distinfo
index c5b6febe96c7..190afb83a48a 100644
--- a/devel/py-game_sdl2/distinfo
+++ b/devel/py-game_sdl2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1527821357
-SHA256 (pygame_sdl2-2.1.0-for-renpy-7.0.0.tar.gz) = 7eba0b990d613868daa077943bf89ce542e2945ed005e130cfa85f9819944437
-SIZE (pygame_sdl2-2.1.0-for-renpy-7.0.0.tar.gz) = 2573001
+TIMESTAMP = 1536624238
+SHA256 (pygame_sdl2-2.1.0-for-renpy-7.1.0.tar.gz) = 56136a6e56369d3b8bf95ede11a76f82243a1737ece30fe72189780d5104f2a0
+SIZE (pygame_sdl2-2.1.0-for-renpy-7.1.0.tar.gz) = 2572875
diff --git a/games/renpy/Makefile b/games/renpy/Makefile
index fb4adefd07b6..f3d22ebacac6 100644
--- a/games/renpy/Makefile
+++ b/games/renpy/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= renpy
-PORTVERSION?= 7.0.0
+PORTVERSION?= 7.1.0
DISTVERSIONSUFFIX=-sdk
PORTREVISION?= 0
CATEGORIES= games devel
diff --git a/games/renpy/distinfo b/games/renpy/distinfo
index 348e2a709d4c..4234257aa5b8 100644
--- a/games/renpy/distinfo
+++ b/games/renpy/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1527821217
-SHA256 (renpy-7.0.0-sdk.tar.bz2) = 548561684b4e800c5aa349f9fae0371789c462dc3ede4ffd60ef45d3df1cc384
-SIZE (renpy-7.0.0-sdk.tar.bz2) = 92106485
+TIMESTAMP = 1536624118
+SHA256 (renpy-7.1.0-sdk.tar.bz2) = 1ea30273e3c7eaf7f3c974b622a21618a8e96143d181178cb321bf9878d89b27
+SIZE (renpy-7.1.0-sdk.tar.bz2) = 92329790
diff --git a/games/renpy/files/patch-system-fribidi b/games/renpy/files/patch-system-fribidi
new file mode 100644
index 000000000000..0232db728876
--- /dev/null
+++ b/games/renpy/files/patch-system-fribidi
@@ -0,0 +1,57 @@
+Partially revert 4a9efc0cab7d as module/fribidi-src/ is missing from source archive.
+
+gen/_renpybidi.c:564:10: fatal error: 'fribidi.h' file not found
+#include "fribidi.h"
+ ^
+
+--- module/renpybidicore.c.orig 2018-07-11 04:11:19 UTC
++++ module/renpybidicore.c
+@@ -1,5 +1,5 @@
+ #include <Python.h>
+-#include <fribidi-src/lib/fribidi.h>
++#include <fribidi.h>
+ #include <stdlib.h>
+
+ #ifndef alloca
+--- module/setup.py.orig 2018-07-11 04:29:32 UTC
++++ module/setup.py
+@@ -92,6 +92,7 @@ has_avresample = library("avresample", optional=True)
+ has_swresample = library("swresample", optional=True)
+ has_swscale = library("swscale", optional=True)
+ library("freetype")
++has_fribidi = include("fribidi.h", directory="fribidi", optional=True) and library("fribidi", optional=True)
+ library("z")
+ has_libglew = library("GLEW", optional=True)
+ has_libglew32 = library("glew32", optional=True)
+@@ -105,6 +106,16 @@ else:
+ sdl = [ 'SDL2' ]
+ png = 'png'
+
++
++if has_fribidi and (not android) and (not ios):
++ try:
++ # Some versions of fribidi require glib, and it doesn't hurt to include it in
++ # our path.
++ glib_flags = subprocess.check_output(["pkg-config", "--cflags", "glib-2.0"])
++ setuplib.extra_compile_args.extend(glib_flags.split())
++ except:
++ pass
++
+ steam_sdk = os.environ.get("RENPY_STEAM_SDK", None)
+ steam_platform = os.environ.get("RENPY_STEAM_PLATFORM", "")
+
+@@ -134,11 +145,12 @@ renpybidicore.c
+ """.split()
+ cython(
+ "_renpybidi",
+- FRIBIDI_SOURCES,
+- includes=[
++ has_fribidi and [ i for i in FRIBIDI_SOURCES if 'fribidi-src' not in i ] or FRIBIDI_SOURCES,
++ includes=has_fribidi and [] or [
+ BASE + "/fribidi-src/",
+ BASE + "/fribidi-src/lib/",
+ ],
++ libs=has_fribidi and ['fribidi'] or [],
+ define_macros=[
+ ("FRIBIDI_ENTRY", ""),
+ ("HAVE_CONFIG_H", "1"),