aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2014-07-21 05:59:06 +0800
committerrene <rene@FreeBSD.org>2014-07-21 05:59:06 +0800
commitcbd50858ee530f13e07b2e2f89de2efa7e1ea01d (patch)
treed0dbad03d8369bae6e107d4b32994ba9c91f3e10
parentbdfa2ade071076e70315168e4f580bb2f4f925b6 (diff)
downloadfreebsd-ports-gnome-cbd50858ee530f13e07b2e2f89de2efa7e1ea01d.tar.gz
freebsd-ports-gnome-cbd50858ee530f13e07b2e2f89de2efa7e1ea01d.tar.zst
freebsd-ports-gnome-cbd50858ee530f13e07b2e2f89de2efa7e1ea01d.zip
comms/dcf77pi: apply upstream patch to fix display bug when realfreq is reset
-rw-r--r--comms/dcf77pi/Makefile2
-rw-r--r--comms/dcf77pi/files/patch-d3ab07122
2 files changed, 24 insertions, 0 deletions
diff --git a/comms/dcf77pi/Makefile b/comms/dcf77pi/Makefile
index 70efe45b8781..d297351c650a 100644
--- a/comms/dcf77pi/Makefile
+++ b/comms/dcf77pi/Makefile
@@ -3,6 +3,7 @@
PORTNAME= dcf77pi
PORTVERSION= 3.1.0
+PORTREVISION= 1
CATEGORIES= comms
MAINTAINER= rene@FreeBSD.org
@@ -16,6 +17,7 @@ GH_COMMIT= d441662
USES= ncurses
+PATCH_STRIP= -p1
PORTDOCS= README.md
INSTALL_TARGET= install-strip
diff --git a/comms/dcf77pi/files/patch-d3ab071 b/comms/dcf77pi/files/patch-d3ab071
new file mode 100644
index 000000000000..87cd6b30d910
--- /dev/null
+++ b/comms/dcf77pi/files/patch-d3ab071
@@ -0,0 +1,22 @@
+commit d3ab071432f052c799dc5c77035913423abd16c4
+Author: René Ladan <r.c.ladan@gmail.com>
+Date: Sun Jul 20 12:44:57 2014 +0200
+
+ dcf77pi: fix display of freq_reset
+
+diff --git a/dcf77pi.c b/dcf77pi.c
+index 2e46911..ce61d51 100644
+--- a/dcf77pi.c
++++ b/dcf77pi.c
+@@ -218,9 +218,9 @@ display_bit_gui(uint16_t state, int bitpos)
+ bitinf->realfreq, (int)bitinf->bit0, (int)bitinf->bit20,
+ bitinf->maxone * 100, bitinf->a);
+ if (bitinf->freq_reset)
+- mvwchgat(input_win, 3, 24, 8, A_BOLD, 3, NULL);
++ mvwchgat(input_win, 3, 22, 8, A_BOLD, 3, NULL);
+ else
+- mvwchgat(input_win, 3, 24, 8, A_NORMAL, 7, NULL);
++ mvwchgat(input_win, 3, 22, 8, A_NORMAL, 7, NULL);
+
+ mvwprintw(input_win, 3, 1, "%2u", bitpos);
+