aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornovel <novel@FreeBSD.org>2008-06-15 12:53:15 +0800
committernovel <novel@FreeBSD.org>2008-06-15 12:53:15 +0800
commitcbe4bf1a3f66d51e5d0df4f3525c9b8043730ed8 (patch)
tree32f26edc0c1f1ffe32caf48be1b0176cd422a99a
parent9c40b5845497d0bb78cde398e6fa58ec3b79b13c (diff)
downloadfreebsd-ports-gnome-cbe4bf1a3f66d51e5d0df4f3525c9b8043730ed8.tar.gz
freebsd-ports-gnome-cbe4bf1a3f66d51e5d0df4f3525c9b8043730ed8.tar.zst
freebsd-ports-gnome-cbe4bf1a3f66d51e5d0df4f3525c9b8043730ed8.zip
Add WITHOUT_OPENCDK and WITHOUT_LIBTASN1 knobs to respect if the
user wishes to build gnutls with the included versions instead of the ones from ports. PR: 121357 Submitted by: Naram Qashat <cyberbotx@cyberbotx.com>
-rw-r--r--security/gnutls/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/security/gnutls/Makefile b/security/gnutls/Makefile
index 5b3b6f4056fd..1c2ccbe50fc2 100644
--- a/security/gnutls/Makefile
+++ b/security/gnutls/Makefile
@@ -39,12 +39,16 @@ CONFIGURE_ARGS+= --with-included-lzo --disable-guile
MANCOMPRESSED= no
.include <bsd.port.pre.mk>
-.if defined(WITH_OPENCDK) || exists(${LOCALBASE}/lib/libopencdk.so.10)
+.if (defined(WITH_OPENCDK) || exists(${LOCALBASE}/lib/libopencdk.so.10)) && !defined(WITHOUT_OPENCDK)
LIB_DEPENDS+= opencdk.10:${PORTSDIR}/security/opencdk
+.else
+CONFIGURE_ARGS+= --with-included-opencdk
.endif
-.if defined(WITH_LIBTASN1) || exists(${LOCALBASE}/lib/libtasn1.so.3)
+.if (defined(WITH_LIBTASN1) || exists(${LOCALBASE}/lib/libtasn1.so.3)) && !defined(WITHOUT_LIBTASN1)
LIB_DEPENDS+= tasn1.3:${PORTSDIR}/security/libtasn1
+.else
+CONFIGURE_ARGS+= --with-included-libtasn1
.endif
.if ${OSVERSION} < 600000