aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsheldonh <sheldonh@FreeBSD.org>2002-08-27 22:39:58 +0800
committersheldonh <sheldonh@FreeBSD.org>2002-08-27 22:39:58 +0800
commitcc95437447ad72818919ed5739e38199a558583d (patch)
treeda9501b3b38b80664ebf78a9daaacc9fcefcf7b9
parentca6dc79b5e2612855ba9e1126a1e72b824edbfa2 (diff)
downloadfreebsd-ports-gnome-cc95437447ad72818919ed5739e38199a558583d.tar.gz
freebsd-ports-gnome-cc95437447ad72818919ed5739e38199a558583d.tar.zst
freebsd-ports-gnome-cc95437447ad72818919ed5739e38199a558583d.zip
Add perl5 module Config::General, for handling Apache-style configuration
files.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Config-General/Makefile23
-rw-r--r--devel/p5-Config-General/distinfo1
-rw-r--r--devel/p5-Config-General/pkg-comment1
-rw-r--r--devel/p5-Config-General/pkg-descr4
-rw-r--r--devel/p5-Config-General/pkg-plist8
6 files changed, 38 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index f50621586491..d3ccbd9e79ca 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -414,6 +414,7 @@
SUBDIR += p5-Class-Trigger
SUBDIR += p5-Class-WhiteHole
SUBDIR += p5-Clone
+ SUBDIR += p5-Config-General
SUBDIR += p5-Config-Ini
SUBDIR += p5-Config-IniFiles
SUBDIR += p5-Config-Setting
diff --git a/devel/p5-Config-General/Makefile b/devel/p5-Config-General/Makefile
new file mode 100644
index 000000000000..e2f7517ae731
--- /dev/null
+++ b/devel/p5-Config-General/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: p5-Config-General
+# Date created: August 27 2002
+# Whom: Sheldon Hearn <sheldonh@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Config-General
+PORTVERSION= 2.07
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Config
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sheldonh@FreeBSD.org
+
+PERL_CONFIGURE= YES
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Config::General::Extended.3 Config::General::Interpolated.3 \
+ Config::General.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Config-General/distinfo b/devel/p5-Config-General/distinfo
new file mode 100644
index 000000000000..f11a4dc0aaad
--- /dev/null
+++ b/devel/p5-Config-General/distinfo
@@ -0,0 +1 @@
+MD5 (Config-General-2.07.tar.gz) = 1cf2ee00bba4b3e26abb3b67921b1d3a
diff --git a/devel/p5-Config-General/pkg-comment b/devel/p5-Config-General/pkg-comment
new file mode 100644
index 000000000000..8c8719577a5f
--- /dev/null
+++ b/devel/p5-Config-General/pkg-comment
@@ -0,0 +1 @@
+Perl5 module for handling Apache-style configuration files
diff --git a/devel/p5-Config-General/pkg-descr b/devel/p5-Config-General/pkg-descr
new file mode 100644
index 000000000000..3b41aa491d3b
--- /dev/null
+++ b/devel/p5-Config-General/pkg-descr
@@ -0,0 +1,4 @@
+Config::General handles configuration files of a format inspired by
+Apache's httpd.conf file format. It features some enhancements such
+as here-documents, C-style commends and multiline options. Both
+reading and writing of configuration files is supported.
diff --git a/devel/p5-Config-General/pkg-plist b/devel/p5-Config-General/pkg-plist
new file mode 100644
index 000000000000..8ebadc457c03
--- /dev/null
+++ b/devel/p5-Config-General/pkg-plist
@@ -0,0 +1,8 @@
+lib/perl5/site_perl/%%PERL_VER%%/Config/General.pm
+lib/perl5/site_perl/%%PERL_VER%%/Config/General/Extended.pm
+lib/perl5/site_perl/%%PERL_VER%%/Config/General/Interpolated.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Config/General/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Config/General
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Config 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Config/General 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Config 2>/dev/null || true