aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-10-11 20:58:20 +0800
committermiwi <miwi@FreeBSD.org>2009-10-11 20:58:20 +0800
commitcccc515766b07bdf8eea8abb5a32215b71581842 (patch)
tree9cd71858e34a982aed705ed3e2a6241524591418
parent1a8294f75b3c85de6c4691ba217904447cf2541d (diff)
downloadfreebsd-ports-gnome-cccc515766b07bdf8eea8abb5a32215b71581842.tar.gz
freebsd-ports-gnome-cccc515766b07bdf8eea8abb5a32215b71581842.tar.zst
freebsd-ports-gnome-cccc515766b07bdf8eea8abb5a32215b71581842.zip
The HTML::Query module provides jQuery-like selection queries for
HTML::Element. WWW: http://search.cpan.org/dist/HTML-Query PR: ports/139439 Submitted by: Vivek Khera <vivek at khera.org>
-rw-r--r--finance/Makefile1
-rw-r--r--finance/p5-HTML-Query/Makefile28
-rw-r--r--finance/p5-HTML-Query/distinfo3
-rw-r--r--finance/p5-HTML-Query/pkg-descr4
-rw-r--r--www/p5-HTML-Query/Makefile28
-rw-r--r--www/p5-HTML-Query/distinfo3
-rw-r--r--www/p5-HTML-Query/pkg-descr4
7 files changed, 71 insertions, 0 deletions
diff --git a/finance/Makefile b/finance/Makefile
index e3379c392234..23396c487c4f 100644
--- a/finance/Makefile
+++ b/finance/Makefile
@@ -69,6 +69,7 @@
SUBDIR += p5-Finance-TW-EmergingQuote
SUBDIR += p5-Finance-TW-TSEQuote
SUBDIR += p5-Finance-YahooQuote
+ SUBDIR += p5-HTML-Query
SUBDIR += p5-Locale-Currency-Format
SUBDIR += p5-Math-Financial
SUBDIR += p5-PFProAPI
diff --git a/finance/p5-HTML-Query/Makefile b/finance/p5-HTML-Query/Makefile
new file mode 100644
index 000000000000..9278f8629e74
--- /dev/null
+++ b/finance/p5-HTML-Query/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-HTML-Query
+# Date created: Wed Oct 24 10:09:12 EDT 2007
+# Whom: Vivek Khera <vivek@khera.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML-Query
+PORTVERSION= 0.02
+CATEGORIES= finance perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../by-authors/id/A/AB/ABW
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= vivek@khera.org
+COMMENT= JQuery-like selection queries for HTML::Element
+
+RUN_DEPENDS+= p5-Badger>0.0:${PORTSDIR}/devel/p5-Badger \
+ p5-HTML-Tree>=3.23:${PORTSDIR}/www/p5-HTML-Tree
+
+PERL_CONFIGURE= yes
+
+MAN3= HTML::Query.3
+PLIST_FILES= %%SITE_PERL%%/HTML/Query.pm \
+ %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML-Query/.packlist
+PLIST_DIRS= %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML-Query
+
+.include <bsd.port.mk>
diff --git a/finance/p5-HTML-Query/distinfo b/finance/p5-HTML-Query/distinfo
new file mode 100644
index 000000000000..c922c7b5bf50
--- /dev/null
+++ b/finance/p5-HTML-Query/distinfo
@@ -0,0 +1,3 @@
+MD5 (HTML-Query-0.02.tar.gz) = 97c72e38de74dce3c748037a42bb00e3
+SHA256 (HTML-Query-0.02.tar.gz) = 4b33a9728bf5b09b8d99878a3b4d66f21176c92a1123a490bbdd52561a4887ff
+SIZE (HTML-Query-0.02.tar.gz) = 11973
diff --git a/finance/p5-HTML-Query/pkg-descr b/finance/p5-HTML-Query/pkg-descr
new file mode 100644
index 000000000000..1d9d93856f70
--- /dev/null
+++ b/finance/p5-HTML-Query/pkg-descr
@@ -0,0 +1,4 @@
+The HTML::Query module provides jQuery-like selection queries for
+HTML::Element.
+
+WWW: http://search.cpan.org/dist/HTML-Query
diff --git a/www/p5-HTML-Query/Makefile b/www/p5-HTML-Query/Makefile
new file mode 100644
index 000000000000..9278f8629e74
--- /dev/null
+++ b/www/p5-HTML-Query/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-HTML-Query
+# Date created: Wed Oct 24 10:09:12 EDT 2007
+# Whom: Vivek Khera <vivek@khera.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML-Query
+PORTVERSION= 0.02
+CATEGORIES= finance perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../by-authors/id/A/AB/ABW
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= vivek@khera.org
+COMMENT= JQuery-like selection queries for HTML::Element
+
+RUN_DEPENDS+= p5-Badger>0.0:${PORTSDIR}/devel/p5-Badger \
+ p5-HTML-Tree>=3.23:${PORTSDIR}/www/p5-HTML-Tree
+
+PERL_CONFIGURE= yes
+
+MAN3= HTML::Query.3
+PLIST_FILES= %%SITE_PERL%%/HTML/Query.pm \
+ %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML-Query/.packlist
+PLIST_DIRS= %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML-Query
+
+.include <bsd.port.mk>
diff --git a/www/p5-HTML-Query/distinfo b/www/p5-HTML-Query/distinfo
new file mode 100644
index 000000000000..c922c7b5bf50
--- /dev/null
+++ b/www/p5-HTML-Query/distinfo
@@ -0,0 +1,3 @@
+MD5 (HTML-Query-0.02.tar.gz) = 97c72e38de74dce3c748037a42bb00e3
+SHA256 (HTML-Query-0.02.tar.gz) = 4b33a9728bf5b09b8d99878a3b4d66f21176c92a1123a490bbdd52561a4887ff
+SIZE (HTML-Query-0.02.tar.gz) = 11973
diff --git a/www/p5-HTML-Query/pkg-descr b/www/p5-HTML-Query/pkg-descr
new file mode 100644
index 000000000000..1d9d93856f70
--- /dev/null
+++ b/www/p5-HTML-Query/pkg-descr
@@ -0,0 +1,4 @@
+The HTML::Query module provides jQuery-like selection queries for
+HTML::Element.
+
+WWW: http://search.cpan.org/dist/HTML-Query