aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2017-01-19 22:07:26 +0800
committermat <mat@FreeBSD.org>2017-01-19 22:07:26 +0800
commitcd1441dbdd484f2e815cb03dcf2255170ddc6ca5 (patch)
treebba7f96d23311d1cb70dada0dcabac1bd5cef307
parent086f40b462d5f9644052aa1e98b263b9e7a1eac7 (diff)
downloadfreebsd-ports-gnome-cd1441dbdd484f2e815cb03dcf2255170ddc6ca5.tar.gz
freebsd-ports-gnome-cd1441dbdd484f2e815cb03dcf2255170ddc6ca5.tar.zst
freebsd-ports-gnome-cd1441dbdd484f2e815cb03dcf2255170ddc6ca5.zip
Improve the error message when conflicting OPTIONS_RADIO or
OPTIONS_SINGLE are defined. PR: 216150 Submitted by: stb lassitu de Sponsored by: Absolight
-rw-r--r--Mk/bsd.port.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index bf9392c70b3c..12d607d842ff 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -4616,6 +4616,7 @@ pre-check-config:
. for opt in ${OPTIONS_SINGLE_${single}}
. if empty(ALL_OPTIONS:M${single}) || !empty(PORT_OPTIONS:M${single})
. if !empty(PORT_OPTIONS:M${opt})
+OPTIONS_WRONG_SINGLE_${single}+= ${opt}
. if defined(OPTFOUND)
OPTIONS_WRONG_SINGLE+= ${single}
. else
@@ -4640,6 +4641,7 @@ OPTIONS_WRONG_SINGLE+= ${single}
.for radio in ${OPTIONS_RADIO}
. for opt in ${OPTIONS_RADIO_${radio}}
. if !empty(PORT_OPTIONS:M${opt})
+OPTIONS_WRONG_RADIO_${radio}+= ${opt}
. if defined(OPTFOUND)
OPTIONS_WRONG_RADIO+= ${radio}
. else
@@ -4692,9 +4694,11 @@ _check-config: pre-check-config
.endfor
.for single in ${OPTIONS_WRONG_SINGLE}
@${ECHO_MSG} "====> You must select one and only one option from the ${single} single"
+ @${ECHO_MSG} "=====> Only one of these must be defined: ${OPTIONS_WRONG_SINGLE_${single}}"
.endfor
.for radio in ${OPTIONS_WRONG_RADIO}
@${ECHO_MSG} "====> You cannot select multiple options from the ${radio} radio"
+ @${ECHO_MSG} "=====> Only one of these must be defined: ${OPTIONS_WRONG_RADIO_${radio}}"
.endfor
.if defined(OPTIONS_WRONG_PREVENTS)
@${ECHO_MSG} "====> Two or more enabled options conflict with each other"