aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2008-03-18 09:06:46 +0800
committerwxs <wxs@FreeBSD.org>2008-03-18 09:06:46 +0800
commitcd2e05450a08d0e1838dee7835ab3e9a8d9dd042 (patch)
tree4c3f74fb6dbf8d48d36eb7ddccb96611a7213be5
parent6e059d68ea537b8ceaf50e0a29b1ad4e717955a0 (diff)
downloadfreebsd-ports-gnome-cd2e05450a08d0e1838dee7835ab3e9a8d9dd042.tar.gz
freebsd-ports-gnome-cd2e05450a08d0e1838dee7835ab3e9a8d9dd042.tar.zst
freebsd-ports-gnome-cd2e05450a08d0e1838dee7835ab3e9a8d9dd042.zip
Update to 1.1.1
Take maintainership. Enable debugging (so silcd can generate better logs) General cleanups. Approved by: garga (mentor)
-rw-r--r--net/silc-server/Makefile45
-rw-r--r--net/silc-server/distinfo6
-rw-r--r--net/silc-server/files/patch-apps:silcd:Makefile.in19
-rw-r--r--net/silc-server/files/patch-doc:example_silcd.conf.in20
-rw-r--r--net/silc-server/files/patch-lib:silcsim:Makefile.in11
-rw-r--r--net/silc-server/files/pkg-deinstall.in20
-rw-r--r--net/silc-server/files/pkg-message.in5
-rw-r--r--net/silc-server/files/silcd.in (renamed from net/silc-server/files/silcd.sh)0
-rw-r--r--net/silc-server/pkg-install90
-rw-r--r--net/silc-server/pkg-plist11
10 files changed, 62 insertions, 165 deletions
diff --git a/net/silc-server/Makefile b/net/silc-server/Makefile
index 3b3dedc1bb36..dda0b1613800 100644
--- a/net/silc-server/Makefile
+++ b/net/silc-server/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= silc
-PORTVERSION= 1.0.3
+PORTVERSION= 1.1.1
CATEGORIES= net ipv6 security
MASTER_SITES= http://www.silcnet.org/download/%SUBDIR%/ \
http://ftp.silcnet.org/%SUBDIR%/ \
@@ -24,25 +24,22 @@ MASTER_SITE_SUBDIR= server/sources
PKGNAMESUFFIX= -server
DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= wxs@FreeBSD.org
COMMENT= Secure Internet Live Conferencing (SILC) network server
-BROKEN= Leaves files behind on deinstall
-
+SUB_FILES= pkg-message pkg-deinstall
+USE_RC_SUBR= silcd
USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
+CONFIGURE_ENV= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS} ${PTHREAD_LIBS}"
CONFIGURE_ARGS= --with-silcd-config-file=${PREFIX}/etc/${PORTNAME}/silcd.conf \
- --with-etcdir=${PREFIX}/etc/${PORTNAME} \
+ --sysconfdir=${PREFIX}/etc/${PORTNAME} \
--with-helpdir=share/${PORTNAME}/help \
--with-logsdir=/var/log/${PORTNAME} \
--with-silcd-pid-file=/var/run/silcd.pid \
- --enable-ipv6
-
-PLIST_SUB= INSTALL_DIR="${INSTALL_DIR}"
-PKGDEINSTALL= ${PKGINSTALL}
-
-INSTALL_DIR?= ${INSTALL} -d -o ${BINOWN} -g ${BINGRP} -m 755
+ --enable-ipv6 \
+ --enable-debug
MAN5= silcd.conf.5
MAN8= silcd.8
@@ -57,24 +54,10 @@ WITHOUT_OPTIMIZED_ASM= yes
CONFIGURE_ARGS+= --disable-asm
.endif
-.ifndef(WITH_PTHREADS)
-CONFIGURE_ARGS+= --without-pthreads
-.else
-CONFIGURE_ENV+= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS} ${PTHREAD_LIBS}"
-.endif
-
pre-everything::
.ifndef(WITHOUT_OPTIMIZED_ASM)
@${ECHO_MSG} '===> Define WITHOUT_OPTIMIZED_ASM to disable assembler optimizations'
.endif
-.ifndef(WITH_PTHREADS)
- @${ECHO_MSG} '===> Define WITH_PTHREADS to enable pthreads support'
-.endif
- @${ECHO_MSG}
-
-post-extract:
- @${SED} -e "s=%%PREFIX%%=${PREFIX}=g" ${FILESDIR}/silcd.sh \
- > ${WRKSRC}/silcd.sh
post-patch:
.ifdef(NOPORTDOCS)
@@ -86,12 +69,12 @@ post-patch:
${WRKSRC}/lib/silccrypt/Makefile.in
post-install:
- @${SETENV} PKG_PREFIX=${PREFIX} ${SH} \
- ${PKGINSTALL} ${PKGNAME} POST-INSTALL
- ${INSTALL_DATA} ${WRKSRC}/silcd.sh ${PREFIX}/etc/rc.d/silcd.sh-dist
- @if [ ! -f ${PREFIX}/etc/rc.d/silcd.sh ]; then \
- ${ECHO} "Installing ${PREFIX}/etc/rc.d/silcd.sh startup file."; \
- ${INSTALL_SCRIPT} ${WRKSRC}/silcd.sh ${PREFIX}/etc/rc.d/silcd.sh; \
+ @if [ ! -f ${PREFIX}/etc/silc/silcd.conf ]; then \
+ ${CP} -p ${PREFIX}/etc/silc/silcd.conf.sample ${PREFIX}/etc//silc/silcd.conf; \
+ fi
+ @if [ ! -f ${PREFIX}/etc/silc/silcalgs.conf ]; then \
+ ${CP} -p ${PREFIX}/etc/silc/silcalgs.conf.sample ${PREFIX}/etc/silc/silcalgs.conf; \
fi
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/net/silc-server/distinfo b/net/silc-server/distinfo
index 6fd2d7bfae7c..d03ca43239f9 100644
--- a/net/silc-server/distinfo
+++ b/net/silc-server/distinfo
@@ -1,3 +1,3 @@
-MD5 (silc-server-1.0.3.tar.bz2) = 138ffaf5528aa412b18b3c0a38184861
-SHA256 (silc-server-1.0.3.tar.bz2) = e7c43aebe7a48326c381e8b89c394fc3b7177cd1495da82612bad223be85fb67
-SIZE (silc-server-1.0.3.tar.bz2) = 895374
+MD5 (silc-server-1.1.1.tar.bz2) = 1536791c9cfb557600a360a7cddbe659
+SHA256 (silc-server-1.1.1.tar.bz2) = ef0b8352897dc953921cd3eb9685065e02fefc4d8c2678c2f24574a8e7438caa
+SIZE (silc-server-1.1.1.tar.bz2) = 1016071
diff --git a/net/silc-server/files/patch-apps:silcd:Makefile.in b/net/silc-server/files/patch-apps:silcd:Makefile.in
index 64286065a883..e0a053af6723 100644
--- a/net/silc-server/files/patch-apps:silcd:Makefile.in
+++ b/net/silc-server/files/patch-apps:silcd:Makefile.in
@@ -1,6 +1,6 @@
---- apps/silcd/Makefile.in.orig Wed Dec 14 15:47:35 2005
-+++ apps/silcd/Makefile.in Mon Aug 21 21:53:39 2006
-@@ -358,8 +358,8 @@
+--- apps/silcd/Makefile.in.orig 2007-11-18 07:37:58.000000000 -0500
++++ apps/silcd/Makefile.in 2008-01-03 00:30:42.000000000 -0500
+@@ -350,8 +350,8 @@
|| test -f $$p1 \
; then \
f=`echo "$$p1" | sed 's,^.*/,,;$(transform);s/$$/$(EXEEXT)/'`; \
@@ -11,7 +11,7 @@
else :; fi; \
done
-@@ -579,14 +579,11 @@
+@@ -576,14 +576,11 @@
install-dirs-server:
@@ -26,18 +26,19 @@
-@if test -f $(top_srcdir)/doc/silcd.8 ; then \
$(INSTALL_DATA) $(top_srcdir)/doc/silcd.8 $(mandir)/man8; \
fi
-@@ -597,20 +594,18 @@
+@@ -592,22 +589,17 @@
+ fi
+
etc-install-server:
- -@if test '!' -f $(etcdir)/silcd.conf ; then \
+- -@if test '!' -f $(etcdir)/silcd.conf ; then \
$(INSTALL_DATA) $(top_srcdir)/doc/example_silcd.conf \
- $(etcdir)/silcd.conf; \
+ $(etcdir)/silcd.conf.sample; \
$(INSTALL_DATA) $(top_srcdir)/doc/silcalgs.conf \
- $(etcdir)/silcalgs.conf; \
- chmod go= $(etcdir)/silcd.conf; \
-+ $(etcdir)/silcalgs.conf.sample; \
-+ chmod go= $(etcdir)/silcd.conf.sample; \
- fi
+- fi
++ $(etcdir)/silcalgs.conf.sample;
examples-install:
- -mkdir -p $(docdir)/examples/
diff --git a/net/silc-server/files/patch-doc:example_silcd.conf.in b/net/silc-server/files/patch-doc:example_silcd.conf.in
index 941fb875cf98..2656c89fbe4c 100644
--- a/net/silc-server/files/patch-doc:example_silcd.conf.in
+++ b/net/silc-server/files/patch-doc:example_silcd.conf.in
@@ -1,5 +1,5 @@
---- doc/example_silcd.conf.in.orig Mon Oct 27 12:06:06 2003
-+++ doc/example_silcd.conf.in Mon Oct 27 12:07:47 2003
+--- doc/example_silcd.conf.in.orig 2007-11-04 03:39:39.000000000 -0500
++++ doc/example_silcd.conf.in 2007-12-26 11:51:20.000000000 -0500
@@ -22,7 +22,6 @@
# Include global algorithms from the "silcalgs.conf" file. This file defines
# ciphers, hash functions, HMACs and PKCS algorithms that can be used.
@@ -8,19 +8,7 @@
#
# General configuration options
-@@ -32,11 +31,6 @@
- # for different connections.
- #
- General {
-- # This is the default path where to search modules. If omitted
-- # built-in modules will be used. Built-in modules will also be
-- # used if a module file cannot be located.
-- module_path = "@MODULESDIR@";
--
- # If both passphrase and public key authentication is set for a
- # connection the public key authentication is the preferred one
- # to use. Set this to `true' to prefer passphrase authentication
-@@ -466,13 +460,13 @@
+@@ -482,13 +481,13 @@
# to true. For normal connections set it false. If it is set to true then
# your server will be backup router.
#
@@ -41,7 +29,7 @@
#
# Configured router connections
-@@ -502,17 +496,17 @@
+@@ -518,17 +517,17 @@
# backup router is in our cell then set the "BackupLocal" option to true.
# If the backup router is in other cell then set it to false.
#
diff --git a/net/silc-server/files/patch-lib:silcsim:Makefile.in b/net/silc-server/files/patch-lib:silcsim:Makefile.in
deleted file mode 100644
index 945b162dc16b..000000000000
--- a/net/silc-server/files/patch-lib:silcsim:Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/silcsim/Makefile.in.orig Wed Dec 14 15:47:35 2005
-+++ lib/silcsim/Makefile.in Thu Aug 10 13:30:43 2006
-@@ -563,8 +563,6 @@
- # Installation
- #
- install-data-hook:
-- -mkdir -p $(modulesdir)
-- -$(INSTALL_DATA) $(top_srcdir)/lib/silcsim/*.so $(modulesdir)/
-
- @INCLUDE_DEFINES_INT@
-
diff --git a/net/silc-server/files/pkg-deinstall.in b/net/silc-server/files/pkg-deinstall.in
new file mode 100644
index 000000000000..f0fe894b3e4c
--- /dev/null
+++ b/net/silc-server/files/pkg-deinstall.in
@@ -0,0 +1,20 @@
+#!/bin/sh
+# $FreeBSD$
+
+KEY_FILES="silcd.prv silcd.pub"
+
+case "$2" in
+POST-DEINSTALL)
+ if [ -f %%PREFIX%%/etc/silc/silcd.prv -o -f %%PREFIX%%/etc/silc/silcd.pub ]; then
+ echo "$1: The following files were left behind:"
+ for key_file in ${KEY_FILES}
+ do
+ [ -f %%PREFIX%%/etc/silc/${key_file} ] && echo "%%PREFIX%%/etc/silc/${key_file}"
+ done
+ echo "$1: If this port is not used anymore please remove them."
+ fi
+ ;;
+*)
+ ;;
+esac
+exit
diff --git a/net/silc-server/files/pkg-message.in b/net/silc-server/files/pkg-message.in
new file mode 100644
index 000000000000..725f6d53c29a
--- /dev/null
+++ b/net/silc-server/files/pkg-message.in
@@ -0,0 +1,5 @@
+******************************************************
+You will need to edit %%PREFIX%%/etc/silc/silcd.conf
+and make sure to change permissions to 400 if it
+contains sensitive information.
+******************************************************
diff --git a/net/silc-server/files/silcd.sh b/net/silc-server/files/silcd.in
index 16988485fb2c..16988485fb2c 100644
--- a/net/silc-server/files/silcd.sh
+++ b/net/silc-server/files/silcd.in
diff --git a/net/silc-server/pkg-install b/net/silc-server/pkg-install
deleted file mode 100644
index 73788f8030a5..000000000000
--- a/net/silc-server/pkg-install
+++ /dev/null
@@ -1,90 +0,0 @@
-#!/bin/sh
-# $FreeBSD$
-
-# based on original from op port, written by Cyrille Lefevre
-# <clefevre@citeweb.net>
-
-[ $# != 2 ] && exit 1
-PKGNAME=$1
-ACTION=$2
-
-
-CONF_DIR=${PKG_PREFIX}/etc/silc
-
-SILC_DAEMON=${PKG_PREFIX}/sbin/silcd
-KEY_FILES="silcd.prv silcd.pub"
-
-CONF_FILE=silcd.conf
-CONF_OWN=root
-CONF_GRP=wheel
-CONF_MODE=0600
-
-SAMP_SUFX=.sample
-
-INSTALL=install
-CMP=cmp
-FMT=fmt
-RM=rm
-RMDIR=rmdir
-
-INSTALL_DIR="${INSTALL} -d -o root -g wheel -m 755"
-
-case "$ACTION" in
-
-POST-INSTALL)
- if [ -f "${CONF_DIR}/${CONF_FILE}" ]
- then
- echo "$PKGNAME: Will not overwrite existing ${CONF_DIR}/${CONF_FILE} configuration file."
- else
- ${INSTALL} -c -o ${CONF_OWN} -g ${CONF_GRP} -m ${CONF_MODE} \
- ${CONF_DIR}/${CONF_FILE}${SAMP_SUFX} \
- ${CONF_DIR}/${CONF_FILE}
- fi
- if [ -f ${CONF_DIR}/silcd.prv -o -f ${CONF_DIR}/silcd.pub ]
- then
- echo "$PKGNAME: Will not overwrite existing PUBLIC KEY PAIRS in ${CONF_DIR}."
- echo "$PKGNAME: Remove them if you both want new keys and know what you are doing, deinstall this package and install again." | ${FMT}
- echo "$PKGNAME: To remove the old keys:"
- for key_file in ${KEY_FILES}
- do
- [ -f ${CONF_DIR}/${key_file} ] && echo "$PKGNAME: rm -f ${CONF_DIR}/${key_file}"
- done
- else
- ${SILC_DAEMON} -C ${CONF_DIR}
- fi
- ${INSTALL_DIR} ${PKG_PREFIX}/silc/logs
- ;;
-
-DEINSTALL)
- if ${CMP} -s ${CONF_DIR}/${CONF_FILE}${SAMP_SUFX} \
- ${CONF_DIR}/${CONF_FILE}; then
- ${RM} -f ${CONF_DIR}/${CONF_FILE}
- else
- echo "$PKGNAME: Will not remove existing ${CONF_DIR}/${CONF_FILE} configuration file."
- echo "$PKGNAME: Remove it manually if you know what you are doing:"
- echo "$PKGNAME: rm -f ${CONF_DIR}/${CONF_FILE}"
- fi
- echo "$PKGNAME: Will not remove remaining PUBLIC KEY PAIRS."
- echo "$PKGNAME: If you want to remove any remaining PUBLIC KEY PAIRS:"
- for key_file in ${KEY_FILES}
- do
- [ -f ${CONF_DIR}/${key_file} ] && echo "$PKGNAME: rm -f ${CONF_DIR}/${key_file}"
- done
- echo "$PKGNAME: Also, do not forget to 'rmdir ${CONF_DIR} 2>/dev/null'"
-
- ${RMDIR} ${PKG_PREFIX}/silc/logs 2>/dev/null
- if [ -d ${PKG_PREFIX}/silc ]
- then
- ${RMDIR} ${PKG_PREFIX}/silc 2>/dev/null || echo "$PKGNAME: Will not remove silc server logs. If permanently removing the port, 'rm -Rf ${PKG_PREFIX}/silc'"
- fi
- ;;
-
-PRE-INSTALL|POST-DEINSTALL)
- ;;
-
-*)
- exit 1
- ;;
-esac
-
-exit
diff --git a/net/silc-server/pkg-plist b/net/silc-server/pkg-plist
index 7ff0db593ebd..a86285e738da 100644
--- a/net/silc-server/pkg-plist
+++ b/net/silc-server/pkg-plist
@@ -1,9 +1,10 @@
-etc/silc/silcalgs.conf.sample
-etc/silc/silcd.conf.sample
sbin/silcd
-@unexec if cmp -s %D/etc/rc.d/silcd.sh %D/etc/rc.d/silcd.sh-dist; then rm -f %D/etc/rc.d/silcd.sh; fi
-etc/rc.d/silcd.sh-dist
-@exec [ -f %B/silcd.sh ] || ( cp %B/%f %B/silcd.sh; chmod 755 %B/silcd.sh )
+@unexec if cmp -s %D/etc/silc/silcd.conf.sample %D/etc/silc/silcd.conf; then rm -f %D/etc/silc/silcd.conf; fi
+etc/silc/silcd.conf.sample
+@exec if [ ! -f %D/etc/silc/silcd.conf ] ; then cp -p %D/%F %B/silcd.conf; fi
+@unexec if cmp -s %D/etc/silc/silcalgs.conf.sample %D/etc/silc/silcalgs.conf; then rm -f %D/etc/silc/silcalgs.conf; fi
+etc/silc/silcalgs.conf.sample
+@exec if [ ! -f %D/etc/silc/silcalgs.conf ] ; then cp -p %D/%F %B/silcalgs.conf; fi
%%PORTDOCS%%%%EXAMPLESDIR%%/README
%%PORTDOCS%%%%EXAMPLESDIR%%/cell_backup.conf
%%PORTDOCS%%%%EXAMPLESDIR%%/cell_router.conf