aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpetef <petef@FreeBSD.org>2001-08-31 13:43:57 +0800
committerpetef <petef@FreeBSD.org>2001-08-31 13:43:57 +0800
commitcdaf71e4f2baa702270c35214c1aba4cded27f94 (patch)
tree8d825f1c4da06a3ec5594ac4e943347259d939eb
parentd35ae48fd818386b5ca1f38476fa02fd956c5715 (diff)
downloadfreebsd-ports-gnome-cdaf71e4f2baa702270c35214c1aba4cded27f94.tar.gz
freebsd-ports-gnome-cdaf71e4f2baa702270c35214c1aba4cded27f94.tar.zst
freebsd-ports-gnome-cdaf71e4f2baa702270c35214c1aba4cded27f94.zip
add tpop3d 1.3.4
Virtual-domain capable POP3 server supporting MySQL auth PR: 29265 Submitted by: Chris Elsworth <chris@shagged.org>
-rw-r--r--mail/Makefile1
-rw-r--r--mail/tpop3d/Makefile63
-rw-r--r--mail/tpop3d/distinfo1
-rw-r--r--mail/tpop3d/files/tpop3d.conf.dist7
-rw-r--r--mail/tpop3d/files/tpop3d.sh.sample45
-rw-r--r--mail/tpop3d/pkg-comment1
-rw-r--r--mail/tpop3d/pkg-descr9
-rw-r--r--mail/tpop3d/pkg-plist5
8 files changed, 132 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 91b3b1a00784..ff0abc756611 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -197,6 +197,7 @@
SUBDIR += tkrat2
SUBDIR += tlb
SUBDIR += tmda
+ SUBDIR += tpop3d
SUBDIR += vbsfilter
SUBDIR += vm-pop3d
SUBDIR += vpopmail
diff --git a/mail/tpop3d/Makefile b/mail/tpop3d/Makefile
new file mode 100644
index 000000000000..d3872219c0c8
--- /dev/null
+++ b/mail/tpop3d/Makefile
@@ -0,0 +1,63 @@
+# New ports collection makefile for: tpop3d
+# Date created: 27 July 2001
+# Whom: chris@shagged.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= tpop3d
+PORTVERSION= 1.3.4
+CATEGORIES= mail
+MASTER_SITES= http://www.ex-parrot.com/~chris/tpop3d/
+
+MAINTAINER= chris@shagged.org
+
+# mysql authentication
+.if !defined(WITHOUT_MYSQL)
+LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
+.endif
+
+# perl authentication
+.if defined(WITH_PERLAUTH)
+USE_PERL5= yes
+.endif
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-auth-other \
+ --with-mailspool-directory=/var/mail
+
+.if !defined(WITHOUT_MYSQL)
+CONFIGURE_ARGS+= --enable-auth-mysql --with-mysql-root=${LOCALBASE}
+.endif
+.if defined(WITH_PERLAUTH)
+CONFIGURE_ARGS+= --enable-auth-perl
+.endif
+.if !defined(WITHOUT_MAILDIR)
+CONFIGURE_ARGS+= --enable-mbox-maildir
+.endif
+
+SAMPLE_RCD= tpop3d.sh.sample
+STARTUP_SCRIPT= ${PREFIX}/etc/rc.d/${SAMPLE_RCD}
+DEFAULT_CONFIG= ${PREFIX}/etc/tpop3d.conf.dist
+
+MAN5= tpop3d.conf.5
+MAN8= tpop3d.8
+
+post-patch:
+ @${PERL} -pi -e 's,^CFLAGS =, CFLAGS = \@CFLAGS\@,' \
+ ${WRKSRC}/Makefile.in
+ @${PERL} -pi -e 's,/etc/tpop3d,${PREFIX}/etc/tpop3d,g' \
+ ${WRKSRC}/tpop3d.conf.5 ${WRKSRC}/tpop3d.8
+
+post-install:
+ ${INSTALL_SCRIPT} ${FILESDIR}/tpop3d.conf.dist ${DEFAULT_CONFIG}
+ @if [ ! -f ${STARTUP_SCRIPT} ]; then \
+ ${INSTALL_SCRIPT} ${FILESDIR}/${SAMPLE_RCD} \
+ ${STARTUP_SCRIPT} ; \
+ fi
+ @if [ ! -f ${PREFIX}/etc/tpop3d.conf ]; then \
+ ${INSTALL_SCRIPT} ${FILESDIR}/tpop3d.conf.dist \
+ ${PREFIX}/etc/tpop3d.conf ; \
+ fi
+
+.include <bsd.port.mk>
diff --git a/mail/tpop3d/distinfo b/mail/tpop3d/distinfo
new file mode 100644
index 000000000000..72713696691a
--- /dev/null
+++ b/mail/tpop3d/distinfo
@@ -0,0 +1 @@
+MD5 (tpop3d-1.3.4.tar.gz) = c91148c4465be32b0bb5ffbbc45db971
diff --git a/mail/tpop3d/files/tpop3d.conf.dist b/mail/tpop3d/files/tpop3d.conf.dist
new file mode 100644
index 000000000000..2089501e54f4
--- /dev/null
+++ b/mail/tpop3d/files/tpop3d.conf.dist
@@ -0,0 +1,7 @@
+listen-address: 0.0.0.0
+max-children: 20
+
+mailbox: bsd:/var/mail/$(user)
+
+auth-pam-enable: yes
+
diff --git a/mail/tpop3d/files/tpop3d.sh.sample b/mail/tpop3d/files/tpop3d.sh.sample
new file mode 100644
index 000000000000..97dbd2514da1
--- /dev/null
+++ b/mail/tpop3d/files/tpop3d.sh.sample
@@ -0,0 +1,45 @@
+#!/bin/sh
+#
+# tpop3d:
+# Init script for starting/stopping tpop3d.
+#
+# Copyright (c) 2001 Chris Lightfoot. All rights reserved.
+# Portability enhanced by Chris Elsworth, July 2001
+#
+# $FreeBSD$
+#
+
+if ! PREFIX=$(expr $0 : "\(/.*\)/etc/rc\.d/$(basename $0)\$"); then
+ echo "$0: Cannot determine the PREFIX" >&2
+ exit 1
+fi
+
+DAEMON=$PREFIX/sbin/tpop3d
+
+[ -f $DAEMON ] || exit 0
+
+# See how we were called.
+case "$1" in
+ start)
+ # Start daemons.
+ $DAEMON -f $PREFIX/etc/tpop3d.conf -p /var/run/tpop3d.pid \
+ && echo -n " tpop3d"
+ ;;
+ stop)
+ # Stop daemons.
+ [ -r /var/run/tpop3d.pid ] && kill `cat /var/run/tpop3d.pid` \
+ && echo -n " tpop3d"
+ ;;
+ restart)
+ $0 stop
+ $0 start
+ ;;
+ reload)
+ [ -r /var/run/tpop3d.pid ] && kill -HUP `cat /var/run/tpop3d.pid`
+ ;;
+ *)
+ echo "Usage: `basename $0` {start|stop|restart|reload}"
+ exit 1
+esac
+
+exit 0
diff --git a/mail/tpop3d/pkg-comment b/mail/tpop3d/pkg-comment
new file mode 100644
index 000000000000..b60db53816d8
--- /dev/null
+++ b/mail/tpop3d/pkg-comment
@@ -0,0 +1 @@
+Virtual-domain capable POP3 server supporting MySQL auth
diff --git a/mail/tpop3d/pkg-descr b/mail/tpop3d/pkg-descr
new file mode 100644
index 000000000000..226e9ea7d9a6
--- /dev/null
+++ b/mail/tpop3d/pkg-descr
@@ -0,0 +1,9 @@
+tpop3d is yet-another-pop3-server. The intention has been to write
+a server which is fast, extensible, and secure. tpop3d supports
+traditional (BSD-format) mailspools and Maildir. It also supports
+MySQL, perl, and external authentication methods.
+
+WWW: http://www.ex-parrot.com/~chris/tpop3d/
+
+- Chris Elsworth
+chris@shagged.org
diff --git a/mail/tpop3d/pkg-plist b/mail/tpop3d/pkg-plist
new file mode 100644
index 000000000000..e3a2c0800a55
--- /dev/null
+++ b/mail/tpop3d/pkg-plist
@@ -0,0 +1,5 @@
+sbin/tpop3d
+etc/rc.d/tpop3d.sh.sample
+@unexec if cmp -s %D/etc/tpop3d.conf.dist %D/etc/tpop3d.conf; then rm -f %D/etc/tpop3d.conf; fi
+etc/tpop3d.conf.dist
+@exec if [ ! -f %D/etc/tpop3d.conf ]; then cp %D/etc/%f %D/etc/tpop3d.conf; fi