aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2017-07-27 01:01:57 +0800
committerjbeich <jbeich@FreeBSD.org>2017-07-27 01:01:57 +0800
commitcdcbe33ddda8321d537d156c321a2aeb0052f76e (patch)
treef0a6cbb5414fb0df3282011f73496d756075650f
parentf029e184f9cf82a720d0f84d55419064b7f80f6a (diff)
downloadfreebsd-ports-gnome-cdcbe33ddda8321d537d156c321a2aeb0052f76e.tar.gz
freebsd-ports-gnome-cdcbe33ddda8321d537d156c321a2aeb0052f76e.tar.zst
freebsd-ports-gnome-cdcbe33ddda8321d537d156c321a2aeb0052f76e.zip
devel/clanlib{22,}: unbreak on non-x86
configure: error: *** Requires SSE2 Support System/detect_cpu_ext.cpp: In static member function 'static bool CL_System::detect_cpu_extension(CL_System::CL_CPU_ExtensionX86)': System/detect_cpu_ext.cpp:62:88: error: impossible constraint in 'asm' : "=a" ((out)[0]), "=r" ((out)[1]), "=c" ((out)[2]), "=d" ((out)[3]): "a" (infoType)); ^ System/detect_cpu_ext.cpp:79:3: note: in expansion of macro '__cpuid' __cpuid((int*)cpuinfo, 0x1); ^ Reported by: pkg-fallout (aarch64)
-rw-r--r--devel/clanlib/Makefile3
-rw-r--r--devel/clanlib/files/patch-Sources_Core_System_detect__cpu__ext.cpp15
-rw-r--r--devel/clanlib22/Makefile7
-rw-r--r--devel/clanlib22/files/patch-Sources_Core_System_detect__cpu__ext.cpp15
-rw-r--r--devel/clanlib22/pkg-plist32
5 files changed, 47 insertions, 25 deletions
diff --git a/devel/clanlib/Makefile b/devel/clanlib/Makefile
index 8d751e5c4601..c8c7d6d17984 100644
--- a/devel/clanlib/Makefile
+++ b/devel/clanlib/Makefile
@@ -20,9 +20,6 @@ LIB_DEPENDS= libpng.so:graphics/png \
libfontconfig.so:x11-fonts/fontconfig \
libpcre.so:devel/pcre
-NOT_FOR_ARCHS= aarch64 armv6 powerpc powerpc64
-NOT_FOR_ARCHS_REASON= invokes x86 asm
-
USES= compiler:c++0x execinfo gmake jpeg libtool localbase:ldflags \
pathfix pkgconfig sqlite tar:tgz
USE_XORG= x11
diff --git a/devel/clanlib/files/patch-Sources_Core_System_detect__cpu__ext.cpp b/devel/clanlib/files/patch-Sources_Core_System_detect__cpu__ext.cpp
new file mode 100644
index 000000000000..b21b0fd7e9b7
--- /dev/null
+++ b/devel/clanlib/files/patch-Sources_Core_System_detect__cpu__ext.cpp
@@ -0,0 +1,15 @@
+--- Sources/Core/System/detect_cpu_ext.cpp.orig 2011-11-15 12:15:42 UTC
++++ Sources/Core/System/detect_cpu_ext.cpp
+@@ -30,6 +30,7 @@
+ #include "Core/precomp.h"
+ #include "API/Core/System/system.h"
+
++#ifndef CL_DISABLE_SSE2
+ #ifdef CL_ARM_PLATFORM
+ bool CL_System::detect_cpu_extension(CL_CPU_ExtensionPPC ext)
+ {
+@@ -183,3 +184,4 @@ bool CL_System::detect_cpu_extension(CL_CPU_ExtensionX
+ }
+
+ #endif
++#endif // not CL_DISABLE_SSE2
diff --git a/devel/clanlib22/Makefile b/devel/clanlib22/Makefile
index 042f35ba8d6e..696a754077cc 100644
--- a/devel/clanlib22/Makefile
+++ b/devel/clanlib22/Makefile
@@ -39,20 +39,15 @@ CONFIGURE_ARGS= --disable-docs \
--enable-clanNetwork \
--enable-clanGUI \
--enable-clanCSSLayout \
- --enable-clanSWRender \
--enable-clanMikMod \
--enable-clanVorbis \
--enable-getaddr
INSTALL_TARGET= install-strip
PLIST_SUB+= VER=${PORTVERSION:R} \
+ SWRENDER=${ARCH:N*86:Namd64:C/.+/"@comment "/} \
SHORT_VER=${PORTVERSION:R:R}${PORTVERSION:R:E}
-BROKEN_aarch64= fails to configure: error: Requires SSE2 Support
-BROKEN_armv6= fails to configure: error: Requires SSE2 Support
-BROKEN_powerpc64= fails to configure: error: Requires SSE2 Support
-BROKEN_sparc64= fails to configure: error: Requires SSE2 Support
-
post-patch:
@${REINPLACE_CMD} -e '/^extra_LIBS_clanSqlite/s|-ldl||g' \
${WRKSRC}/configure
diff --git a/devel/clanlib22/files/patch-Sources_Core_System_detect__cpu__ext.cpp b/devel/clanlib22/files/patch-Sources_Core_System_detect__cpu__ext.cpp
new file mode 100644
index 000000000000..6535f2a9083a
--- /dev/null
+++ b/devel/clanlib22/files/patch-Sources_Core_System_detect__cpu__ext.cpp
@@ -0,0 +1,15 @@
+--- Sources/Core/System/detect_cpu_ext.cpp.orig 2011-01-27 08:46:22 UTC
++++ Sources/Core/System/detect_cpu_ext.cpp
+@@ -30,6 +30,7 @@
+ #include "Core/precomp.h"
+ #include "API/Core/System/system.h"
+
++#ifndef CL_DISABLE_SSE2
+ #if (defined(WIN32) || defined(_WIN32) || defined(_WIN64)) && !defined __MINGW32__
+ #include <intrin.h>
+ #endif
+@@ -142,3 +143,4 @@ bool CL_System::detect_cpu_extension(CL_CPU_ExtensionX
+ return false;
+ }
+
++#endif // not CL_DISABLE_SSE2
diff --git a/devel/clanlib22/pkg-plist b/devel/clanlib22/pkg-plist
index 99cf232a11b0..fe5de1f2a321 100644
--- a/devel/clanlib22/pkg-plist
+++ b/devel/clanlib22/pkg-plist
@@ -405,16 +405,16 @@ include/ClanLib-%%VER%%/ClanLib/Network/setupnetwork.h
include/ClanLib-%%VER%%/ClanLib/RegExp/api_regexp.h
include/ClanLib-%%VER%%/ClanLib/RegExp/regexp.h
include/ClanLib-%%VER%%/ClanLib/RegExp/regexp_match.h
-include/ClanLib-%%VER%%/ClanLib/SWRender/api_swrender.h
-include/ClanLib-%%VER%%/ClanLib/SWRender/blit_argb8_sse.h
-include/ClanLib-%%VER%%/ClanLib/SWRender/pixel_buffer_data.h
-include/ClanLib-%%VER%%/ClanLib/SWRender/pixel_command.h
-include/ClanLib-%%VER%%/ClanLib/SWRender/pixel_thread_context.h
-include/ClanLib-%%VER%%/ClanLib/SWRender/setup_swrender.h
-include/ClanLib-%%VER%%/ClanLib/SWRender/software_program.h
-include/ClanLib-%%VER%%/ClanLib/SWRender/swr_graphic_context.h
-include/ClanLib-%%VER%%/ClanLib/SWRender/swr_program_object.h
-include/ClanLib-%%VER%%/ClanLib/SWRender/swr_target.h
+%%SWRENDER%%include/ClanLib-%%VER%%/ClanLib/SWRender/api_swrender.h
+%%SWRENDER%%include/ClanLib-%%VER%%/ClanLib/SWRender/blit_argb8_sse.h
+%%SWRENDER%%include/ClanLib-%%VER%%/ClanLib/SWRender/pixel_buffer_data.h
+%%SWRENDER%%include/ClanLib-%%VER%%/ClanLib/SWRender/pixel_command.h
+%%SWRENDER%%include/ClanLib-%%VER%%/ClanLib/SWRender/pixel_thread_context.h
+%%SWRENDER%%include/ClanLib-%%VER%%/ClanLib/SWRender/setup_swrender.h
+%%SWRENDER%%include/ClanLib-%%VER%%/ClanLib/SWRender/software_program.h
+%%SWRENDER%%include/ClanLib-%%VER%%/ClanLib/SWRender/swr_graphic_context.h
+%%SWRENDER%%include/ClanLib-%%VER%%/ClanLib/SWRender/swr_program_object.h
+%%SWRENDER%%include/ClanLib-%%VER%%/ClanLib/SWRender/swr_target.h
include/ClanLib-%%VER%%/ClanLib/Sound/SoundFilters/echofilter.h
include/ClanLib-%%VER%%/ClanLib/Sound/SoundFilters/fadefilter.h
include/ClanLib-%%VER%%/ClanLib/Sound/SoundFilters/inverse_echofilter.h
@@ -456,7 +456,7 @@ include/ClanLib-%%VER%%/ClanLib/network.h
include/ClanLib-%%VER%%/ClanLib/regexp.h
include/ClanLib-%%VER%%/ClanLib/sound.h
include/ClanLib-%%VER%%/ClanLib/sqlite.h
-include/ClanLib-%%VER%%/ClanLib/swrender.h
+%%SWRENDER%%include/ClanLib-%%VER%%/ClanLib/swrender.h
include/ClanLib-%%VER%%/ClanLib/vorbis.h
lib/libclan%%SHORT_VER%%App-%%VER%%.so.1
lib/libclan%%SHORT_VER%%App-%%VER%%.so.1.0.0
@@ -502,10 +502,10 @@ lib/libclan%%SHORT_VER%%RegExp-%%VER%%.so.1
lib/libclan%%SHORT_VER%%RegExp-%%VER%%.so.1.0.0
lib/libclan%%SHORT_VER%%RegExp.a
lib/libclan%%SHORT_VER%%RegExp.so
-lib/libclan%%SHORT_VER%%SWRender-%%VER%%.so.1
-lib/libclan%%SHORT_VER%%SWRender-%%VER%%.so.1.0.0
-lib/libclan%%SHORT_VER%%SWRender.a
-lib/libclan%%SHORT_VER%%SWRender.so
+%%SWRENDER%%lib/libclan%%SHORT_VER%%SWRender-%%VER%%.so.1
+%%SWRENDER%%lib/libclan%%SHORT_VER%%SWRender-%%VER%%.so.1.0.0
+%%SWRENDER%%lib/libclan%%SHORT_VER%%SWRender.a
+%%SWRENDER%%lib/libclan%%SHORT_VER%%SWRender.so
lib/libclan%%SHORT_VER%%Sound-%%VER%%.so.1
lib/libclan%%SHORT_VER%%Sound-%%VER%%.so.1.0.0
lib/libclan%%SHORT_VER%%Sound.a
@@ -529,7 +529,7 @@ libdata/pkgconfig/clanGUI-%%VER%%.pc
libdata/pkgconfig/clanMikMod-%%VER%%.pc
libdata/pkgconfig/clanNetwork-%%VER%%.pc
libdata/pkgconfig/clanRegExp-%%VER%%.pc
-libdata/pkgconfig/clanSWRender-%%VER%%.pc
+%%SWRENDER%%libdata/pkgconfig/clanSWRender-%%VER%%.pc
libdata/pkgconfig/clanSound-%%VER%%.pc
libdata/pkgconfig/clanSqlite-%%VER%%.pc
libdata/pkgconfig/clanVorbis-%%VER%%.pc