aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-09-17 00:45:35 +0800
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-09-17 00:45:35 +0800
commitcddacdc1a85e239682053f3716b7c685f422ebf4 (patch)
tree62ec5ad5c85e69fd9755b85db994f8c7042a1fc0
parent1f7b0d3e1b562bcd76f89ebdbd346571511c07c0 (diff)
downloadfreebsd-ports-gnome-cddacdc1a85e239682053f3716b7c685f422ebf4.tar.gz
freebsd-ports-gnome-cddacdc1a85e239682053f3716b7c685f422ebf4.tar.zst
freebsd-ports-gnome-cddacdc1a85e239682053f3716b7c685f422ebf4.zip
Convert to new perl framework
Convert USE_GMAKE to USES
-rw-r--r--emulators/qemu-devel/Makefile4
-rw-r--r--emulators/qemu/Makefile4
-rw-r--r--math/asymptote/Makefile4
-rw-r--r--math/fftw3/Makefile4
-rw-r--r--math/gotoblas/Makefile3
-rw-r--r--math/isabelle/Makefile10
-rw-r--r--math/mtl/Makefile10
-rw-r--r--math/oleo/Makefile4
-rw-r--r--math/polymake/Makefile9
-rw-r--r--math/yacas/Makefile4
-rw-r--r--security/fcheck/Makefile8
-rw-r--r--security/ftimes/Makefile2
-rw-r--r--security/gnomint/Makefile5
-rw-r--r--security/krb5-appl/Makefile4
-rw-r--r--security/lasso/Makefile2
-rw-r--r--security/openpgpsdk/Makefile16
-rw-r--r--security/openssl/Makefile13
-rw-r--r--security/vpnc/Makefile4
-rw-r--r--ukrainian/ispell/Makefile3
19 files changed, 44 insertions, 69 deletions
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index 48a84097ee2b..1e4c411be16e 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -18,8 +18,8 @@ LIB_DEPENDS= pixman-1:${PORTSDIR}/x11/pixman
HAS_CONFIGURE= yes
USE_BZIP2= yes
-USES= gmake pkgconfig bison
-USE_PERL5_BUILD= yes
+USES= gmake pkgconfig bison perl5
+USE_PERL5= build
USE_PYTHON_BUILD= -2.7
USE_GNOME+= glib20
PATCH_STRIP= -p1
diff --git a/emulators/qemu/Makefile b/emulators/qemu/Makefile
index 51c276d21e28..02c52fbd38e5 100644
--- a/emulators/qemu/Makefile
+++ b/emulators/qemu/Makefile
@@ -15,8 +15,8 @@ COMMENT= QEMU CPU Emulator
HAS_CONFIGURE= yes
USE_GCC= any
-USE_GMAKE= yes
-USE_PERL5_BUILD= yes
+USES= gmake perl5
+USE_PERL5= build
PATCH_STRIP= -p1
MAKE_ENV+= BSD_MAKE="${MAKE}"
MAN1= qemu.1 qemu-img.1
diff --git a/math/asymptote/Makefile b/math/asymptote/Makefile
index 8f9cd7f4f3f8..b098e753635d 100644
--- a/math/asymptote/Makefile
+++ b/math/asymptote/Makefile
@@ -27,8 +27,8 @@ CONFIGURE_ARGS= --disable-gc
USE_GHOSTSCRIPT=yes
USE_TEX= latex
USE_GL= glut
-USE_GMAKE= yes
-USE_PERL5_BUILD= yes
+USES= gmake perl5
+USE_PERL5= build
USE_PYTHON= yes
MAKE_JOBS_UNSAFE= yes
diff --git a/math/fftw3/Makefile b/math/fftw3/Makefile
index 9ea1decf50c4..938da4c03588 100644
--- a/math/fftw3/Makefile
+++ b/math/fftw3/Makefile
@@ -19,8 +19,8 @@ FFTW3_FLAVOR?= default
FFTW3_SUFX=
GNU_CONFIGURE= yes
-USES= pathfix pkgconfig
-USE_PERL5_BUILD=yes
+USES= pathfix perl5 pkgconfig
+USE_PERL5= build
USE_LDCONFIG= yes
CONFIGURE_ARGS = --enable-shared --enable-threads --disable-fortran
diff --git a/math/gotoblas/Makefile b/math/gotoblas/Makefile
index 24b482c30409..9750d82e3f4e 100644
--- a/math/gotoblas/Makefile
+++ b/math/gotoblas/Makefile
@@ -29,7 +29,8 @@ USE_GMAKE= yes
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/GotoBLAS2
-USE_PERL5_BUILD= yes
+USES= gmake perl5
+USE_PERL5= build
USE_FORTRAN= yes
GOTOLIBS= libgoto2 libgoto2p
GOTOFILES= ${GOTOLIBS:S|$|.so|} ${GOTOLIBS:S|$|.so.1|} ${GOTOLIBS:S|$|.a|}
diff --git a/math/isabelle/Makefile b/math/isabelle/Makefile
index 26ebb87e036b..1d196217b4ab 100644
--- a/math/isabelle/Makefile
+++ b/math/isabelle/Makefile
@@ -29,7 +29,7 @@ HOL_TLA_DESC= Build optional heap: TLA
HOL_HOL4_DESC= Build optional heap: HOL4
EMACS_PKG_DESC= Build with Emacs Packages
-USE_PERL5= yes
+USES= perl5
.include <bsd.port.options.mk>
@@ -39,10 +39,10 @@ DISTFILES= ${DISTNAME}.tar.gz \
.endif
.if ${PORT_OPTIONS:MEMACS_PKG}
- USE_EMACS= yes # for EMACS_SITE_LISPDIR
- EMACS_NO_BUILD_DEPENDS=yes
- EMACS_NO_RUN_DEPENDS=yes
- RUN_DEPENDS+= proofgeneral:${PORTSDIR}/math/proofgeneral
+USE_EMACS= yes # for EMACS_SITE_LISPDIR
+EMACS_NO_BUILD_DEPENDS=yes
+EMACS_NO_RUN_DEPENDS=yes
+RUN_DEPENDS+= proofgeneral:${PORTSDIR}/math/proofgeneral
.else
.endif
diff --git a/math/mtl/Makefile b/math/mtl/Makefile
index 71ae6d367a5a..4497645a0d6d 100644
--- a/math/mtl/Makefile
+++ b/math/mtl/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: mtl
-# Date created: Mar 15, 2002
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= mtl
DISTVERSION= 2.1.2-23.tentative
@@ -23,7 +18,8 @@ CONFIGURE_ENV= CXXCPP="${CXXCPP}"
CXXCPP?= ${CXX} -E
GNU_CONFIGURE= yes
NO_BUILD= yes
-USE_PERL5_BUILD= yes
+USES= perl5
+USE_PERL5= build
WRKSRC = ${WRKDIR}/${DISTNAME:R}
post-patch:
diff --git a/math/oleo/Makefile b/math/oleo/Makefile
index 2717e294d515..0eb30c9bf9f9 100644
--- a/math/oleo/Makefile
+++ b/math/oleo/Makefile
@@ -11,8 +11,8 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= gahr@FreeBSD.org
COMMENT= The GNU spreadsheet for X11 and terminals
-USE_PERL5_BUILD= yes
-USES= bison
+USE_PERL5= build
+USES= bison perl5
USE_AUTOTOOLS= autoconf213
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/math/polymake/Makefile b/math/polymake/Makefile
index a712c9def124..eb86d977c9bc 100644
--- a/math/polymake/Makefile
+++ b/math/polymake/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: polymake
-# Date created: 21 December 2004
-# Whom: Ewgenij Gawrilow <gawrilow@math.tu-berlin.de>
-#
+# Created by: Ewgenij Gawrilow <gawrilow@math.tu-berlin.de>
# $FreeBSD$
-#
PORTNAME= polymake
PORTVERSION= 2.9.9
@@ -25,9 +21,8 @@ RUN_DEPENDS= p5-XML-LibXML>=0:${PORTSDIR}/textproc/p5-XML-LibXML \
LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp \
readline.[56]:${PORTSDIR}/devel/readline
-USE_GMAKE= yes
+USES= gmake perl5
USE_BZIP2= yes
-USE_PERL5= yes
USE_GCC= 4.2+
USE_JAVA= yes
JAVA_BUILD= yes
diff --git a/math/yacas/Makefile b/math/yacas/Makefile
index 3956cf1bd887..1e643e0848f8 100644
--- a/math/yacas/Makefile
+++ b/math/yacas/Makefile
@@ -16,8 +16,8 @@ OPTIONS_DEFINE= TESTS DOCS
OPTIONS_DEFAULT= TESTS
TESTS_DESC= Run bundled self-tests after build
-USE_PERL5_BUILD=yes
-USE_GMAKE= yes
+USES= gmake perl5
+USE_PERL5= build
#USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
diff --git a/security/fcheck/Makefile b/security/fcheck/Makefile
index 636bdc718645..d1012488228c 100644
--- a/security/fcheck/Makefile
+++ b/security/fcheck/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: fcheck
-# Date created: 2008-01-31
-# Whom: Lars Engels <lme@FreeBSD.org>
-#
+# Created by: Lars Engels <lme@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= fcheck
PORTVERSION= 2.07.59
@@ -20,7 +16,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
PORTDOCS= *
PLIST_FILES= sbin/${PORTNAME} etc/${PORTNAME}.cfg.sample
NO_BUILD= YES
-USE_PERL5= YES
+USES= perl5
.include <bsd.port.pre.mk>
diff --git a/security/ftimes/Makefile b/security/ftimes/Makefile
index f89ab71e9dd8..26c14053cc41 100644
--- a/security/ftimes/Makefile
+++ b/security/ftimes/Makefile
@@ -14,7 +14,7 @@ LICENSE= BSD AL2 MIT
LICENSE_COMB= multi
GNU_CONFIGURE= yes
-USE_PERL5= yes
+USES= perl5
MAN1= ftimes.1
MAN3= FTimes::EadRoutines.3 FTimes::Properties.3
diff --git a/security/gnomint/Makefile b/security/gnomint/Makefile
index a281dc33f70d..632523beaa19 100644
--- a/security/gnomint/Makefile
+++ b/security/gnomint/Makefile
@@ -11,17 +11,14 @@ MAINTAINER= kevinz5000@gmail.com
COMMENT= X.509 Certification Authority management tool
LICENSE= GPLv3
-LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= gcrypt:${PORTSDIR}/security/libgcrypt \
gnutls:${PORTSDIR}/security/gnutls \
sqlite3:${PORTSDIR}/databases/sqlite3
GNU_CONFIGURE= yes
-USES= pkgconfig
-USE_GMAKE= yes
+USES= gmake perl5 pkgconfig
USE_GNOME= gconf2 gdkpixbuf2 glib20 gtk20
-USE_PERL5= yes
CFLAGS:= ${CFLAGS:C/-Werror//}
diff --git a/security/krb5-appl/Makefile b/security/krb5-appl/Makefile
index 82fff3925ab3..77052449f3e5 100644
--- a/security/krb5-appl/Makefile
+++ b/security/krb5-appl/Makefile
@@ -22,8 +22,8 @@ CONFLICTS= krb4-[0-9]* krb5-1.[0-7].* heimdal-[0-9]* srp-[0-9]*
LATEST_LINK= ${PORTNAME}-1
KERBEROSV_URL= http://web.mit.edu/kerberos/
USE_OPENSSL= yes
-USE_GMAKE= yes
-USE_PERL5_BUILD= yes
+USES= gmake perl5
+USE_PERL5= build
USE_LDCONFIG= yes
USE_CSTD= gnu89
USE_AUTOTOOLS= libtool autoheader autoconf
diff --git a/security/lasso/Makefile b/security/lasso/Makefile
index 7d04c7e2e4ef..143bd7c51b75 100644
--- a/security/lasso/Makefile
+++ b/security/lasso/Makefile
@@ -28,7 +28,7 @@ OPTIONS_DEFINE= PERL PHP PYTHON
.if !empty(PORT_OPTIONS:MPERL)
CONFIGURE_ARGS+= --enable-perl
PLIST_SUB+= WITH_PERL=""
-USE_PERL5= yes
+USES+= perl5
.else
CONFIGURE_ARGS+= --disable-perl
PLIST_SUB+= WITH_PERL="@comment "
diff --git a/security/openpgpsdk/Makefile b/security/openpgpsdk/Makefile
index 40bc914256d3..21049c57dd7d 100644
--- a/security/openpgpsdk/Makefile
+++ b/security/openpgpsdk/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: openpgpsdk
-# Date created: 2009-02-10
-# Whom: Martin Wilke <miwi@FreeBSD.org>
-#
+# Created by: Martin Wilke <miwi@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= openpgpsdk
PORTVERSION= 0.9
@@ -17,20 +13,14 @@ COMMENT= OpenPGP SDK
BUILD_DEPENDS= gpg2:${PORTSDIR}/security/gnupg
LIB_DEPENDS= cunit.1:${PORTSDIR}/devel/cunit
-USE_PERL5= yes
+USES= perl5
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --without-idea --with-cunit=${LOCALBASE}
PLIST_FILES= bin/openpgp lib/libops.a
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 700042
-BROKEN= does not build on 6.x.
-.endif
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/openpgp ${PREFIX}/bin/
${INSTALL_DATA} ${WRKSRC}/lib/libops.a ${PREFIX}/lib/
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index a2eaa1666195..5b89ac122505 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -48,12 +48,13 @@ MAKE_JOBS_UNSAFE= yes
NOPRECIOUSMAKEVARS= Too many _MLINKS for fetch
NOPRECIOUSSOFTMAKEVARS= Too many _MLINKS for fetch
-USE_PERL5_BUILD= yes
-MAKE_ARGS+= WHOLE_ARCHIVE_FLAG=--whole-archive
-MAKE_ENV+= LIBRPATH="${PREFIX}/lib"
-SUB_FILES= pkg-message
-OPENSSLDIR= ${PREFIX}/openssl
-MANPREFIX= ${PREFIX}
+USES= perl5
+USE_PERL5= build
+MAKE_ARGS+= WHOLE_ARCHIVE_FLAG=--whole-archive
+MAKE_ENV+= LIBRPATH="${PREFIX}/lib"
+SUB_FILES= pkg-message
+OPENSSLDIR= ${PREFIX}/openssl
+MANPREFIX= ${PREFIX}
MAN1= CA.pl.1 asn1parse.1 ca.1 ciphers.1 cms.1 crl.1 crl2pkcs7.1 dgst.1 \
dhparam.1 dsa.1 dsaparam.1 ec.1 ecparam.1 enc.1 errstr.1 gendsa.1 \
diff --git a/security/vpnc/Makefile b/security/vpnc/Makefile
index 79214ee4c9e4..5dcd3d84e63e 100644
--- a/security/vpnc/Makefile
+++ b/security/vpnc/Makefile
@@ -14,8 +14,8 @@ COMMENT= Client for Cisco 3000 VPN Concentrator
LIB_DEPENDS= gcrypt:${PORTSDIR}/security/libgcrypt
RUN_DEPENDS= vpnc-script:${PORTSDIR}/sysutils/vpnc-scripts
-USES= shebangfix gmake
-USE_PERL5_BUILD=yes
+USES= shebangfix gmake perl5
+USE_PERL5= build
USE_RC_SUBR= vpnc
ALL_TARGET= all
diff --git a/ukrainian/ispell/Makefile b/ukrainian/ispell/Makefile
index 565a36072936..b15e461efd30 100644
--- a/ukrainian/ispell/Makefile
+++ b/ukrainian/ispell/Makefile
@@ -13,10 +13,9 @@ BUILD_DEPENDS= buildhash:${PORTSDIR}/textproc/ispell
MAKE_JOBS_UNSAFE= yes
-USES= gmake
+USES= gmake perl5
USE_BZIP2= YES
ALL_TARGET= koi
-USE_PERL5= yes
# Still need gmake for other reasons :-\
#post-patch: