aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2017-01-10 02:58:54 +0800
committerantoine <antoine@FreeBSD.org>2017-01-10 02:58:54 +0800
commitce71cd45643f619e05ea6d31edbbfb9d23195b23 (patch)
tree49e59f132bff13cd9ace669ee771545e3096a4c0
parent63d33016afd884e94b6ec39f3223876df3a216af (diff)
downloadfreebsd-ports-gnome-ce71cd45643f619e05ea6d31edbbfb9d23195b23.tar.gz
freebsd-ports-gnome-ce71cd45643f619e05ea6d31edbbfb9d23195b23.tar.zst
freebsd-ports-gnome-ce71cd45643f619e05ea6d31edbbfb9d23195b23.zip
New port: devel/py-jupyter_code
Jupyter core package. A base package on which Jupyter projects rely. WWW: http://jupyter.org/
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-jupyter_core/Makefile29
-rw-r--r--devel/py-jupyter_core/distinfo3
-rw-r--r--devel/py-jupyter_core/pkg-descr3
4 files changed, 36 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 1d3eb2ebe067..14ce695abda1 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4319,6 +4319,7 @@
SUBDIR += py-jsonpointer
SUBDIR += py-jsonrpclib
SUBDIR += py-jsonschema
+ SUBDIR += py-jupyter_core
SUBDIR += py-kaptan
SUBDIR += py-kayako
SUBDIR += py-kazoo
diff --git a/devel/py-jupyter_core/Makefile b/devel/py-jupyter_core/Makefile
new file mode 100644
index 000000000000..681ac75f5f18
--- /dev/null
+++ b/devel/py-jupyter_core/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= jupyter_core
+PORTVERSION= 4.2.1
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= python@FreeBSD.org
+COMMENT= Jupyter core package
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING.md
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}traitlets>=0:devel/py-traitlets
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ipython>=0:devel/ipython \
+ ${PYTHON_PKGNAMEPREFIX}mock>=0:devel/py-mock \
+ ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest \
+ ${PYTHON_PKGNAMEPREFIX}testpath>=0:devel/py-testpath
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+TEST_ENV= ${MAKE_ENV} LANG=en_US.UTF-8
+
+do-test:
+ @(cd ${TEST_WRKSRC} && ${SETENV} ${TEST_ENV} pytest-${PYTHON_VER})
+
+.include <bsd.port.mk>
diff --git a/devel/py-jupyter_core/distinfo b/devel/py-jupyter_core/distinfo
new file mode 100644
index 000000000000..7cc52b4bad3a
--- /dev/null
+++ b/devel/py-jupyter_core/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1483859718
+SHA256 (jupyter_core-4.2.1.tar.gz) = 89c55399c8437f777197c2c82c1ff5639c7f71d4eb2f172a81afa120b68dc7b3
+SIZE (jupyter_core-4.2.1.tar.gz) = 61794
diff --git a/devel/py-jupyter_core/pkg-descr b/devel/py-jupyter_core/pkg-descr
new file mode 100644
index 000000000000..844c7e40120e
--- /dev/null
+++ b/devel/py-jupyter_core/pkg-descr
@@ -0,0 +1,3 @@
+Jupyter core package. A base package on which Jupyter projects rely.
+
+WWW: http://jupyter.org/