aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2015-09-21 04:24:04 +0800
committersunpoet <sunpoet@FreeBSD.org>2015-09-21 04:24:04 +0800
commitcf1d81141cd99be7bba67b11a22b3458c5abf63e (patch)
treed4ce4b864554d9e68756a7da941cbe6fff2451d7
parenta03a794d9f04b368d1d0b51ca39a8750bc192915 (diff)
downloadfreebsd-ports-gnome-cf1d81141cd99be7bba67b11a22b3458c5abf63e.tar.gz
freebsd-ports-gnome-cf1d81141cd99be7bba67b11a22b3458c5abf63e.tar.zst
freebsd-ports-gnome-cf1d81141cd99be7bba67b11a22b3458c5abf63e.zip
- Revert r397413: this file is not part of clang 3.7.0 fix
- Pet portlint: fix diff header of patch files
-rw-r--r--lang/v8-devel/files/patch-Makefile15
1 files changed, 3 insertions, 12 deletions
diff --git a/lang/v8-devel/files/patch-Makefile b/lang/v8-devel/files/patch-Makefile
index 860ef5dc2c14..7992668e2ff8 100644
--- a/lang/v8-devel/files/patch-Makefile
+++ b/lang/v8-devel/files/patch-Makefile
@@ -1,4 +1,4 @@
---- Makefile.orig 2014-06-03 08:52:18 UTC
+--- Makefile.orig 2014-02-04 02:07:31 UTC
+++ Makefile
@@ -52,6 +52,14 @@ endif
ifdef console
@@ -15,16 +15,7 @@
# disassembler=on
ifeq ($(disassembler), on)
GYPFLAGS += -Dv8_enable_disassembler=1
-@@ -227,7 +235,7 @@ NACL_ARCHES = nacl_ia32 nacl_x64
- # List of files that trigger Makefile regeneration:
- GYPFILES = build/all.gyp build/features.gypi build/standalone.gypi \
- build/toolchain.gypi samples/samples.gyp src/d8.gyp \
-- test/cctest/cctest.gyp tools/gyp/v8.gyp
-+ tools/gyp/v8.gyp
-
- # If vtunejit=on, the v8vtune.gyp will be appended.
- ifeq ($(vtunejit), on)
-@@ -395,8 +403,7 @@ clean: $(addsuffix .clean, $(ARCHES) $(A
+@@ -386,8 +394,7 @@ clean: $(addsuffix .clean, $(ARCHES) $(A
# GYP file generation targets.
OUT_MAKEFILES = $(addprefix $(OUTDIR)/Makefile.,$(BUILDS))
$(OUT_MAKEFILES): $(GYPFILES) $(ENVFILE)
@@ -34,7 +25,7 @@
GYP_GENERATORS=make \
build/gyp/gyp --generator-output="$(OUTDIR)" build/all.gyp \
-Ibuild/standalone.gypi --depth=. \
-@@ -405,8 +412,7 @@ $(OUT_MAKEFILES): $(GYPFILES) $(ENVFILE)
+@@ -396,8 +403,7 @@ $(OUT_MAKEFILES): $(GYPFILES) $(ENVFILE)
-S$(suffix $(basename $@))$(suffix $@) $(GYPFLAGS)
$(OUTDIR)/Makefile.native: $(GYPFILES) $(ENVFILE)