aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2020-03-17 10:46:39 +0800
committerMikhail Teterin <mi@FreeBSD.org>2020-03-17 10:46:39 +0800
commitcf98741f164d6806c49653d67f135a577adbc36b (patch)
treee6d40fa925f673a4c7aca61c0a7cb48f3d2bd303
parent81a631101a9ef715197979af518666606b9a2af5 (diff)
downloadfreebsd-ports-gnome-cf98741f164d6806c49653d67f135a577adbc36b.tar.gz
freebsd-ports-gnome-cf98741f164d6806c49653d67f135a577adbc36b.tar.zst
freebsd-ports-gnome-cf98741f164d6806c49653d67f135a577adbc36b.zip
Patch an ancient upstream bug uncovered on HEAD by the new compiler
warning (-Wmisleading-indentation). Bump PORTREVISION... Glory be to LLVM and -Werror. Reported by: pkg-fallout
-rw-r--r--www/websh/Makefile2
-rw-r--r--www/websh/files/patch-response_ap.c20
2 files changed, 21 insertions, 1 deletions
diff --git a/www/websh/Makefile b/www/websh/Makefile
index f5d2a4460533..2cbd3bea776e 100644
--- a/www/websh/Makefile
+++ b/www/websh/Makefile
@@ -3,7 +3,7 @@
PORTNAME= websh
PORTVERSION= 3.6.0b5
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= www tcl
MASTER_SITES= APACHE/tcl/${PORTNAME}/source
EXTRACT_SUFX= -src.tar.gz
diff --git a/www/websh/files/patch-response_ap.c b/www/websh/files/patch-response_ap.c
new file mode 100644
index 000000000000..02d352fbf298
--- /dev/null
+++ b/www/websh/files/patch-response_ap.c
@@ -0,0 +1,20 @@
+Patch an ancient bug, uncovered by clang10's new warning-flag...
+
+ -mi
+
+--- ../generic/response_ap.c 2009-05-22 06:13:35.000000000 -0400
++++ ../generic/response_ap.c 2020-03-16 22:40:32.845609000 -0400
+@@ -69,4 +69,6 @@
+ r->status_line = ap_pstrdup(r->pool, ++response);
+ #else /* APACHE2 */
++ {
++
+ r->status_line = (char *) apr_pstrdup(r->pool, ++response);
+ /* as of Apache 2.2.1, r->status_line must be in line with
+@@ -80,5 +82,5 @@
+ response[3] = tmp;
+ }
+-
++ }
+ #endif /* APACHE2 */
+ }