aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2005-05-08 23:37:47 +0800
committeroliver <oliver@FreeBSD.org>2005-05-08 23:37:47 +0800
commitcfb09d0ccd2dc7f3367d380baf60c84cf6b9d414 (patch)
tree5d400e3e8f456ff804ee3243fa2c2cfbf1452a26
parent73be84ecbf46be0cf85921d96672a5262a74b523 (diff)
downloadfreebsd-ports-gnome-cfb09d0ccd2dc7f3367d380baf60c84cf6b9d414.tar.gz
freebsd-ports-gnome-cfb09d0ccd2dc7f3367d380baf60c84cf6b9d414.tar.zst
freebsd-ports-gnome-cfb09d0ccd2dc7f3367d380baf60c84cf6b9d414.zip
- Fix the misc/mime-support dependency
- Add the MUTT_LITE knob for those who want to build mutt with minimal effort. PR: ports/80785 Submitted by: maintainer
-rw-r--r--mail/mutt/Makefile18
-rw-r--r--mail/mutt14/Makefile18
2 files changed, 24 insertions, 12 deletions
diff --git a/mail/mutt/Makefile b/mail/mutt/Makefile
index 29817493e003..f2a78a145166 100644
--- a/mail/mutt/Makefile
+++ b/mail/mutt/Makefile
@@ -30,18 +30,21 @@ COMMENT?= The Mongrel of Mail User Agents (part Elm, Pine, Mush, mh, etc.)
CONFLICTS= mutt-devel-*
-.if defined(PACKAGE_BUILDING)
+RUN_DEPENDS= ${LOCALBASE}/etc/mime.types:${PORTSDIR}/misc/mime-support
+.if defined(PACKAGE_BUILDING) && !defined (MUTT_LITE)
WITH_SLANG= yes
BUILD_DEPENDS= ispell:${PORTSDIR}/textproc/ispell
-RUN_DEPENDS= ispell:${PORTSDIR}/textproc/ispell \
- urlview:${PORTSDIR}/textproc/urlview \
- ${LOCALBASE}/etc/mime.types:${PORTSDIR}/misc/mime-support
+RUN_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell \
+ urlview:${PORTSDIR}/textproc/urlview
.endif
-.if ${MACHINE_ARCH} != "alpha"
+.if defined (MUTT_LITE)
+WITH_SGML_DOCS:=no
+.elif ${MACHINE_ARCH} != "alpha"
# coredump in sgmls
WITH_SGML_DOCS?=yes
.endif
+.if !defined (MUTT_LITE)
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
USE_ICONV= yes
@@ -49,15 +52,17 @@ USE_ICONV= yes
.error the WITHOUT_MUTT_ICONV knob of the mutt port only works if \
WITHOUT_NLS is also given
.endif
-.elif !defined(WITHOUT_MUTT_ICONV)
+.elif !defined(WITHOUT_MUTT_ICONV) && !defined (MUTT_LITE)
USE_ICONV= yes
.endif
+.endif
.if defined(WITH_SLANG)
LIB_DEPENDS+= slang.1:${PORTSDIR}/devel/libslang
.elif defined(WITH_NCURSES_PORT)
LIB_DEPENDS+= ncurses.5:${PORTSDIR}/devel/ncurses
.endif
+.if !defined (MUTT_LITE)
.if defined(WITH_MUTT_CYRUS_SASL)
LIB_DEPENDS+= sasl.8:${PORTSDIR}/security/cyrus-sasl
.endif
@@ -68,6 +73,7 @@ BUILD_DEPENDS+= sgmlfmt:${PORTSDIR}/textproc/sgmlformat
PATCH_DEPENDS+= ${NONEXISTENT}:${PORTSDIR}/news/slrnface:extract
RUN_DEPENDS+= slrnface:${PORTSDIR}/news/slrnface
.endif
+.endif
DIST_SUBDIR= mutt
WRKSRC= ${WRKDIR}/${DISTNAME:S/i$//}
diff --git a/mail/mutt14/Makefile b/mail/mutt14/Makefile
index 29817493e003..f2a78a145166 100644
--- a/mail/mutt14/Makefile
+++ b/mail/mutt14/Makefile
@@ -30,18 +30,21 @@ COMMENT?= The Mongrel of Mail User Agents (part Elm, Pine, Mush, mh, etc.)
CONFLICTS= mutt-devel-*
-.if defined(PACKAGE_BUILDING)
+RUN_DEPENDS= ${LOCALBASE}/etc/mime.types:${PORTSDIR}/misc/mime-support
+.if defined(PACKAGE_BUILDING) && !defined (MUTT_LITE)
WITH_SLANG= yes
BUILD_DEPENDS= ispell:${PORTSDIR}/textproc/ispell
-RUN_DEPENDS= ispell:${PORTSDIR}/textproc/ispell \
- urlview:${PORTSDIR}/textproc/urlview \
- ${LOCALBASE}/etc/mime.types:${PORTSDIR}/misc/mime-support
+RUN_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell \
+ urlview:${PORTSDIR}/textproc/urlview
.endif
-.if ${MACHINE_ARCH} != "alpha"
+.if defined (MUTT_LITE)
+WITH_SGML_DOCS:=no
+.elif ${MACHINE_ARCH} != "alpha"
# coredump in sgmls
WITH_SGML_DOCS?=yes
.endif
+.if !defined (MUTT_LITE)
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
USE_ICONV= yes
@@ -49,15 +52,17 @@ USE_ICONV= yes
.error the WITHOUT_MUTT_ICONV knob of the mutt port only works if \
WITHOUT_NLS is also given
.endif
-.elif !defined(WITHOUT_MUTT_ICONV)
+.elif !defined(WITHOUT_MUTT_ICONV) && !defined (MUTT_LITE)
USE_ICONV= yes
.endif
+.endif
.if defined(WITH_SLANG)
LIB_DEPENDS+= slang.1:${PORTSDIR}/devel/libslang
.elif defined(WITH_NCURSES_PORT)
LIB_DEPENDS+= ncurses.5:${PORTSDIR}/devel/ncurses
.endif
+.if !defined (MUTT_LITE)
.if defined(WITH_MUTT_CYRUS_SASL)
LIB_DEPENDS+= sasl.8:${PORTSDIR}/security/cyrus-sasl
.endif
@@ -68,6 +73,7 @@ BUILD_DEPENDS+= sgmlfmt:${PORTSDIR}/textproc/sgmlformat
PATCH_DEPENDS+= ${NONEXISTENT}:${PORTSDIR}/news/slrnface:extract
RUN_DEPENDS+= slrnface:${PORTSDIR}/news/slrnface
.endif
+.endif
DIST_SUBDIR= mutt
WRKSRC= ${WRKDIR}/${DISTNAME:S/i$//}