aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrpaulo <rpaulo@FreeBSD.org>2013-08-15 14:12:48 +0800
committerrpaulo <rpaulo@FreeBSD.org>2013-08-15 14:12:48 +0800
commitd05ec3a23570cdaf37a59f1a7f71a168547a924d (patch)
tree869ec0417e379f94330e7806499f45cebd54da13
parent98ff7daa80e0928ba6ca8cf0f41fb7057d56d105 (diff)
downloadfreebsd-ports-gnome-d05ec3a23570cdaf37a59f1a7f71a168547a924d.tar.gz
freebsd-ports-gnome-d05ec3a23570cdaf37a59f1a7f71a168547a924d.tar.zst
freebsd-ports-gnome-d05ec3a23570cdaf37a59f1a7f71a168547a924d.zip
Add a port for the TI PASM.
PASM stands for PRU assembler. PRU stands for Programmable Realtime Unit. Reviewed by: ak
-rw-r--r--devel/Makefile1
-rw-r--r--devel/pasm/Makefile26
-rw-r--r--devel/pasm/distinfo2
-rw-r--r--devel/pasm/pkg-descr8
4 files changed, 37 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index e66a5bcab8a1..fef7f4d89a19 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3036,6 +3036,7 @@
SUBDIR += papi
SUBDIR += papp
SUBDIR += pas2dox
+ SUBDIR += pasm
SUBDIR += patch
SUBDIR += pccts
SUBDIR += pcl
diff --git a/devel/pasm/Makefile b/devel/pasm/Makefile
new file mode 100644
index 000000000000..271ccc74686b
--- /dev/null
+++ b/devel/pasm/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= pasm
+PORTVERSION= 0.84
+CATEGORIES= devel
+MASTER_SITES= https://github.com/rpaulo/am335x_pru_package/archive/
+
+MAINTAINER= rpaulo@FreeBSD.org
+COMMENT= TI PRU Assembler
+
+LICENSE= BSD
+LICENSE_FILE= ${WRKSRC}/pru_sw/utils/LICENCE.txt
+
+WRKSRC= ${WRKDIR}/am335x_pru_package-${PORTNAME}-${PORTVERSION}
+FETCH_ARGS= "-Fpr"
+PLIST_FILES= bin/pasm
+
+do-build:
+ (cd ${WRKSRC}/pru_sw/utils/pasm_source && \
+ ${CC} ${CFLAGS} -D_UNIX_ pasm.c pasmpp.c pasmexp.c pasmop.c \
+ pasmdot.c pasmstruct.c pasmmacro.c -o pasm)
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/pru_sw/utils/pasm_source/pasm ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/devel/pasm/distinfo b/devel/pasm/distinfo
new file mode 100644
index 000000000000..966c3eb5be46
--- /dev/null
+++ b/devel/pasm/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pasm-0.84.tar.gz) = e49b4c5f8be3a82122223591194b428fcf9ccbe0b59eb52ec3a7756a685faf8e
+SIZE (pasm-0.84.tar.gz) = 3788982
diff --git a/devel/pasm/pkg-descr b/devel/pasm/pkg-descr
new file mode 100644
index 000000000000..3e206900dca0
--- /dev/null
+++ b/devel/pasm/pkg-descr
@@ -0,0 +1,8 @@
+TI PRU Assembler. For use with Texas Instruments Programmable
+Realtime Units.
+
+These materials are intended for do-it-yourself (DIY) users
+who want to use the PRU at their own risk without TI support.
+"Community" support is offered at BeagleBoard.org/discuss.
+
+WWW: https://github.com/beagleboard/am335x_pru_package