aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzi <zi@FreeBSD.org>2014-12-17 22:36:01 +0800
committerzi <zi@FreeBSD.org>2014-12-17 22:36:01 +0800
commitd0a7a009d7cdf9a2996de610eed62781161a7bb5 (patch)
treed2e83c554c5e0558e2370a12e1481fd5542759dc
parent82f930622e350490aacfbee595d9a6e7309941f2 (diff)
downloadfreebsd-ports-gnome-d0a7a009d7cdf9a2996de610eed62781161a7bb5.tar.gz
freebsd-ports-gnome-d0a7a009d7cdf9a2996de610eed62781161a7bb5.tar.zst
freebsd-ports-gnome-d0a7a009d7cdf9a2996de610eed62781161a7bb5.zip
- Mark IGNORE on 9.0-9.2 due to build failures
- Remove trailing whitespace from pkg-descr - Bump PORTREVISION
-rw-r--r--dns/gdnsd2/Makefile9
-rw-r--r--dns/gdnsd2/pkg-descr10
2 files changed, 13 insertions, 6 deletions
diff --git a/dns/gdnsd2/Makefile b/dns/gdnsd2/Makefile
index dd6b7ef7bb87..a591de6a5f77 100644
--- a/dns/gdnsd2/Makefile
+++ b/dns/gdnsd2/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gdnsd
PORTVERSION= 2.1.0
+PORTREVISION= 1
CATEGORIES= dns
MASTER_SITES= https://github.com/blblack/gdnsd/releases/download/v${PORTVERSION}/ \
http://mirrors.rit.edu/zi/ \
@@ -42,6 +43,12 @@ URCU_DESC= Read-Copy-Update Support (Faster Zone Parsing)
URCU_CONFIGURE_WITH= urcu
URCU_LIB_DEPENDS= liburcu.so:${PORTSDIR}/sysutils/liburcu
+.include <bsd.port.pre.mk>
+
+.if (${OSVERSION} >= 900000 && ${OSVERSION} < 903000)
+IGNORE= you must be running FreeBSD 9.3 or higher
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|$${localstatedir}/lib/$${PACKAGE_NAME}|/var/db/${PORTNAME}|g' \
${WRKSRC}/configure
@@ -53,4 +60,4 @@ post-install:
${STAGEDIR}${PREFIX}/etc/gdnsd/zones \
${STAGEDIR}/var/run/gdnsd
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/dns/gdnsd2/pkg-descr b/dns/gdnsd2/pkg-descr
index c526ed29b6f1..571179658dd5 100644
--- a/dns/gdnsd2/pkg-descr
+++ b/dns/gdnsd2/pkg-descr
@@ -1,13 +1,13 @@
gdnsd is an Authoritative-only DNS server.
The initial g stands for Geographic, as gdnsd offers a plugin system for
-geographic (or other sorts of) balancing, redirection, and
-service-state-conscious failover. If you don't care about that feature,
-it's still quite good at being a very fast, lean, and resilient
+geographic (or other sorts of) balancing, redirection, and
+service-state-conscious failover. If you don't care about that feature,
+it's still quite good at being a very fast, lean, and resilient
authoritative-only server for static DNS data.
-gdnsd is written in C using libev and pthreads with a focus on high
-performance, low latency service. It does not offer any form of caching or
+gdnsd is written in C using libev and pthreads with a focus on high
+performance, low latency service. It does not offer any form of caching or
recursive service, and does not support DNSSEC.
WWW: https://github.com/blblack/gdnsd/