aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2007-06-19 01:58:50 +0800
committerdanfe <danfe@FreeBSD.org>2007-06-19 01:58:50 +0800
commitd0f3bb2e3a0d418a4a8daa9a834e86efb6048393 (patch)
treecef0609aaf238925f52214448a5d8c96beb39e64
parent9cbc44260a28a67a18642e5f8432fff134c11adc (diff)
downloadfreebsd-ports-gnome-d0f3bb2e3a0d418a4a8daa9a834e86efb6048393.tar.gz
freebsd-ports-gnome-d0f3bb2e3a0d418a4a8daa9a834e86efb6048393.tar.zst
freebsd-ports-gnome-d0f3bb2e3a0d418a4a8daa9a834e86efb6048393.zip
- Fix the build with latest GCC [1]
- Drop unneeded USE_X_PREFIX Reported by: pointyhat (logs) [1]
-rw-r--r--x11-toolkits/slingshot/Makefile1
-rw-r--r--x11-toolkits/slingshot/files/patch-gcc495
2 files changed, 95 insertions, 1 deletions
diff --git a/x11-toolkits/slingshot/Makefile b/x11-toolkits/slingshot/Makefile
index 76299006d4a3..ee1f48d3ea95 100644
--- a/x11-toolkits/slingshot/Makefile
+++ b/x11-toolkits/slingshot/Makefile
@@ -19,7 +19,6 @@ COMMENT= Supplemental Libraries to extend Xview
LIB_DEPENDS= xview.3:${PORTSDIR}/x11-toolkits/xview
WRKSRC= ${WRKDIR}/sspkg2.1
-USE_X_PREFIX= yes
USE_LDCONFIG= yes
USE_GMAKE= yes
MAKE_ENV= OPENWINHOME=${X11BASE}
diff --git a/x11-toolkits/slingshot/files/patch-gcc4 b/x11-toolkits/slingshot/files/patch-gcc4
new file mode 100644
index 000000000000..41f812cb7849
--- /dev/null
+++ b/x11-toolkits/slingshot/files/patch-gcc4
@@ -0,0 +1,95 @@
+--- src/canshell.c.orig Tue Oct 26 00:39:15 1993
++++ src/canshell.c Tue Jun 19 00:26:42 2007
+@@ -458,6 +458,8 @@
+ }
+
+
++static void rectobj_show_rects();
++
+ void
+ canvas_shell_event_proc(paint_window, event, arg)
+ Xv_window paint_window;
+@@ -468,7 +470,6 @@
+ Canvas_shell_info *csinfo;
+ Rectobj rectobj;
+ Rectobj_info *rinfo;
+- static void rectobj_show_rects();
+
+ canvas_shell = (Canvas_shell) xv_get(paint_window, CANVAS_PAINT_CANVAS_WINDOW);
+ csinfo = CANVAS_SHELL_PRIVATE(canvas_shell);
+--- src/drawimage.c.orig Tue Oct 26 00:40:12 1993
++++ src/drawimage.c Tue Jun 19 00:33:21 2007
+@@ -216,6 +216,8 @@
+ }
+
+
++static void render_image();
++
+ /*ARGSUSED*/
+ Pkg_private void
+ drawimage_paint_proc(drawimage, dpy, win, xrects)
+@@ -229,7 +231,6 @@
+ Drawimage_image *image;
+ GC gc;
+ int highlighted;
+- static void render_image();
+
+ gc = XCreateGC(dpy, win, 0, 0);
+
+--- src/rectobj.c.orig Fri Nov 5 07:51:06 1993
++++ src/rectobj.c Tue Jun 19 00:28:09 2007
+@@ -757,12 +757,13 @@
+ return XV_OK;
+ }
+
++static void *set_shared_info();
++
+ static void
+ rectobj_add_to_parent_list(rinfo)
+ Rectobj_info *rinfo;
+ {
+ Rectobj_info *parent_rinfo;
+- void *set_shared_info();
+
+ /* add adjustment for stacking order here */
+ if(rinfo->parent) {
+diff -ur work/sspkg2.1/src/tree.c foo/sspkg2.1/src/tree.c
+--- src/tree.c.orig Tue Oct 26 00:41:13 1993
++++ src/tree.c Tue Jun 19 00:47:27 2007
+@@ -392,21 +392,21 @@
+ }
+
+
+-void tree_set_geometries();
+-void tree_set_xy();
+-void tree_set_links();
+-void tree_move_links();
+-void tree_calc_positions();
+-void tree_attach_parent();
+-Polyline *tree_line();
+-void tree_layout();
+-void tree_layout_leaf();
+-int tree_join();
+-int tree_merge();
+-int tree_offset();
+-Polyline *tree_bridge();
+-void tree_calc_breadth_depth();
+-void tree_set_breadth_depth();
++static void tree_set_geometries();
++static void tree_set_xy();
++static void tree_set_links();
++static void tree_move_links();
++static void tree_calc_positions();
++static void tree_attach_parent();
++static Polyline *tree_line();
++static void tree_layout();
++static void tree_layout_leaf();
++static int tree_join();
++static int tree_merge();
++static int tree_offset();
++static Polyline *tree_bridge();
++static void tree_calc_breadth_depth();
++static void tree_set_breadth_depth();
+
+ /* These are copied from tree private to avoid passing them around */
+ static Listnode *line_heap_list;